primary node hangs during maint on down secondary node - Veritas Cluster Server

This is a discussion on primary node hangs during maint on down secondary node - Veritas Cluster Server ; Have 2 Sun 1125 db servers Solaris 8 running db edition for oracle 3.0. these are connected to (2) sun d1000 disk arrays in a cluster doing mirroring across both arrays. we offline the secondary node and properly shutdown the ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: primary node hangs during maint on down secondary node

  1. primary node hangs during maint on down secondary node


    Have 2 Sun 1125 db servers Solaris 8 running db edition for oracle 3.0.
    these are connected to (2) sun d1000 disk arrays in a cluster doing mirroring
    across both arrays.

    we offline the secondary node and properly shutdown the server, exits cluster
    normally. primary node functions normally.

    Power down secondary node and perform maint which inculdes removing SCSI
    cables to disk arrays.

    Shortly after primary node locks up, can ping but can not telnet
    console is locked have to power cycle.

    Same problem repeated in reverse when we did maint on primary node.

    Doe sdisconnect the SCSI cause this????


  2. Re: primary node hangs during maint on down secondary node



    Yes. When you removed the cables from one of the nodes, you removed termination.
    If the bus was not quiescent (idle) at the time, active IO would hang.


    Such maintenance should have offlined any active service groups using the
    affected D1000s, thereby idling both SCSI buses. Then you could substitute
    the cable between D1000 and the node marked for maintenance with a terminator
    placed on the port of D1000. You could have then safely onlined the service
    group on the other node while proceeding with the maintenance.

    -Bryan.

    "tom kearney" wrote:
    >
    >Have 2 Sun 1125 db servers Solaris 8 running db edition for oracle 3.0.
    >these are connected to (2) sun d1000 disk arrays in a cluster doing mirroring
    >across both arrays.
    >
    >we offline the secondary node and properly shutdown the server, exits cluster
    >normally. primary node functions normally.
    >
    >Power down secondary node and perform maint which inculdes removing SCSI
    >cables to disk arrays.
    >
    >Shortly after primary node locks up, can ping but can not telnet
    >console is locked have to power cycle.
    >
    >Same problem repeated in reverse when we did maint on primary node.
    >
    >Doe sdisconnect the SCSI cause this????
    >



+ Reply to Thread