Oracle Agent failing - Veritas Cluster Server

This is a discussion on Oracle Agent failing - Veritas Cluster Server ; Does anyone have any tips/hints for setting up Oracle under VCS control? Veritas documentation seems to be pretty lacking when it comes to setting up Oracle under VCS control. I have Solaris 2.6, VCS 112 and Oracle 806. I can ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Oracle Agent failing

  1. Oracle Agent failing


    Does anyone have any tips/hints for setting up Oracle under VCS control?
    Veritas documentation seems to be pretty lacking when it comes to setting
    up Oracle under VCS control. I have Solaris 2.6, VCS 112 and Oracle 806.
    I can bring up the Oracle database successfully manually but it fails every
    time when I try it under VCS control. I have found (so far) nothing wrong
    with the main.cf (the Oracle resource is pretty straight forward; not too
    many places to make a mistake).
    The log file (/var/VRTSvcs/log/engine.log_a) doesn't tell me much. It says
    that the Oracle agent started successfully and then a few minutes later,
    the log file will report that "Agent Oracle agent has not sent a startup
    message since"... yada...yada...yada...
    Also, could use some good troubleshooting techniques.

  2. Re: Oracle Agent failing


    OK, so I'm not as smart as I thought I was. I actually had everything set
    up correctly except for one thing: the wrong version of the Oracle extension
    was installed (duh). I removed the old version (1.0.2) and installed the
    latest version (1.1). After that everything worked perfectly.

    Thanks to Jerry for providing some troubleshooting hints:
    "Usually Oracle fails to come up because:
    The timeouts are too short
    The disks don't get mounted properly
    There is a problem with the ip-aliases
    There is a problem with TNSNAMES.ora
    Oracle's Unix home is on the system disk rather than the shared disk.
    Oracle's home is the same for each instance of Oracle.
    There is a problem with init.ora."


    "Brad Leak" wrote:
    >
    >Does anyone have any tips/hints for setting up Oracle under VCS control?
    >Veritas documentation seems to be pretty lacking when it comes to setting
    >up Oracle under VCS control. I have Solaris 2.6, VCS 112 and Oracle 806.
    > I can bring up the Oracle database successfully manually but it fails every
    >time when I try it under VCS control. I have found (so far) nothing wrong
    >with the main.cf (the Oracle resource is pretty straight forward; not too
    >many places to make a mistake).
    >The log file (/var/VRTSvcs/log/engine.log_a) doesn't tell me much. It says
    >that the Oracle agent started successfully and then a few minutes later,
    >the log file will report that "Agent Oracle agent has not sent a startup
    >message since"... yada...yada...yada...
    >Also, could use some good troubleshooting techniques.



+ Reply to Thread