I just installed BE 9.X for the first time. I see it loads some SQL database
version 8.00.760. Should this be updated with the latest Microsoft Security
updates to avoid hacks? What patch do I need?

Thanks Ed