I am running a Windows 2k server with Bent 8.6 and Exchange 2000. We are
currently in Windows 2000 k native mode but still have one Exchange 5.5
server up. Which version of Outlook do I need to install on the server for
Exchange?

Thanks,

Jackie