Incomplete SQL 7 database restore - Help needed - Veritas Backup Exec

This is a discussion on Incomplete SQL 7 database restore - Help needed - Veritas Backup Exec ; In trying to learn how to restore a SQL Server 7.0 database useing BE 8.5 (rev 3571) on my NT 4.0 (sp6a), I have a problem. When the restore is complete, I go into SQL Enterprise manager and the database ...

+ Reply to Thread
Results 1 to 5 of 5

Thread: Incomplete SQL 7 database restore - Help needed

  1. Incomplete SQL 7 database restore - Help needed


    In trying to learn how to restore a SQL Server 7.0 database
    useing BE 8.5 (rev 3571) on my NT 4.0 (sp6a), I have a problem.

    When the restore is complete, I go into SQL Enterprise manager
    and the database I restored has "(Loading)" following the
    database name. If I try to access the database (using Enterprise
    manager) I get the message "An error occured while trying to
    access the database information".

    What am I doing wrong? When I did the backup using the BE SQL
    Agent, the backup log indicated that the backup went correctly.

    Any and all help would be greatly appreciated>
    Russ Alltucker
    Calif. Dept. of Toxic Substances Control
    Sacramento, Ca.


  2. Re: Incomplete SQL 7 database restore - Help needed

    If it is just the database that you are restoring, check Recover Database on
    the Restore Job Properties. You will have to run the restore again and
    using the Replace option. Note that once you run a restore with recovery,
    you cannot apply any further backups of type differential or transaction
    log.

    Alex

    "Russ Alltucker" wrote in message
    news:3aafb32c$1@hronntp01....
    >
    > In trying to learn how to restore a SQL Server 7.0 database
    > useing BE 8.5 (rev 3571) on my NT 4.0 (sp6a), I have a problem.
    >
    > When the restore is complete, I go into SQL Enterprise manager
    > and the database I restored has "(Loading)" following the
    > database name. If I try to access the database (using Enterprise
    > manager) I get the message "An error occured while trying to
    > access the database information".
    >
    > What am I doing wrong? When I did the backup using the BE SQL
    > Agent, the backup log indicated that the backup went correctly.
    >
    > Any and all help would be greatly appreciated>
    > Russ Alltucker
    > Calif. Dept. of Toxic Substances Control
    > Sacramento, Ca.
    >




  3. Re: Incomplete SQL 7 database restore - Help needed

    To avoid a complete restore with the Recover options checked see
    http://seer.support.veritas.com/docs/191449.htm

    Russ Alltucker wrote:

    > In trying to learn how to restore a SQL Server 7.0 database
    > useing BE 8.5 (rev 3571) on my NT 4.0 (sp6a), I have a problem.
    >
    > When the restore is complete, I go into SQL Enterprise manager
    > and the database I restored has "(Loading)" following the
    > database name. If I try to access the database (using Enterprise
    > manager) I get the message "An error occured while trying to
    > access the database information".
    >
    > What am I doing wrong? When I did the backup using the BE SQL
    > Agent, the backup log indicated that the backup went correctly.
    >
    > Any and all help would be greatly appreciated>
    > Russ Alltucker
    > Calif. Dept. of Toxic Substances Control
    > Sacramento, Ca.



  4. Re: Incomplete SQL 7 database restore - Help needed

    To avoid a complete restore with the Recover options checked see
    http://seer.support.veritas.com/docs/191449.htm

    Alex Moore wrote:

    > If it is just the database that you are restoring, check Recover Database on
    > the Restore Job Properties. You will have to run the restore again and
    > using the Replace option. Note that once you run a restore with recovery,
    > you cannot apply any further backups of type differential or transaction
    > log.
    >
    > Alex
    >
    > "Russ Alltucker" wrote in message
    > news:3aafb32c$1@hronntp01....
    > >
    > > In trying to learn how to restore a SQL Server 7.0 database
    > > useing BE 8.5 (rev 3571) on my NT 4.0 (sp6a), I have a problem.
    > >
    > > When the restore is complete, I go into SQL Enterprise manager
    > > and the database I restored has "(Loading)" following the
    > > database name. If I try to access the database (using Enterprise
    > > manager) I get the message "An error occured while trying to
    > > access the database information".
    > >
    > > What am I doing wrong? When I did the backup using the BE SQL
    > > Agent, the backup log indicated that the backup went correctly.
    > >
    > > Any and all help would be greatly appreciated>
    > > Russ Alltucker
    > > Calif. Dept. of Toxic Substances Control
    > > Sacramento, Ca.
    > >



  5. Re: Incomplete SQL 7 database restore - Help needed

    Thanks Ken. I have not used that option, but it may come in handy some day
    if I forget the recovery option on the last restore. Alex

    "Ken Putnam" wrote in message
    news:3AB00F50.94906C46@usa.net...
    > To avoid a complete restore with the Recover options checked see
    > http://seer.support.veritas.com/docs/191449.htm
    >
    > Alex Moore wrote:
    >
    > > If it is just the database that you are restoring, check Recover

    Database on
    > > the Restore Job Properties. You will have to run the restore again and
    > > using the Replace option. Note that once you run a restore with

    recovery,
    > > you cannot apply any further backups of type differential or transaction
    > > log.
    > >
    > > Alex
    > >
    > > "Russ Alltucker" wrote in message
    > > news:3aafb32c$1@hronntp01....
    > > >
    > > > In trying to learn how to restore a SQL Server 7.0 database
    > > > useing BE 8.5 (rev 3571) on my NT 4.0 (sp6a), I have a problem.
    > > >
    > > > When the restore is complete, I go into SQL Enterprise manager
    > > > and the database I restored has "(Loading)" following the
    > > > database name. If I try to access the database (using Enterprise
    > > > manager) I get the message "An error occured while trying to
    > > > access the database information".
    > > >
    > > > What am I doing wrong? When I did the backup using the BE SQL
    > > > Agent, the backup log indicated that the backup went correctly.
    > > >
    > > > Any and all help would be greatly appreciated>
    > > > Russ Alltucker
    > > > Calif. Dept. of Toxic Substances Control
    > > > Sacramento, Ca.
    > > >

    >




+ Reply to Thread