W2K DCOM got error "Class not registered" - Veritas Backup Exec

This is a discussion on W2K DCOM got error "Class not registered" - Veritas Backup Exec ; Hi I have the following entry in the eventlog: Event Type: Error Event Source: DCOM Event Category: None Event ID: 10006 Date: 19.09.2000 Time: 23:24:28 User: KAESTLIBAU\Backup Computer: SRV-01 Description: DCOM got error "Class not registered " from the computer ...

+ Reply to Thread
Results 1 to 8 of 8

Thread: W2K DCOM got error "Class not registered"

  1. W2K DCOM got error "Class not registered"

    Hi

    I have the following entry in the eventlog:

    Event Type: Error
    Event Source: DCOM
    Event Category: None
    Event ID: 10006
    Date: 19.09.2000
    Time: 23:24:28
    User: KAESTLIBAU\Backup
    Computer: SRV-01
    Description:
    DCOM got error "Class not registered " from the computer SRV-02 when
    attempting to activate the server:
    {D99E6E73-FC88-11D0-B498-00A0C90312F3}

    The server hangs up after that, the message surely comes from the
    veritas-backup 8.0.

    Any idea how to fix that?

    Thanks



  2. Re: W2K DCOM got error "Class not registered"

    Let me know if you find anything, I have the same issue, but no hang ups,
    just the error. I have asked Veritas about this last week with no answer
    yet, if I get something I will post it.


    "a" wrote in message news:39c8653a@hronntp01....
    > Hi
    >
    > I have the following entry in the eventlog:
    >
    > Event Type: Error
    > Event Source: DCOM
    > Event Category: None
    > Event ID: 10006
    > Date: 19.09.2000
    > Time: 23:24:28
    > User: KAESTLIBAU\Backup
    > Computer: SRV-01
    > Description:
    > DCOM got error "Class not registered " from the computer SRV-02 when
    > attempting to activate the server:
    > {D99E6E73-FC88-11D0-B498-00A0C90312F3}
    >
    > The server hangs up after that, the message surely comes from the
    > veritas-backup 8.0.
    >
    > Any idea how to fix that?
    >
    > Thanks
    >
    >




  3. Re: W2K DCOM got error "Class not registered"

    Hello, I have the same error, when BE Server tries to backup the System
    State in another Domain Controller Server with NTAA I think that the
    instalation of NTAA or another programa blocks the access to the System
    State.

    I´m also waiting for a solution. Please contact with me if you find
    something.
    Thanks.
    ..
    "a" escribió en el mensaje news:39c8653a@hronntp01....
    > Hi
    >
    > I have the following entry in the eventlog:
    >
    > Event Type: Error
    > Event Source: DCOM
    > Event Category: None
    > Event ID: 10006
    > Date: 19.09.2000
    > Time: 23:24:28
    > User: KAESTLIBAU\Backup
    > Computer: SRV-01
    > Description:
    > DCOM got error "Class not registered " from the computer SRV-02 when
    > attempting to activate the server:
    > {D99E6E73-FC88-11D0-B498-00A0C90312F3}
    >
    > The server hangs up after that, the message surely comes from the
    > veritas-backup 8.0.
    >
    > Any idea how to fix that?
    >
    > Thanks
    >
    >




  4. Re: W2K DCOM got error "Class not registered"


    I also had this same problem and asked Veritas about it. Here is their answer:

    Hi Tim,
    The DCOM error will happen only when the Certificate Server is NOT online.
    Microsoft is aware of this issue.

    Lee Wickersham
    Sr. Product Support Specialist II


    "Matt Alter" wrote:
    >Let me know if you find anything, I have the same issue, but no hang ups,
    >just the error. I have asked Veritas about this last week with no answer
    >yet, if I get something I will post it.



  5. Re: W2K DCOM got error "Class not registered"


    Found this on Microsoft Support which matched the DCOM error message I am
    getting in my eventlog.

    Certification Authority Does Not Start and Returns Error Code 0x80004015


    --------------------------------------------------------------------------------
    The information in this article applies to:

    Microsoft Windows 2000 Advanced Server
    Microsoft Windows 2000 Server
    Microsoft Windows 2000 Datacenter Server

    --------------------------------------------------------------------------------
    IMPORTANT: This article contains information about editing the registry.
    Before you edit the registry, make sure you understand how to restore it
    if a problem occurs. For information about how to do this, view the "Restoring
    the Registry" Help topic in Regedit.exe or the "Restoring a Registry Key"
    Help topic in Regedt32.exe.


    SYMPTOMS
    The Windows 2000 Certification Authority service may not start and may return
    error code 0x80004015 ("The class is configured to run as a security ID different
    from the caller").



    CAUSE
    This behavior can occur if the registration for the Distributed Component
    Object Model (DCOM) interface in either of the following registry locations
    contains both RunAs and LocalService entries:

    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AppId\{D99E6E7 4-FC88-11D0-B498-00A0C90312F3}


    -or-

    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AppId\{D99E6E7 3-FC88-11D0-B498-00A0C90312F3}

    When this occurs, the Certification Authority service does not start because
    it does not expect both values to be set.



    RESOLUTION
    WARNING: Using Registry Editor incorrectly can cause serious problems that
    may require you to reinstall your operating system. Microsoft cannot guarantee
    that problems resulting from the incorrect use of Registry Editor can be
    solved. Use Registry Editor at your own risk.

    For information about how to edit the registry, view the "Changing Keys and
    Values" Help topic in Registry Editor (Regedit.exe) or the "Add and Delete
    Information in the Registry" and "Edit Registry Data" Help topics in Regedt32.exe.
    Note that you should back up the registry before you edit it. If you are
    running Windows NT, you should also update your Emergency Repair Disk (ERD).

    To resolve this issue, remove the RunAs entries under both of the following
    registry locations:

    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AppId\{D99E6E7 4-FC88-11D0-B498-00A0C90312F3}


    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AppId\{D99E6E7 3-FC88-11D0-B498-00A0C90312F3}

    Make sure that the LocalService entry exists under the following registry
    locations with a data value of CertSvc:
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AppId\{D99E6E7 4-FC88-11D0-B498-00A0C90312F3}


    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AppId\{D99E6E7 3-FC88-11D0-B498-00A0C90312F3}




    STATUS
    Microsoft has confirmed this to be a problem in the Microsoft products listed
    at the beginning of this article.

    Additional query words:

    Keywords : kbenv kberrmsg
    Version : WINDOWS:2000
    Platform : WINDOWS
    Issue type : kbprb
    Technology :



    Last Reviewed: December 29, 1999
    © 2000 Microsoft Corporation. All rights reserved. Terms of Use.




    "Tim Fink" wrote:
    >
    >I also had this same problem and asked Veritas about it. Here is their answer:
    >
    >Hi Tim,
    >The DCOM error will happen only when the Certificate Server is NOT online.
    >Microsoft is aware of this issue.
    >
    >Lee Wickersham
    >Sr. Product Support Specialist II
    >
    >
    >"Matt Alter" wrote:
    >>Let me know if you find anything, I have the same issue, but no hang ups,
    >>just the error. I have asked Veritas about this last week with no answer
    >>yet, if I get something I will post it.

    >



  6. Re: W2K DCOM got error "Class not registered"


    Has anybody found a solution for this?

    "Andres Rios" wrote:
    >Hello, I have the same error, when BE Server tries to backup the System
    >State in another Domain Controller Server with NTAA I think that the
    >instalation of NTAA or another programa blocks the access to the System
    >State.
    >
    >I´m also waiting for a solution. Please contact with me if you find
    >something.
    >Thanks.
    >..
    >"a" escribió en el mensaje news:39c8653a@hronntp01....
    >> Hi
    >>
    >> I have the following entry in the eventlog:
    >>
    >> Event Type: Error
    >> Event Source: DCOM
    >> Event Category: None
    >> Event ID: 10006
    >> Date: 19.09.2000
    >> Time: 23:24:28
    >> User: KAESTLIBAU\Backup
    >> Computer: SRV-01
    >> Description:
    >> DCOM got error "Class not registered " from the computer SRV-02 when
    >> attempting to activate the server:
    >> {D99E6E73-FC88-11D0-B498-00A0C90312F3}
    >>
    >> The server hangs up after that, the message surely comes from the
    >> veritas-backup 8.0.
    >>
    >> Any idea how to fix that?
    >>
    >> Thanks
    >>
    >>

    >
    >



  7. Re: W2K DCOM got error "Class not registered"


    After reading this posting a while back:

    Hi Tim,
    The DCOM error will happen only when the Certificate Server is NOT online.
    Microsoft is aware of this issue.

    Lee Wickersham
    Sr. Product Support Specialist II

    I installed the certificate server on one of my servers and
    ran a backup with system state selected, and the DCOM error
    did not show up in the event log. As a test I removed the cert.
    server and re-ran the backup and the DCOM error appeared again in
    the event log. I don't understand how intalling certificate
    server remedies this problem, but it does. Has anyone else tried
    this? Do you have to install certificate server on every node
    you are backing up? This is frustratring!
    Greg


    "Sam Awad" wrote:
    >
    >Has anybody found a solution for this?
    >
    >"Andres Rios" wrote:
    >>Hello, I have the same error, when BE Server tries to backup the System
    >>State in another Domain Controller Server with NTAA I think that the
    >>instalation of NTAA or another programa blocks the access to the System
    >>State.
    >>
    >>I´m also waiting for a solution. Please contact with me if you find
    >>something.
    >>Thanks.
    >>..
    >>"a" escribió en el mensaje news:39c8653a@hronntp01....
    >>> Hi
    >>>
    >>> I have the following entry in the eventlog:
    >>>
    >>> Event Type: Error
    >>> Event Source: DCOM
    >>> Event Category: None
    >>> Event ID: 10006
    >>> Date: 19.09.2000
    >>> Time: 23:24:28
    >>> User: KAESTLIBAU\Backup
    >>> Computer: SRV-01
    >>> Description:
    >>> DCOM got error "Class not registered " from the computer SRV-02 when
    >>> attempting to activate the server:
    >>> {D99E6E73-FC88-11D0-B498-00A0C90312F3}
    >>>
    >>> The server hangs up after that, the message surely comes from the
    >>> veritas-backup 8.0.
    >>>
    >>> Any idea how to fix that?
    >>>
    >>> Thanks
    >>>
    >>>

    >>
    >>

    >



  8. Re: W2K DCOM got error "Class not registered"

    It is my understanding that the System State can contain information about
    Certificate Server if the server is a domain controller and has Certificate
    Server installed. With that in mind I would speculate that Backup Exec is
    trying to backup the System State of the remote machine and there is no
    Certificate Server installed so it cannot communicate with the Certificate
    Server in order to back it up. In other words, no Certificate server data
    exists in the System State. Maybe the Veritas remote agent is not smart
    enough the check the existence and just tries to back up the certificate
    data. Thus a communication error occurs when it can't. On my server it
    only shows up as an error in the event log and the backup continues on with
    success. I'm not going to worry about it at this point.


    "greg may" wrote in message
    news:3a26e533$1@hronntp01....
    >
    > After reading this posting a while back:
    >
    > Hi Tim,
    > The DCOM error will happen only when the Certificate Server is NOT online.
    > Microsoft is aware of this issue.
    >
    > Lee Wickersham
    > Sr. Product Support Specialist II
    >
    > I installed the certificate server on one of my servers and
    > ran a backup with system state selected, and the DCOM error
    > did not show up in the event log. As a test I removed the cert.
    > server and re-ran the backup and the DCOM error appeared again in
    > the event log. I don't understand how intalling certificate
    > server remedies this problem, but it does. Has anyone else tried
    > this? Do you have to install certificate server on every node
    > you are backing up? This is frustratring!
    > Greg
    >
    >
    > "Sam Awad" wrote:
    > >
    > >Has anybody found a solution for this?
    > >
    > >"Andres Rios" wrote:
    > >>Hello, I have the same error, when BE Server tries to backup the System
    > >>State in another Domain Controller Server with NTAA I think that the
    > >>instalation of NTAA or another programa blocks the access to the System
    > >>State.
    > >>
    > >>I´m also waiting for a solution. Please contact with me if you find
    > >>something.
    > >>Thanks.
    > >>..
    > >>"a" escribió en el mensaje news:39c8653a@hronntp01....
    > >>> Hi
    > >>>
    > >>> I have the following entry in the eventlog:
    > >>>
    > >>> Event Type: Error
    > >>> Event Source: DCOM
    > >>> Event Category: None
    > >>> Event ID: 10006
    > >>> Date: 19.09.2000
    > >>> Time: 23:24:28
    > >>> User: KAESTLIBAU\Backup
    > >>> Computer: SRV-01
    > >>> Description:
    > >>> DCOM got error "Class not registered " from the computer SRV-02 when
    > >>> attempting to activate the server:
    > >>> {D99E6E73-FC88-11D0-B498-00A0C90312F3}
    > >>>
    > >>> The server hangs up after that, the message surely comes from the
    > >>> veritas-backup 8.0.
    > >>>
    > >>> Any idea how to fix that?
    > >>>
    > >>> Thanks
    > >>>
    > >>>
    > >>
    > >>

    > >

    >




+ Reply to Thread