Ubuntu mounting MMC ro - Ubuntu

This is a discussion on Ubuntu mounting MMC ro - Ubuntu ; Hi all, I have a Multi Media Card reader on my Dell XPS with pre installed Ubuntu (+Gnome). And I have a MMC (SD, 4 GB) on my Treo. The card gets recognized by the reader and the OS and ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: Ubuntu mounting MMC ro

  1. Ubuntu mounting MMC ro

    Hi all,

    I have a Multi Media Card reader on my Dell XPS with pre installed
    Ubuntu (+Gnome). And I have a MMC (SD, 4 GB) on my Treo. The card gets
    recognized by the reader and the OS and auto mounted - but in ro mode.

    I've tried a "mount -o remount,rw /media/disk" to no avail.

    I've tried editing the fstab to tell the system to mount the disk rw
    (using the mtab settings, and again using own settings), but the system
    mounted the card on a new mount, ignoring the settings of my fstab.

    I tried setting up the policy for mmc mounts so they are mounted rw -
    not accepted. I tried using another MMC card reader thru USB - same
    issues.

    While the card is mounted, a "mount" will show the card as being rw, but
    in fact, neither thru cli nor thru Nautilus I'm able to do anything rw
    to the card.

    The card can be read and written by the Treo and by a winXP 64 system
    where I tried. All steps in Ubuntu done thru sudo, BTW.

    Does anyone have an idea how I can convince Ubuntu to mount the MMC rw?
    I'm all out of them.

    TIA
    Aleks

  2. Re: Ubuntu mounting MMC ro

    Aleks A.-Lessmann schreef:
    > Hi all,
    >
    > I have a Multi Media Card reader on my Dell XPS with pre installed
    > Ubuntu (+Gnome). And I have a MMC (SD, 4 GB) on my Treo. The card gets
    > recognized by the reader and the OS and auto mounted - but in ro mode.
    >
    > I've tried a "mount -o remount,rw /media/disk" to no avail.
    >
    > I've tried editing the fstab to tell the system to mount the disk rw
    > (using the mtab settings, and again using own settings), but the system
    > mounted the card on a new mount, ignoring the settings of my fstab.
    >
    > I tried setting up the policy for mmc mounts so they are mounted rw -
    > not accepted. I tried using another MMC card reader thru USB - same
    > issues.
    >
    > While the card is mounted, a "mount" will show the card as being rw, but
    > in fact, neither thru cli nor thru Nautilus I'm able to do anything rw
    > to the card.
    >
    > The card can be read and written by the Treo and by a winXP 64 system
    > where I tried. All steps in Ubuntu done thru sudo, BTW.
    >
    > Does anyone have an idea how I can convince Ubuntu to mount the MMC rw?
    > I'm all out of them.
    >
    > TIA
    > Aleks


    It might have to do with your rights, make sure you (as a user) are in
    the list of processes allowed to access the card.

  3. Re: Ubuntu mounting MMC ro

    On Sat, 18 Oct 2008 10:40:12 +0200, Aleks A.-Lessmann wrote:

    > Hi all,
    >
    > I have a Multi Media Card reader on my Dell XPS with pre installed
    > Ubuntu (+Gnome). And I have a MMC (SD, 4 GB) on my Treo. The card gets
    > recognized by the reader and the OS and auto mounted - but in ro mode.
    >
    >


    Make sure you have a valid partition on the card..


    --
    still slacking ...

+ Reply to Thread