Ubuntu mounting MMC ro only - Ubuntu

This is a discussion on Ubuntu mounting MMC ro only - Ubuntu ; Hi all, I have a Multi Media Card reader on my Dell XPS with pre installed Ubuntu (+Gnome). And I have a MMC (SD, 4 GB) on my Treo. The card gets recognized by the reader and the OS and ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Ubuntu mounting MMC ro only

  1. Ubuntu mounting MMC ro only

    Hi all,

    I have a Multi Media Card reader on my Dell XPS with pre installed
    Ubuntu (+Gnome). And I have a MMC (SD, 4 GB) on my Treo. The card gets
    recognized by the reader and the OS and auto mounted - but in ro mode.

    I've tried a "mount -o remount,rw /media/disk" to no avail.

    I've tried editing the fstab to tell the system to mount the disk rw
    (using the mtab settings, and again using own settings), but the system
    mounted the card on a new mount, ignoring the settings of my fstab.

    I tried setting up the policy for mmc mounts so they are mounted rw -
    not accepted. I tried using another MMC card reader thru USB - same
    issues.

    While the card is mounted, a "mount" will show the card as being rw, but
    in fact, neither thru cli nor thru Nautilus I'm able to do anything rw
    to the card.

    The card can be read and written by the Treo and by a windows system
    where I tried it.

    Does anyone have an idea how I can convince Ubuntu to mount the MMC rw?
    I'm all out of them.

    TIA
    Aleks

  2. Re: Ubuntu mounting MMC ro only

    * Aleks A.-Lessmann :
    > Hi all,
    >
    > I have a Multi Media Card reader on my Dell XPS with pre installed
    > Ubuntu (+Gnome). And I have a MMC (SD, 4 GB) on my Treo. The card gets
    > recognized by the reader and the OS and auto mounted - but in ro mode.
    >
    > I've tried a "mount -o remount,rw /media/disk" to no avail.
    >
    > I've tried editing the fstab to tell the system to mount the disk rw
    > (using the mtab settings, and again using own settings), but the system
    > mounted the card on a new mount, ignoring the settings of my fstab.
    >
    > I tried setting up the policy for mmc mounts so they are mounted rw -
    > not accepted. I tried using another MMC card reader thru USB - same
    > issues.
    >
    > While the card is mounted, a "mount" will show the card as being rw, but
    > in fact, neither thru cli nor thru Nautilus I'm able to do anything rw
    > to the card.


    This sounds like a permissions issue. My guess would be that your
    memory card contians a FAT filesystem. The owner and group of files as
    well as the permissions mask is determined at the time the filesystem is
    mounted. Look at the owner, group, and permissions of the files and see
    whether those would restrict your user's access to them. Then check the
    mount options for uid, gid, and *mask options which affect such
    permissions. See the options for fat section of mount(8) for details.

    Also check whether your user is the plugdev group which I think has an
    effect on the policy for removeable media.

    > The card can be read and written by the Treo and by a windows system
    > where I tried it.
    >
    > Does anyone have an idea how I can convince Ubuntu to mount the MMC rw?
    > I'm all out of them.
    >
    > TIA
    > Aleks



    --
    James Michael Fultz
    Remove this part when replying ^^^^^^^^

+ Reply to Thread