The following packages have been kept back: why? - Ubuntu

This is a discussion on The following packages have been kept back: why? - Ubuntu ; Lately when I do a apt-get update & upgrade I get the following message: The following packages have been kept back: linux-generic linux-headers-generic linux-image-generic linux-restricted-modules-generic My question is why is it doing that and is there a way to force ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: The following packages have been kept back: why?

  1. The following packages have been kept back: why?

    Lately when I do a apt-get update & upgrade I get the following message:

    The following packages have been kept back:
    linux-generic linux-headers-generic linux-image-generic
    linux-restricted-modules-generic

    My question is why is it doing that and is there a way to force it to
    upgrade those packages?

    -HP

  2. Re: The following packages have been kept back: why?

    HP Garcia writes:

    > Lately when I do a apt-get update & upgrade I get the following message:
    >
    > The following packages have been kept back:
    > linux-generic linux-headers-generic linux-image-generic
    > linux-restricted-modules-generic
    >
    > My question is why is it doing that and is there a way to force it to
    > upgrade those packages?


    You did a `apt-get upgrade'. It should be `apt-get dist-upgrade'.

    --
    I like the idea of 256 bits, though: 32 for the (Unicode) character leaves
    room for 224 Bucky bits, which ought to be enough for anyone.
    -- Roland Hutchinson, in alt.folklore.computers

+ Reply to Thread