https://bugzilla.samba.org/show_bug.cgi?id=2628


hmijail@gmail.com changed:

What |Removed |Added
----------------------------------------------------------------------------
CC| |hmijail@gmail.com




------- Comment #12 from hmijail@gmail.com 2008-05-01 06:45 CST -------
Bitten here by what seems to be the same bug.
Using rsync 3.0.2 in both Windows 2003 (cwRsync, sender, remote) and OS X
10.5.2 (receiver, local).
Command line in OS X: rsync -avhiz --delete --stats -P -v -v
winhost:/remotedir/ localdir

But I have managed to work around the problem by specifying just one or two
files in the remote filespec. That is, specifying for example
winhost:/remotedir/file{1,2}.rar. If I made that *.rar it won't work either.
(the remote dir also contains files not covered with the *.rar).

Problem seems independent of using -v, -vv and -vvv. When using the -vvv, the
last line *sometimes* is "generate_files phase=1", but that seems to depend on
the number of files asked for. With 3 to say 10 files, the last line usually is
something like "match at 16356128 last_match=16356128 j=1633 len=10016 n=0", or
rsync's progress display. The larger the number of files, the more probable to
get the "generate_files" the line. With 10 files it usually is the last one
displayed.

Some more context:
--the connection uses cygwin's opensshd
--it is running over openvpn
--when rsync hangs/deadlocks and I ctl-C it, the rsync process in the Windows
host remains there, doing nothing. It will not be killed by a normal cygwin
kill $pid, but they do die with a kill -SIGKILL $pid. In contrast, when I ctl-C
the local rsync while it is working OK, the Windows process goes away.
--while rsync is hung/deadlocked, if I kill -SIGKILL the remote windows
process, it disappears from Windows' task manager, but the local rsync progress
display shows a surge of activity which lasts for about 20 seconds, together
with about 2 MBytes worth of received network traffic (so maxing out my 100KBps
line). After that, the local rsync complains about connection unexpectedly
closed and exits.
--I can see no differences between using rsync 3.0.2 and 2.6.9 (cygwin's
official) in the Windows side.


--
Configure bugmail: https://bugzilla.samba.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug, or are watching the QA contact.
--
Please use reply-all for most replies to avoid omitting the mailing list.
To unsubscribe or change options: https://lists.samba.org/mailman/listinfo/rsync
Before posting, read: http://www.catb.org/~esr/faqs/smart-questions.html