--===============0788927935==
Content-Type: multipart/alternative;
boundary="----=_Part_15201_21483490.1209427507758"

------=_Part_15201_21483490.1209427507758
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

Hi All.

On Mac OS10.4, using rsync 3.0, it stops during a transfer.

I mount an SMB share, and then use the line:
sudo rsync -avhi --delete --stats --timeout=360 --progress
--log-file=/Volumes/backup/20080429/rsynclog.txt --exclude="*:*"
/Volumes/RAID_One /Volumes/backup/20080429

There's a few terabytes of data, and it never finishes a complete run.

It can stop at anywhere during the transfer, from 5mins, but usually a few
hours into it.

on the current issues and debugging section on the website, it mentions how
to debug a remote rsync, or daemon, but as far as i know, these dont apply
because i'm copying the data on the same machine.

See the error log below. Is there anywhere else i can check for errors?

Also, what's the characters mean in the logfile, such as:
>f..tpog.... RAID_One/data/file

8.39M 100% 4.12MB/s 0:00:01 (xfer#3478, to-check=1224/8633)

Any help much appreciated.
Andrew


Logfile:
2008/04/28 20:48:46 [3149] rsync: writefd_unbuffered failed to write 4 bytes
[sender]: Broken pipe (32)
2008/04/28 20:48:46 [3149] rsync: connection unexpectedly closed (735103
bytes received so far) [sender]
2008/04/28 20:48:46 [3149] rsync error: error in rsync protocol data stream
(code 12) at io.c(600) [sender=3.0.0]

------=_Part_15201_21483490.1209427507758
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

Hi All.

 

On Mac OS10.4, using rsync 3.0, it stops during a transfer.

 

I mount an SMB share, and then use the line:

sudo rsync -avhi --delete --stats --timeout=360 --progress --log-file=/Volumes/backup/20080429/rsynclog.txt  --exclude="*:*" /Volumes/RAID_One /Volumes/backup/20080429

 

There's a few terabytes of data, and it never finishes a complete run.

 

It can stop at anywhere during the transfer, from 5mins, but usually a few hours into it.

 

on the current issues and debugging section on the website, it mentions how to debug a remote rsync, or daemon, but as far as i know, these dont apply because i'm copying the data on the same machine.

 

See the error log below. Is there anywhere else i can check for errors?

 

Also, what's the characters mean in the logfile, such as:

>f..tpog.... RAID_One/data/file
       8.39M 100%    4.12MB/s    0:00:01 (xfer#3478, to-check=1224/8633)

 

Any help much appreciated.

Andrew

 

 

Logfile:

2008/04/28 20:48:46 [3149] rsync: writefd_unbuffered failed to write 4 bytes [sender]: Broken pipe (32)
2008/04/28 20:48:46 [3149] rsync: connection unexpectedly closed (735103 bytes received so far) [sender]

2008/04/28 20:48:46 [3149] rsync error: error in rsync protocol data stream (code 12) at io.c(600) [sender=3.0.0]


------=_Part_15201_21483490.1209427507758--

--===============0788927935==
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

--
Please use reply-all for most replies to avoid omitting the mailing list.
To unsubscribe or change options: https://lists.samba.org/mailman/listinfo/rsync
Before posting, read: http://www.catb.org/~esr/faqs/smart-questions.html
--===============0788927935==--