https://bugzilla.samba.org/show_bug.cgi?id=3175

Summary: devices and --link-dest don't seem to work together
Product: rsync
Version: 2.6.7
Platform: x86
OS/Version: Linux
Status: NEW
Severity: normal
Priority: P3
Component: core
AssignedTo: wayned@samba.org
ReportedBy: foner-rsync-bugzilla@media.mit.edu
QAContact: rsync-qa@samba.org
CC: foner-rsync-bugzilla@media.mit.edu


[I'm using the version from the 20051014 nightly snapshot, on Ubuntu Breezy
5.10, which is a Debian-based system, and using an ext3fs filesystem.]

It doesn't appear as if rsync correctly hard-links devices together. This came
up in the context of dirvish runs which happen to include some filesystem trees
of older versions of entire OS disks, so they've got /dev directories in them,
etc. dirvish is supposed to crosslink snapshots with each other (courtesy of
--link-dest), but it wasn't doing so for these files. And I can't get rsync to
do it when I invoke it manually, either---it just always creates the devices anew.

I'll either attach (if this bugzilla lets me) or add as a second comment (if it
doesn't) a transcript showing this behavior. (There are some pointless switches
such as -z in those transcripts because I'm trying to alter the dirvish
invocation of rsync as little as possible in testing.) This seems like a bug,
since I have no problems manually hardlinking these files together with ln -f,
and it's annoying since it clutters up my logs with thousands of spurious
transfers (even though dev files are small, they shouldn't be getting
redundantly transferred night after night because of this).

Thanks!

--
Configure bugmail: https://bugzilla.samba.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug, or are watching the QA contact.
--
To unsubscribe or change options: https://lists.samba.org/mailman/listinfo/rsync
Before posting, read: http://www.catb.org/~esr/faqs/smart-questions.html