https://bugzilla.samba.org/show_bug.cgi?id=3174

Summary: Patch for specifying zlib compression level
Product: rsync
Version: 2.6.7
Platform: All
OS/Version: All
Status: NEW
Severity: normal
Priority: P3
Component: core
AssignedTo: wayned@samba.org
ReportedBy: stix@stix.homeunix.net
QAContact: rsync-qa@samba.org


Attached is a patch against HEAD to enable an optional compression level when
using --compress. Tested on NetBSD, running against both same version and stock
2.6.3 on the remote end, over ssh.

This uses the "feature" that popt will ignore option arguments it isn't
requested to parse. eg. Older rsyncs will happily run with the option
"--compress=1".

Note, to support the syntax "--compress 1" (ie, space separated), a patch to
popt is required, available from
https://bugzilla.redhat.com/bugzilla...g.cgi?id=71147

--
Configure bugmail: https://bugzilla.samba.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug, or are watching the QA contact.
--
To unsubscribe or change options: https://lists.samba.org/mailman/listinfo/rsync
Before posting, read: http://www.catb.org/~esr/faqs/smart-questions.html