Re: Windows XP x64 probably has bug in IPv6 Stack relating to ICMPv6. - TCP-IP

This is a discussion on Re: Windows XP x64 probably has bug in IPv6 Stack relating to ICMPv6. - TCP-IP ; Situation is as follows: 1. Not a gui bug from my part. 2. ICMPv6 stats weren't updating because no gui code yet. 3. ICMPv6 reporter not receiving anything. 4. Ethereal is showing ICMPv6 error reports... but these are encapsulated inside ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: Re: Windows XP x64 probably has bug in IPv6 Stack relating to ICMPv6.

  1. Re: Windows XP x64 probably has bug in IPv6 Stack relating to ICMPv6.

    Situation is as follows:

    1. Not a gui bug from my part.
    2. ICMPv6 stats weren't updating because no gui code yet.
    3. ICMPv6 reporter not receiving anything.
    4. Ethereal is showing ICMPv6 error reports... but these are encapsulated
    inside IPv4 packets. (Tunneling ?!?)
    5. GUI bugs caused by stack/drivers ?

    I wonder if encapsulated has anything to do with it... later I test a
    simpler example/code to see if it can receive icmpv6's at all

    Bye,
    Skybuck.



  2. Re: Windows XP x64 probably has bug in IPv6 Stack relating to ICMPv6.

    Ok,

    I tried a simple icmpv6 receiver test...

    It can't receive the tunneling icmp errors.

    I have no idea how to receive those at the moment.

    Maybe Windows XP x64 doesn't support it or something...

    Bye,
    Skybuck.



  3. Re: Windows XP x64 probably has bug in IPv6 Stack relating to ICMPv6.

    Windows seems to have some issue's with this:

    http://support.microsoft.com/kb/944135

    "
    The recvfrom function stops responding when you use the sendto function in
    the IPv6 raw socket to send an ICMP packet and then use the recvfrom
    function to receive ICMP responses on a Windows Server 2003-based computer
    "

    (I am not sending any IPv6 raw stuff or so... just normal IPv6 stuff)

    Probably more buggies in there !

    Bye,
    Skybuck.



+ Reply to Thread