ping fails to link local address (IPv6) - TCP-IP

This is a discussion on ping fails to link local address (IPv6) - TCP-IP ; hi all, i have configured IPv6 on linux machine. i can see the link local address as an output for ifconfig, but when i try to ping to it i am getting an error "argument invalid" i sending the output ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: ping fails to link local address (IPv6)

  1. ping fails to link local address (IPv6)

    hi all,

    i have configured IPv6 on linux machine. i can see the link local
    address as an output for ifconfig, but when i try to ping to it i am
    getting an error "argument invalid"

    i sending the output of ifconfig and ping6 to loopback ipv6address
    which is successful and to link local address which is failing.

    output:
    =======

    [root@neo root]# ifconfig
    eth0 Link encap:Ethernet HWaddr 00:C0:A8:FF:CC:24
    inet addr:172.31.41.240 Bcast:172.31.41.255 Mask:
    255.255.255.0
    inet6 addr: fe80::2c0:a8ff:feff:cc24/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:22767830 errors:0 dropped:0 overruns:0 frame:0
    TX packets:353031 errors:0 dropped:0 overruns:0 carrier:5
    collisions:0 txqueuelen:100
    RX bytes:3722813269 (3550.3 Mb) TX bytes:262705354 (250.5
    Mb)
    Interrupt:5

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:1890 errors:0 dropped:0 overruns:0 frame:0
    TX packets:1890 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:166617 (162.7 Kb) TX bytes:166617 (162.7 Kb)

    [root@neo root]# ping6 ::1
    PING ::1(::1) 56 data bytes
    64 bytes from ::1: icmp_seq=1 ttl=64 time=0.033 ms
    64 bytes from ::1: icmp_seq=2 ttl=64 time=0.028 ms
    64 bytes from ::1: icmp_seq=3 ttl=64 time=0.019 ms

    [1]+ Stopped ping6 ::1
    [root@neo root]# ping6 fe80::2c0:a8ff:feff:cc24
    connect: Invalid argument
    [root@neo root]#


    thanks
    varma

  2. Re: ping fails to link local address (IPv6)

    varma wrote:

    > hi all,
    >
    > i have configured IPv6 on linux machine. i can see the link local
    > address as an output for ifconfig, but when i try to ping to it i am
    > getting an error "argument invalid"


    Yes, for link-local addresses you have to specify the interface you want to
    use. Try

    # ping6 -I eth0 fe80::2c0:a8ff:feff:cc24

    substitute eth0 with the interface you want to use.


+ Reply to Thread