I am trying to build the Cisco VPN driver on my openSUSE 11
installation. I am getting the following error message.

/usr/src/linux # make scripts/mod/modpost
gcc -m elf_i386 scripts/mod/modpost.c -o scripts/mod/modpost
cc1: error: unrecognized command line option "-m"
make: *** [scripts/mod/modpost] Error 1

It is using the following gcc version;

gcc --version
gcc (SUSE Linux) 4.3.1 20080507 (prerelease) [gcc-4_3-branch revision
135036]


The man page says the "-m" option should be "i386" with "elf_"
removed. However I have yet to find the kernel include file that sets
this link option.

Any ideas?

cj