openSuse 11.0 won't reboot - Suse

This is a discussion on openSuse 11.0 won't reboot - Suse ; I installed openSuse 11.0 on my friend's Dell Optiplex 330 (2.4 GHz Intel E2220 Core 2 Duo processor, 2 GB RAM) and, while it shuts down Ok from the Log Out menu, it won't reboot. Has anyone else had this ...

+ Reply to Thread
Results 1 to 8 of 8

Thread: openSuse 11.0 won't reboot

  1. openSuse 11.0 won't reboot

    I installed openSuse 11.0 on my friend's Dell Optiplex 330 (2.4 GHz Intel
    E2220 Core 2 Duo processor, 2 GB RAM) and, while it shuts down Ok from the
    Log Out menu, it won't reboot. Has anyone else had this problem?

    --
    mochilero


  2. Re: openSuse 11.0 won't reboot

    mochilero wrote:

    > I installed openSuse 11.0 on my friend's Dell Optiplex 330 (2.4 GHz Intel
    > E2220 Core 2 Duo processor, 2 GB RAM) and, while it shuts down Ok from the
    > Log Out menu, it won't reboot. Has anyone else had this problem?
    >

    Difficult to say without more information. Have you got a multi-boot setup?
    Do you get a boot menu? What boot messages (if any) are displayed?

    Chris Gordon-Smith

    www.simsoup.info

  3. Re: openSuse 11.0 won't reboot

    Chris Gordon-Smith wrote:

    > mochilero wrote:
    >
    >> I installed openSuse 11.0 on my friend's Dell Optiplex 330 (2.4 GHz Intel
    >> E2220 Core 2 Duo processor, 2 GB RAM) and, while it shuts down Ok from
    >> the Log Out menu, it won't reboot. Has anyone else had this problem?
    >>

    > Difficult to say without more information. Have you got a multi-boot
    > setup? Do you get a boot menu? What boot messages (if any) are displayed?
    >
    > Chris Gordon-Smith
    >
    > www.simsoup.info


    Also, is this only effecting reboot from that log out menu? Or does boot
    from power on or hardware reset have a problem also?

    John

  4. Re: openSuse 11.0 won't reboot

    John Bowling wrote:

    > Chris Gordon-Smith wrote:
    >> Difficult to say without more information. Have you got a multi-boot
    >> setup? Do you get a boot menu? What boot messages (if any) are displayed?
    >>

    > Also, is this only effecting reboot from that log out menu? Or does boot
    > from power on or hardware reset have a problem also?


    Sorry about the late reply. It's a dual-boot setup with Windows XP
    Professional SP2 using the default Grub bootloader.

    The Grub boot line is this:
    kernel /boot/vmlinuz-2.6.25.11-0.1-pae root=/dev/sda9 resume=/dev/sda5
    splash=silent showopts vga=0x317

    Running KDE, if I click Logout on the menu then "Turn Off Computer" all goes
    well and the computer turns off after stopping all processes. If I
    click "Restart Computer" it stops all processes then displays a message
    about restarting the system (sorry but I just haven't had time to note the
    exact message, but it's the default one), then just sits there (technical
    term :-) without rebooting.

    In KControl's Login Manager section, for Allow Shutdown the settings are
    Local:Everybody and Remote:Only Root. The commands are Halt:/sbin/halt and
    Reboot:/sbin/reboot. The latter exists and is a symlink to /sbin/halt.
    Presumably halt checks the current runlevel to know which to do.

    To answer John's questions: The machine boots up normally from power on.
    There is no hardware reset button on this machine; it's power on or power
    off.

    I don't know what other information to give you. I'll try rebooting by using
    the /sbin/reboot and init 6 commands later on and let you know how I get
    on, but I'm not going to do it right now...

    --
    mochilero


  5. Re: openSuse 11.0 won't reboot

    On Wed, 10 Sep 2008 01:02:23 +0100, mochilero typed this message:

    > John Bowling wrote:
    >
    >> Chris Gordon-Smith wrote:
    >>> Difficult to say without more information. Have you got a multi-boot
    >>> setup? Do you get a boot menu? What boot messages (if any) are
    >>> displayed?
    >>>

    >> Also, is this only effecting reboot from that log out menu? Or does
    >> boot from power on or hardware reset have a problem also?

    >
    > Sorry about the late reply. It's a dual-boot setup with Windows XP
    > Professional SP2 using the default Grub bootloader.
    >
    > The Grub boot line is this:
    > kernel /boot/vmlinuz-2.6.25.11-0.1-pae root=/dev/sda9 resume=/dev/sda5
    > splash=silent showopts vga=0x317
    >
    > Running KDE, if I click Logout on the menu then "Turn Off Computer" all
    > goes well and the computer turns off after stopping all processes. If I
    > click "Restart Computer" it stops all processes then displays a message
    > about restarting the system (sorry but I just haven't had time to note
    > the exact message, but it's the default one), then just sits there
    > (technical term :-) without rebooting.
    >
    > In KControl's Login Manager section, for Allow Shutdown the settings are
    > Local:Everybody and Remote:Only Root. The commands are Halt:/sbin/halt
    > and Reboot:/sbin/reboot. The latter exists and is a symlink to
    > /sbin/halt. Presumably halt checks the current runlevel to know which to
    > do.
    >
    > To answer John's questions: The machine boots up normally from power on.
    > There is no hardware reset button on this machine; it's power on or
    > power off.
    >
    > I don't know what other information to give you. I'll try rebooting by
    > using the /sbin/reboot and init 6 commands later on and let you know how
    > I get on, but I'm not going to do it right now...


    Anything in /var/log/messages? Does (su | sudo) shutdown -r now work?

  6. Re: openSuse 11.0 won't reboot

    noi ance wrote:

    > Anything in /var/log/messages?


    Nothing unusual. The last few lines before it hangs are just what you'd
    expect:

    Sep 10 01:29:41 pc kernel: Kernel logging (proc) stopped.
    Sep 10 01:29:41 pc kernel: Kernel log daemon terminating.
    Sep 10 01:29:41 pc syslog-ng[1779]: syslog-ng version 1.6.12 going down

    > Does (su | sudo) shutdown -r now work?


    No, nor does 'sudo reboot'.

    I don't know if it's relevant but KPowersave is running, set to the
    Performance profile.

    --
    mochilero


  7. Re: openSuse 11.0 won't reboot

    mochilero wrote:
    >noi ance wrote:


    >> Anything in /var/log/messages?


    >Nothing unusual. The last few lines before it hangs are just what you'd
    >expect:


    >Sep 10 01:29:41 pc kernel: Kernel logging (proc) stopped.
    >Sep 10 01:29:41 pc kernel: Kernel log daemon terminating.
    >Sep 10 01:29:41 pc syslog-ng[1779]: syslog-ng version 1.6.12 going down


    >> Does (su | sudo) shutdown -r now work?


    >No, nor does 'sudo reboot'.


    >I don't know if it's relevant but KPowersave is running, set to the
    >Performance profile.


    Most likely an ACPI issue. If a shutdown won't power off, then
    that'd be a fairly clear indicator.

    --
    /"\ Bernd Felsche - Innovative Reckoning, Perth, Western Australia
    \ / ASCII ribbon campaign | Science is the belief in
    X against HTML mail | the ignorance of the experts.
    / \ and postings | -- Richard Feynman

  8. Re: openSuse 11.0 won't reboot

    Bernd Felsche wrote:

    > Most likely an ACPI issue. If a shutdown won't power off, then
    > that'd be a fairly clear indicator.


    Thanks for your input. Shutdown does power off ok.

    --
    mochilero


+ Reply to Thread