banshee says: GStreamer core error: StateChange - Suse

This is a discussion on banshee says: GStreamer core error: StateChange - Suse ; Hello, all of a sudden I can't play music anymore. Instead banshee spits out hundreds of the following 2 error messages: GStreamer core error: StateChange GStreamer resource error: NotFound Not very informative I'd say. Maybe somebody here has got an ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: banshee says: GStreamer core error: StateChange

  1. banshee says: GStreamer core error: StateChange

    Hello,
    all of a sudden I can't play music anymore. Instead banshee spits out
    hundreds of the following 2 error messages:

    GStreamer core error: StateChange
    GStreamer resource error: NotFound

    Not very informative I'd say.
    Maybe somebody here has got an idea what happened or can point me towards
    the right place to ask (if this isn't the right one :-).

    My problem started after I had installed sound-juicer (somebody suggested to
    use sound-juicer to rip the CDs, since I just can't get banshee to fetch
    metadata). I installed sound-juicer and ripped 2 CDs (without any problems)
    and also played a CD. But next time I called banshee I got those odd GStreamer
    errors and now I also get them when I try to play music with sound-juicer.
    But then again that might be pure coincidence.

    Thanks for your help

    Klaus

    --
    ----------------------------------------
    | Klaus Zeitler | news@klauszeitler.de |
    ----------------------------------------
    ---
    Wagner's music is better than it sounds. -- Mark Twain

  2. Re: banshee says: GStreamer core error: StateChange

    On Mon, 01 Sep 2008 18:25:41 +0200, Klaus Zeitler typed this message:

    > Hello,
    > all of a sudden I can't play music anymore. Instead banshee spits out
    > hundreds of the following 2 error messages:
    >
    > GStreamer core error: StateChange
    > GStreamer resource error: NotFound
    >
    > Not very informative I'd say.
    > Maybe somebody here has got an idea what happened or can point me
    > towards the right place to ask (if this isn't the right one :-).
    >
    > My problem started after I had installed sound-juicer (somebody
    > suggested to use sound-juicer to rip the CDs, since I just can't get
    > banshee to fetch metadata). I installed sound-juicer and ripped 2 CDs
    > (without any problems) and also played a CD. But next time I called
    > banshee I got those odd GStreamer errors and now I also get them when I
    > try to play music with sound-juicer. But then again that might be pure
    > coincidence.
    >
    > Thanks for your help
    >
    > Klaus


    Maybe installing sound-juicer interfered with the gstreamer packages.

    Try $ pkill -9 banshee sound-juicer

    $ zypper verify ## look for dependency issues.


  3. Re: banshee says: GStreamer core error: StateChange

    >>>>> "noi" == noi ance writes:
    noi>
    noi> On Mon, 01 Sep 2008 18:25:41 +0200, Klaus Zeitler typed this message:
    noi>
    noi> Maybe installing sound-juicer interfered with the gstreamer packages.

    But it seems as if both banshee and sound-juicer both use gstreamer

    noi> Try $ pkill -9 banshee sound-juicer

    None of them is running. But as soon as I start one of these 2 I get the
    gstreamer errors.

    noi> $ zypper verify ## look for dependency issues.

    Seems there's no verify argument for zypper (at least not on my openSuse 10.3)

    Thanks

    Klaus

    --
    ----------------------------------------
    | Klaus Zeitler | news@klauszeitler.de |
    ----------------------------------------
    ---
    Justice, n.: A decision in your favor.

  4. Re: banshee says: GStreamer core error: StateChange

    On Tue, 02 Sep 2008 21:44:03 +0200, Klaus Zeitler typed this message:

    >>>>>> "noi" == noi ance writes:

    > noi>
    > noi> On Mon, 01 Sep 2008 18:25:41 +0200, Klaus Zeitler typed this
    > message: noi>
    > noi> Maybe installing sound-juicer interfered with the gstreamer
    > packages.
    >
    > But it seems as if both banshee and sound-juicer both use gstreamer
    >
    > noi> Try $ pkill -9 banshee sound-juicer
    >
    > None of them is running. But as soon as I start one of these 2 I get the
    > gstreamer errors.
    >
    > noi> $ zypper verify ## look for dependency issues.
    >
    > Seems there's no verify argument for zypper (at least not on my openSuse
    > 10.3)
    >
    > Thanks
    >
    > Klaus


    Yep, no verify in Suse 10.3

    I don't have any idea what's causing your sound problem
    and I don't have sound-juicer installed but looks like
    sound-juicer 2.20.0-7 in Main (OSS)

    If it helps I show in my Suse 10.3:
    banshee 0.13.1-28
    gstreamer010 0.10.13-34 Main (OSS)
    gstreamer010-plugins-base 0.10.13-36
    gstreamer010-plugins-good 0.10.6-41.2 (suse update)



+ Reply to Thread