Java - Suse

This is a discussion on Java - Suse ; Evidently the 64 bit Java on my SuSE X86_64 10.3 wont support applets. I've installed the 32 bit Java. How do I get Firefox to use it instead of the 64 bit version? Thanks Paul...

+ Reply to Thread
Results 1 to 11 of 11

Thread: Java

  1. Java

    Evidently the 64 bit Java on my SuSE X86_64 10.3 wont support applets.
    I've installed the 32 bit Java. How do I get Firefox to use it instead
    of the 64 bit version?

    Thanks
    Paul

  2. Re: Java

    Paul Thompson wrote:
    > Evidently the 64 bit Java on my SuSE X86_64 10.3 wont support applets.
    > I've installed the 32 bit Java. How do I get Firefox to use it instead
    > of the 64 bit version?
    >
    > Thanks
    > Paul

    Install X86_32 Firefox? This has been an ongoing problem since X86_64
    came out.

    --
    Blattus Slafaly ? 3 7/8

  3. Re: Java

    On Mon, 04 Aug 2008 12:31:57 -0400, Blattus Slafaly wrote:

    > Paul Thompson wrote:
    >> Evidently the 64 bit Java on my SuSE X86_64 10.3 wont support applets.
    >> I've installed the 32 bit Java. How do I get Firefox to use it instead
    >> of the 64 bit version?
    >>
    >> Thanks
    >> Paul

    > Install X86_32 Firefox? This has been an ongoing problem since X86_64
    > came out.


    I wonder how many time I have to say it works ok here.

    about firefox shows
    Mozilla/5.0 (X11; U; Linux x86_64; en-GB; rv:1.9.0.1) Gecko/2008070400
    SUSE/3.0.1-0.1 Firefox/3.0.1

    aboutlugins shows
    GCJ Web Browser Plugin (using IcedTea) 1.2

    File name: gcjwebplugin.so
    The GCJ Web Browser Plugin (using IcedTea) executes Java applets.

    rpm -qa |grep java
    java-1_6_0-openjdk-plugin-1.2_b09-10
    java-1_5_0-gcj-compat-1.5.0.0-65.1
    java-1_6_0-openjdk-1.2_b09-10

    Of course you have to enable java in firefox to execute the applets.

  4. Re: Java

    graham wrote:
    > On Mon, 04 Aug 2008 12:31:57 -0400, Blattus Slafaly wrote:
    >
    >> Paul Thompson wrote:
    >>> Evidently the 64 bit Java on my SuSE X86_64 10.3 wont support applets.
    >>> I've installed the 32 bit Java. How do I get Firefox to use it instead
    >>> of the 64 bit version?
    >>>
    >>> Thanks
    >>> Paul

    >> Install X86_32 Firefox? This has been an ongoing problem since X86_64
    >> came out.

    >
    > I wonder how many time I have to say it works ok here.
    >
    > about firefox shows
    > Mozilla/5.0 (X11; U; Linux x86_64; en-GB; rv:1.9.0.1) Gecko/2008070400
    > SUSE/3.0.1-0.1 Firefox/3.0.1
    >
    > aboutlugins shows
    > GCJ Web Browser Plugin (using IcedTea) 1.2
    >
    > File name: gcjwebplugin.so
    > The GCJ Web Browser Plugin (using IcedTea) executes Java applets.
    >
    > rpm -qa |grep java
    > java-1_6_0-openjdk-plugin-1.2_b09-10
    > java-1_5_0-gcj-compat-1.5.0.0-65.1
    > java-1_6_0-openjdk-1.2_b09-10
    >
    > Of course you have to enable java in firefox to execute the applets.


    When I go to run a weather radar loop I get "Click here to download
    plugin". I then get "Java Runtime Environment", then "Not Available".
    Selecting "Manual Install", the Sun site says "Please use the 32 bit
    version for Java Applet and Java Web Start support". I can install the
    32 bit version but Firefox doesn't link to it. Aboutlugins does not
    show a Java or gciwebplugin.

    Thanks
    Paul

  5. Re: Java

    Paul Thompson wrote:
    > graham wrote:
    >> On Mon, 04 Aug 2008 12:31:57 -0400, Blattus Slafaly wrote:
    >>
    >>> Paul Thompson wrote:
    >>>> Evidently the 64 bit Java on my SuSE X86_64 10.3 wont support applets.
    >>>> I've installed the 32 bit Java. How do I get Firefox to use it instead
    >>>> of the 64 bit version?
    >>>>
    >>>> Thanks
    >>>> Paul
    >>> Install X86_32 Firefox? This has been an ongoing problem since X86_64
    >>> came out.

    >>
    >> I wonder how many time I have to say it works ok here.
    >>
    >> about firefox shows
    >> Mozilla/5.0 (X11; U; Linux x86_64; en-GB; rv:1.9.0.1) Gecko/2008070400
    >> SUSE/3.0.1-0.1 Firefox/3.0.1
    >>
    >> aboutlugins shows
    >> GCJ Web Browser Plugin (using IcedTea) 1.2
    >>
    >> File name: gcjwebplugin.so
    >> The GCJ Web Browser Plugin (using IcedTea) executes Java applets.
    >>
    >> rpm -qa |grep java
    >> java-1_6_0-openjdk-plugin-1.2_b09-10
    >> java-1_5_0-gcj-compat-1.5.0.0-65.1
    >> java-1_6_0-openjdk-1.2_b09-10
    >>
    >> Of course you have to enable java in firefox to execute the applets.

    >
    > When I go to run a weather radar loop I get "Click here to download
    > plugin". I then get "Java Runtime Environment", then "Not Available".
    > Selecting "Manual Install", the Sun site says "Please use the 32 bit
    > version for Java Applet and Java Web Start support". I can install the
    > 32 bit version but Firefox doesn't link to it. Aboutlugins does not
    > show a Java or gciwebplugin.
    >
    > Thanks
    > Paul


    I installed this and still nothing in (aboutlugins)
    jre-6u7-linux-x64-rpm.bin

    Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.1) Gecko/2008070400
    SUSE/3.0.1-1.1 Firefox/3.0.1




    --
    Blattus Slafaly ف ٣

  6. Re: Java

    On Tue, 05 Aug 2008 18:57:00 -0400, Blattus Slafaly wrote:

    > Paul Thompson wrote:
    >> graham wrote:
    >>> On Mon, 04 Aug 2008 12:31:57 -0400, Blattus Slafaly wrote:
    >>>
    >>>> Paul Thompson wrote:
    >>>>> Evidently the 64 bit Java on my SuSE X86_64 10.3 wont support
    >>>>> applets. I've installed the 32 bit Java. How do I get Firefox to use
    >>>>> it instead of the 64 bit version?
    >>>>>
    >>>>> Thanks
    >>>>> Paul
    >>>> Install X86_32 Firefox? This has been an ongoing problem since
    >>>> X86_64 came out.
    >>>
    >>> I wonder how many time I have to say it works ok here.
    >>>
    >>> about firefox shows
    >>> Mozilla/5.0 (X11; U; Linux x86_64; en-GB; rv:1.9.0.1) Gecko/2008070400
    >>> SUSE/3.0.1-0.1 Firefox/3.0.1
    >>>
    >>> aboutlugins shows
    >>> GCJ Web Browser Plugin (using IcedTea) 1.2
    >>>
    >>> File name: gcjwebplugin.so
    >>> The GCJ Web Browser Plugin (using IcedTea) executes Java applets.
    >>>
    >>> rpm -qa |grep java
    >>> java-1_6_0-openjdk-plugin-1.2_b09-10
    >>> java-1_5_0-gcj-compat-1.5.0.0-65.1
    >>> java-1_6_0-openjdk-1.2_b09-10
    >>>
    >>> Of course you have to enable java in firefox to execute the applets.

    >>
    >> When I go to run a weather radar loop I get "Click here to download
    >> plugin". I then get "Java Runtime Environment", then "Not Available".
    >> Selecting "Manual Install", the Sun site says "Please use the 32 bit
    >> version for Java Applet and Java Web Start support". I can install the
    >> 32 bit version but Firefox doesn't link to it. Aboutlugins does not
    >> show a Java or gciwebplugin.
    >>
    >> Thanks
    >> Paul

    >
    > I installed this and still nothing in (aboutlugins)
    > jre-6u7-linux-x64-rpm.bin
    >
    > Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.1) Gecko/2008070400
    > SUSE/3.0.1-1.1 Firefox/3.0.1


    The java I use is one of the three supplied on the dvd.
    I note you did not mention that you have installed the openjdk-plugin.
    This is a must with 64 bit firefox.
    It's worth noting here that konqueror worked without any plugin in
    openSuse 10.3 so I presume it uses a work around.
    The other point is that with firefox java is disabled by default.

  7. Re: Java

    graham wrote:
    > On Tue, 05 Aug 2008 18:57:00 -0400, Blattus Slafaly wrote:
    >
    >> Paul Thompson wrote:
    >>> graham wrote:
    >>>> On Mon, 04 Aug 2008 12:31:57 -0400, Blattus Slafaly wrote:
    >>>>
    >>>>> Paul Thompson wrote:
    >>>>>> Evidently the 64 bit Java on my SuSE X86_64 10.3 wont support
    >>>>>> applets. I've installed the 32 bit Java. How do I get Firefox to use
    >>>>>> it instead of the 64 bit version?
    >>>>>>
    >>>>>> Thanks
    >>>>>> Paul
    >>>>> Install X86_32 Firefox? This has been an ongoing problem since
    >>>>> X86_64 came out.
    >>>> I wonder how many time I have to say it works ok here.
    >>>>
    >>>> about firefox shows
    >>>> Mozilla/5.0 (X11; U; Linux x86_64; en-GB; rv:1.9.0.1) Gecko/2008070400
    >>>> SUSE/3.0.1-0.1 Firefox/3.0.1
    >>>>
    >>>> aboutlugins shows
    >>>> GCJ Web Browser Plugin (using IcedTea) 1.2
    >>>>
    >>>> File name: gcjwebplugin.so
    >>>> The GCJ Web Browser Plugin (using IcedTea) executes Java applets.
    >>>>
    >>>> rpm -qa |grep java
    >>>> java-1_6_0-openjdk-plugin-1.2_b09-10
    >>>> java-1_5_0-gcj-compat-1.5.0.0-65.1
    >>>> java-1_6_0-openjdk-1.2_b09-10
    >>>>
    >>>> Of course you have to enable java in firefox to execute the applets.
    >>> When I go to run a weather radar loop I get "Click here to download
    >>> plugin". I then get "Java Runtime Environment", then "Not Available".
    >>> Selecting "Manual Install", the Sun site says "Please use the 32 bit
    >>> version for Java Applet and Java Web Start support". I can install the
    >>> 32 bit version but Firefox doesn't link to it. Aboutlugins does not
    >>> show a Java or gciwebplugin.
    >>>
    >>> Thanks
    >>> Paul

    >> I installed this and still nothing in (aboutlugins)
    >> jre-6u7-linux-x64-rpm.bin
    >>
    >> Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.1) Gecko/2008070400
    >> SUSE/3.0.1-1.1 Firefox/3.0.1

    >
    > The java I use is one of the three supplied on the dvd.
    > I note you did not mention that you have installed the openjdk-plugin.
    > This is a must with 64 bit firefox.
    > It's worth noting here that konqueror worked without any plugin in
    > openSuse 10.3 so I presume it uses a work around.
    > The other point is that with firefox java is disabled by default.


    I thought openjdk was for IcedTea which I don't have. I install this and
    now I have an entry in aboutlugins - GCJ Web Browser Plugin (using
    IcedTea) 1.2 which has lots of java stuff. If this is necessary why
    isn't it in the dependency list and automatically added?????

    --
    Blattus Slafaly ف ٣

  8. Re: Java

    > The java I use is one of the three supplied on the dvd.
    > I note you did not mention that you have installed the openjdk-plugin.
    > This is a must with 64 bit firefox.
    > It's worth noting here that konqueror worked without any plugin in
    > openSuse 10.3 so I presume it uses a work around.
    > The other point is that with firefox java is disabled by default.


    When I try to install openjdk-plugin I get the following. I'm not sure
    how Packman gets involved?

    Thanks

    #### YaST2 conflicts list - generated 2008-08-06 10:16:19 ####

    java-1_6_0-openjdk cannot be installed due to missing dependencies
    There are no installable providers of jpackage-utils >= 1.7.3 for
    java-1_6_0-openjdk-1.2_b09-9.1.pm.0.x86_64[Packman Repository]
    === java-1_6_0-openjdk-1.2_b09-9.1.pm.0.x86_64[Packman Repository] ===
    java-1_6_0-openjdk-1.2_b09-9.1.pm.0.x86_64[Packman Repository]
    is needed by java-1_6_0-openjdk-plugin-1.2_b09-9.1.pm.0.x86_64[Packman
    Repository] (java-1_6_0-openjdk == 1.2_b09-9.1.pm.0)
    update-alternatives-1.8.3-75.2.noarch is needed by
    java-1_6_0-openjdk-1.2_b09-9.1.pm.0.x86_64[Packman Repository]
    (update-alternatives == 1.8.3-75.2)
    glibc-2.6.1-18.3.x86_64 is needed by
    java-1_6_0-openjdk-1.2_b09-9.1.pm.0.x86_64[Packman Repository]
    (libc.so.6()(64bit))
    13 more...
    bash-3.2-61.x86_64 is needed by
    java-1_6_0-openjdk-1.2_b09-9.1.pm.0.x86_64[Packman Repository] (/bin/sh)
    zlib-1.2.3-75.x86_64 is needed by
    java-1_6_0-openjdk-1.2_b09-9.1.pm.0.x86_64[Packman Repository]
    (libz.so.1()(64bit))
    libasound2-1.0.14-31.2.x86_64 is needed by
    java-1_6_0-openjdk-1.2_b09-9.1.pm.0.x86_64[Packman Repository]
    (libasound.so.2()(64bit))
    xorg-x11-libX11-7.2-75.x86_64 is needed by
    java-1_6_0-openjdk-1.2_b09-9.1.pm.0.x86_64[Packman Repository]
    (libX11.so.6()(64bit))
    freetype2-2.3.5-18.2.x86_64 is needed by
    java-1_6_0-openjdk-1.2_b09-9.1.pm.0.x86_64[Packman Repository]
    (libfreetype.so.6()(64bit))
    libgcc42-4.2.1_20070724-17.x86_64 is needed by
    java-1_6_0-openjdk-1.2_b09-9.1.pm.0.x86_64[Packman Repository]
    (libgcc_s.so.1()(64bit))
    libjpeg-6.2.0-812.x86_64 is needed by
    java-1_6_0-openjdk-1.2_b09-9.1.pm.0.x86_64[Packman Repository]
    (libjpeg.so.62()(64bit))
    xorg-x11-libXext-7.2-65.x86_64 is needed by
    java-1_6_0-openjdk-1.2_b09-9.1.pm.0.x86_64[Packman Repository]
    (libXext.so.6()(64bit))
    libpng-1.2.18-15.4.x86_64 is needed by
    java-1_6_0-openjdk-1.2_b09-9.1.pm.0.x86_64[Packman Repository]
    (libpng12.so.0()(64bit))
    giflib-4.1.4-85.x86_64 is needed by
    java-1_6_0-openjdk-1.2_b09-9.1.pm.0.x86_64[Packman Repository]
    (libgif.so.4()(64bit))
    xorg-x11-libs-7.2-103.4.x86_64 is needed by
    java-1_6_0-openjdk-1.2_b09-9.1.pm.0.x86_64[Packman Repository]
    (libXi.so.6()(64bit))
    java-1_6_0-sun-1.6.0.u6-3.1.x86_64 is needed by
    java-1_6_0-openjdk-1.2_b09-9.1.pm.0.x86_64[Packman Repository]
    (libawt.so()(64bit))
    (null)
    Conflict Resolution:
    ( ) Install jpackage-utils although it would change the vendor
    ( ) do not install java-1_6_0-openjdk
    ( ) Ignore this requirement just here

    #### YaST2 conflicts list END ###

  9. Re: Java

    Paul Thompson wrote:
    >> The java I use is one of the three supplied on the dvd.
    >> I note you did not mention that you have installed the openjdk-plugin.
    >> This is a must with 64 bit firefox. It's worth noting here that
    >> konqueror worked without any plugin in openSuse 10.3 so I presume it
    >> uses a work around.
    >> The other point is that with firefox java is disabled by default.

    >
    > When I try to install openjdk-plugin I get the following. I'm not sure
    > how Packman gets involved?
    >
    > Thanks
    >
    > #### YaST2 conflicts list - generated 2008-08-06 10:16:19 ####
    >
    > java-1_6_0-openjdk cannot be installed due to missing dependencies
    > There are no installable providers of jpackage-utils >= 1.7.3 for
    > java-1_6_0-openjdk-1.2_b09-9.1.pm.0.x86_64[Packman Repository]
    > === java-1_6_0-openjdk-1.2_b09-9.1.pm.0.x86_64[Packman Repository] ===
    > java-1_6_0-openjdk-1.2_b09-9.1.pm.0.x86_64[Packman Repository]
    > is needed by java-1_6_0-openjdk-plugin-1.2_b09-9.1.pm.0.x86_64[Packman
    > Repository] (java-1_6_0-openjdk == 1.2_b09-9.1.pm.0)
    > update-alternatives-1.8.3-75.2.noarch is needed by
    > java-1_6_0-openjdk-1.2_b09-9.1.pm.0.x86_64[Packman Repository]
    > (update-alternatives == 1.8.3-75.2)
    > glibc-2.6.1-18.3.x86_64 is needed by
    > java-1_6_0-openjdk-1.2_b09-9.1.pm.0.x86_64[Packman Repository]
    > (libc.so.6()(64bit))
    > 13 more...
    > bash-3.2-61.x86_64 is needed by
    > java-1_6_0-openjdk-1.2_b09-9.1.pm.0.x86_64[Packman Repository] (/bin/sh)
    > zlib-1.2.3-75.x86_64 is needed by
    > java-1_6_0-openjdk-1.2_b09-9.1.pm.0.x86_64[Packman Repository]
    > (libz.so.1()(64bit))
    > libasound2-1.0.14-31.2.x86_64 is needed by
    > java-1_6_0-openjdk-1.2_b09-9.1.pm.0.x86_64[Packman Repository]
    > (libasound.so.2()(64bit))
    > xorg-x11-libX11-7.2-75.x86_64 is needed by
    > java-1_6_0-openjdk-1.2_b09-9.1.pm.0.x86_64[Packman Repository]
    > (libX11.so.6()(64bit))
    > freetype2-2.3.5-18.2.x86_64 is needed by
    > java-1_6_0-openjdk-1.2_b09-9.1.pm.0.x86_64[Packman Repository]
    > (libfreetype.so.6()(64bit))
    > libgcc42-4.2.1_20070724-17.x86_64 is needed by
    > java-1_6_0-openjdk-1.2_b09-9.1.pm.0.x86_64[Packman Repository]
    > (libgcc_s.so.1()(64bit))
    > libjpeg-6.2.0-812.x86_64 is needed by
    > java-1_6_0-openjdk-1.2_b09-9.1.pm.0.x86_64[Packman Repository]
    > (libjpeg.so.62()(64bit))
    > xorg-x11-libXext-7.2-65.x86_64 is needed by
    > java-1_6_0-openjdk-1.2_b09-9.1.pm.0.x86_64[Packman Repository]
    > (libXext.so.6()(64bit))
    > libpng-1.2.18-15.4.x86_64 is needed by
    > java-1_6_0-openjdk-1.2_b09-9.1.pm.0.x86_64[Packman Repository]
    > (libpng12.so.0()(64bit))
    > giflib-4.1.4-85.x86_64 is needed by
    > java-1_6_0-openjdk-1.2_b09-9.1.pm.0.x86_64[Packman Repository]
    > (libgif.so.4()(64bit))
    > xorg-x11-libs-7.2-103.4.x86_64 is needed by
    > java-1_6_0-openjdk-1.2_b09-9.1.pm.0.x86_64[Packman Repository]
    > (libXi.so.6()(64bit))
    > java-1_6_0-sun-1.6.0.u6-3.1.x86_64 is needed by
    > java-1_6_0-openjdk-1.2_b09-9.1.pm.0.x86_64[Packman Repository]
    > (libawt.so()(64bit))
    > (null)
    > Conflict Resolution:
    > ( ) Install jpackage-utils although it would change the vendor
    > ( ) do not install java-1_6_0-openjdk
    > ( ) Ignore this requirement just here
    >
    > #### YaST2 conflicts list END ###


    I did not get that. It installed without conflicts.


    --
    Blattus Slafaly ف ٣

  10. Re: Java

    On Tue, 05 Aug 2008 17:01:20 -0500, Paul Thompson wrote:

    > When I go to run a weather radar loop I get "Click here to download
    > plugin". I then get "Java Runtime Environment", then "Not Available".
    > Selecting "Manual Install", the Sun site says "Please use the 32 bit
    > version for Java Applet and Java Web Start support".


    Install Java using your package manager e.g. smart or Yast.

    --
    Rob
    To reply, remove zudo

  11. Re: Java

    On Wed, 06 Aug 2008 10:21:34 -0500, Paul Thompson wrote:

    >> The java I use is one of the three supplied on the dvd. I note you did
    >> not mention that you have installed the openjdk-plugin. This is a must
    >> with 64 bit firefox.
    >> It's worth noting here that konqueror worked without any plugin in
    >> openSuse 10.3 so I presume it uses a work around. The other point is
    >> that with firefox java is disabled by default.

    >
    > When I try to install openjdk-plugin I get the following. I'm not sure
    > how Packman gets involved?
    >
    > Thanks
    >


    If more than one repositary for an rpm is available, you can select which
    one you use. Or maybe you don't have the dvd and have not selected the
    oss online repositary leaving you with only Packman.
    If you use the dvd or oss (or is it non-oss) repositary, the dependencies
    should be ok.
    snip

+ Reply to Thread