My zypper showed that four Available updates were available: two for gdm,
and two for libcurl4. Zypper did not fetch them, so I reverted to the
console approach as root:

rpm --rebuilddb
zypper ref
zypper lu
zypper up

This told me that the Main Update Repository was invalid plus
Repository 'openSUSE-10.3-Updates' is invalid. When it asked if I wanted to
continue, I said yes and both repositories were disabled.

Have others experienced this as well?

Thanks,

Godzilla