Firefox update problem. - Suse

This is a discussion on Firefox update problem. - Suse ; uname -a Linux linux-lzu0 2.6.22.17-0.1-bigsmp #1 SMP 2008/02/10 20:01:04 UTC i686 i686 i386 GNU/Linux Tried updating Firefox with latest package update from Respository using Software zypper. produced error. Looked in Software update and found two instances of Firfox installed. 2.0.0.12-5.1 ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: Firefox update problem.

  1. Firefox update problem.

    uname -a
    Linux linux-lzu0 2.6.22.17-0.1-bigsmp #1 SMP 2008/02/10 20:01:04 UTC i686
    i686 i386 GNU/Linux


    Tried updating Firefox with latest package update from Respository using
    Software zypper. produced error. Looked in Software update and found two
    instances of Firfox installed. 2.0.0.12-5.1 and 6.1. Tried uninstalling the
    older version keep getting failure. 6.1 uninstalled. get the following
    error when i try to uninstall it from command line as root.

    Other updates shown by zypper ul installed Ok.

    rpm -e MozillaFirefox-2.0.0.12-5.1

    Usage: usr/bin/update-mime-database [-hvV] MIME-DIR
    No directories in update-desktop-database search path could be processed and
    updated.
    error: %postun(MozillaFirefox-2.0.0.12-5.1.i586) scriptlet failed, exit
    status 1

    ls -l
    -rwxr-xr-x 1 root root 34900 2007-09-21 16:40 update-mime-database


    What does status 1 mean? How can I uninstall firefox completely? I tried
    installing 5.1 again but it gives same error as above

    Should I report this as a bug. Ii notice bug 365649 says you have to run
    SuSEconfig manually. is that correct?

    Thanks for any help?

    --
    Russ
    Registered Linux user #441463


    ----== Posted via Pronews.Com - Unlimited-Unrestricted-Secure Usenet News==----
    http://www.pronews.com The #1 Newsgroup Service in the World! >100,000 Newsgroups
    ---= - Total Privacy via Encryption =---

  2. Re: Firefox update problem.

    On Sat, 15 Mar 2008 15:50:24 -0700, russbucket wrote:

    > rpm -e MozillaFirefox-2.0.0.12-5.1
    >
    > Usage: usr/bin/update-mime-database [-hvV] MIME-DIR No directories in
    > update-desktop-database search path could be processed and updated.
    > error: %postun(MozillaFirefox-2.0.0.12-5.1.i586) scriptlet failed, exit
    > status 1
    >
    > What does status 1 mean? How can I uninstall firefox completely? I tried
    > installing 5.1 again but it gives same error as above


    http://linux.derkeiler.com/Mailing-L.../msg01057.html

    This guide seems to work. I had the same problem.

    After I'd eventually got 5.1 uninstalled, I used Smart and reinstalled
    6.1 and it seems to be fine now.

    --
    Rob
    http://www.uicstock.org.uk/
    To reply, remove zudo

  3. Re: Firefox update problem.

    russbucket wrote:
    > uname -a
    > Linux linux-lzu0 2.6.22.17-0.1-bigsmp #1 SMP 2008/02/10 20:01:04 UTC i686
    > i686 i386 GNU/Linux
    >
    >
    > Tried updating Firefox with latest package update from Respository using
    > Software zypper. produced error. Looked in Software update and found two
    > instances of Firfox installed. 2.0.0.12-5.1 and 6.1. Tried uninstalling the
    > older version keep getting failure. 6.1 uninstalled. get the following
    > error when i try to uninstall it from command line as root.
    >
    > Other updates shown by zypper ul installed Ok.
    >
    > rpm -e MozillaFirefox-2.0.0.12-5.1
    >
    > Usage: usr/bin/update-mime-database [-hvV] MIME-DIR
    > No directories in update-desktop-database search path could be processed and
    > updated.
    > error: %postun(MozillaFirefox-2.0.0.12-5.1.i586) scriptlet failed, exit
    > status 1
    >
    > ls -l
    > -rwxr-xr-x 1 root root 34900 2007-09-21 16:40 update-mime-database
    >
    >
    > What does status 1 mean? How can I uninstall firefox completely? I tried
    > installing 5.1 again but it gives same error as above
    >
    > Should I report this as a bug. Ii notice bug 365649 says you have to run
    > SuSEconfig manually. is that correct?
    >
    > Thanks for any help?
    >


    I used "rpm -e --noscripts MozillaFirefox-2.0.0.12-5.1".
    After that i reinstalled version 6.1 just to be save.

    Uwe



  4. Re: Firefox update problem.

    russbucket wrote:

    > uname -a
    > Linux linux-lzu0 2.6.22.17-0.1-bigsmp #1 SMP 2008/02/10 20:01:04 UTC i686
    > i686 i386 GNU/Linux
    >
    >
    > Tried updating Firefox with latest package update from Respository using


    >

    Thanks to Uwe and The Doctor. the --noscript worked and 6.1 is now
    installed.

    Thanks again.

    --
    Russ
    Registered Linux user #441463


    ----== Posted via Pronews.Com - Unlimited-Unrestricted-Secure Usenet News==----
    http://www.pronews.com The #1 Newsgroup Service in the World! >100,000 Newsgroups
    ---= - Total Privacy via Encryption =---

+ Reply to Thread