mouse cursor disappears after changing users - Suse

This is a discussion on mouse cursor disappears after changing users - Suse ; SuSE 10.3 Gnome. If I log out and then log back in, whether to a different user or the same user, whether root or non-root user, the mouse cursor disappears and the session isn't really usable. I have to reboot. ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: mouse cursor disappears after changing users

  1. mouse cursor disappears after changing users

    SuSE 10.3 Gnome. If I log out and then log back in, whether to a different
    user or the same user, whether root or non-root user, the mouse cursor
    disappears and the session isn't really usable. I have to reboot.

    The mouse is working -- if I move it over a widget that alters its
    appearance when it's under the mouse, I can tell where the mouse is. It
    just doesn't display the mouse cursor any more.

    I note this also happens with my Slackware 12 KDE installation. I have a
    Compaq Presario SR2002X that I bought last fall. It's a PS/2 mouse.

    Is there something I can do to retrieve the mouse cursor when I switch
    users?

    Thanks,
    Allan


  2. Re: mouse cursor disappears after changing users

    Allan schrieb:
    > SuSE 10.3 Gnome. If I log out and then log back in, whether to a
    > different user or the same user, whether root or non-root user, the mouse
    > cursor
    > disappears and the session isn't really usable. I have to reboot.
    >

    No, you don't have to. Does restarting X helps? Press Ctrl-Alt-Backspace in
    the login screen.

    If that helps, you could setup "gdm" so it restarts X every time a session
    is ended. Otherwise you could try to setup thje "sw_cursor" option in X.
    But please try to restart ("zap") X in the login screen.

    Kind regards

    Jan

+ Reply to Thread