dependency resolution failed - Suse

This is a discussion on dependency resolution failed - Suse ; I have just started using SUSE 10.1 and when I start downloading updates for it I recieve the error message ' dependancyresolution failed ' , can someone tell me why please and how I can rectify this TIA...

+ Reply to Thread
Results 1 to 2 of 2

Thread: dependency resolution failed

  1. dependency resolution failed

    I have just started using SUSE 10.1 and when I start downloading updates for
    it I recieve the error message ' dependancyresolution failed ' , can someone
    tell me why please and how I can rectify this TIA



  2. Re: dependency resolution failed

    On Sun, 17 Feb 2008 02:15:17 +0000, PWB typed this message:

    > I have just started using SUSE 10.1 and when I start downloading updates
    > for it I recieve the error message ' dependancyresolution failed ' , can
    > someone tell me why please and how I can rectify this TIA


    I believe it means that for whatever apps you're trying to install the
    prerequisite applications and libraries can not be found. The long way
    is to write down the applications and libraries missing and install those
    before installing the desired application. Library dependencies usually
    require the devel packages, like glibc-devel-2.4-31.43.6 and portaudio18-
    devel-18.1-0.pm.2 if you're using the Packman repositories.


    Question, since you are starting to use SUSE 10.1 is it too late to
    install SUSE 10.3 instead? SUSE 10.3 is better at resolving package
    dependencies and it's zypper/Yast2 updates work much better. On my SUSE
    10.1 system I use YUM instead of YaSt to maintain the system.



+ Reply to Thread