Kernel update and dependency h*** - Suse

This is a discussion on Kernel update and dependency h*** - Suse ; I have ndiswrapper and ndiswrapper-kmp installed on my laptop using 32 bit 10.3. I am unable to install the new kernel updates due to some kind of dependency problem between these packages and the new kernel. On the one hand, ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: Kernel update and dependency h***

  1. Kernel update and dependency h***

    I have ndiswrapper and ndiswrapper-kmp installed on my laptop using 32
    bit 10.3. I am unable to install the new kernel updates due to some kind
    of dependency problem between these packages and the new kernel. On the
    one hand, I can't update the kernel because the two packages depend on
    the old kernel. On the other hand, I can't uninstall ndiswrapper and
    ndiswrapper-kmp because the old kernel depends on them. I've used
    modprobe -r to remove the ndiswrapper module from the kernel, but this
    has not affected the dependency issues. I've asked Yast to use the solver
    to find a solution, but it says no solution is available. What can I do
    to resolve the issue? Is it safe to uninstall ndiswrapper or install the
    kernel updates?

    Thanks for your help.

  2. Re: Kernel update and dependency h***

    Charlie Axilbund wrote:
    > I have ndiswrapper and ndiswrapper-kmp installed on my laptop using 32
    > bit 10.3. I am unable to install the new kernel updates due to some kind
    > of dependency problem between these packages and the new kernel. On the
    > one hand, I can't update the kernel because the two packages depend on
    > the old kernel. On the other hand, I can't uninstall ndiswrapper and
    > ndiswrapper-kmp because the old kernel depends on them. I've used
    > modprobe -r to remove the ndiswrapper module from the kernel, but this
    > has not affected the dependency issues.


    The dependencies are a feature of the package manager and have nothing
    to do with what is currently running.


    > I've asked Yast to use the solver
    > to find a solution, but it says no solution is available. What can I do
    > to resolve the issue? Is it safe to uninstall ndiswrapper or install the
    > kernel updates?


    Simply ignore the dependencies (by choosing the "Ignore this requirement
    just here" option, or something similar).

  3. Re: Kernel update and dependency h***

    On 2008-02-14 18:29, Charlie Axilbund wrote:
    > I have ndiswrapper and ndiswrapper-kmp installed on my laptop using 32
    > bit 10.3. I am unable to install the new kernel updates due to some kind
    > of dependency problem between these packages and the new kernel. On the
    > one hand, I can't update the kernel because the two packages depend on
    > the old kernel. On the other hand, I can't uninstall ndiswrapper and
    > ndiswrapper-kmp because the old kernel depends on them. I've used
    > modprobe -r to remove the ndiswrapper module from the kernel, but this
    > has not affected the dependency issues. I've asked Yast to use the solver
    > to find a solution, but it says no solution is available. What can I do
    > to resolve the issue? Is it safe to uninstall ndiswrapper or install the
    > kernel updates?
    >
    > Thanks for your help.


    I don't know about ndiswrapper, but I had problems to upgrade the kernel last
    time, since there was no matching kernel module for my madwifi, so I just
    waited 1-2 days, and after that it worked just fine.
    Now we got a new kernel update again :-/


    Mostly, it's just to avoid to apply pathes to fast, you must give some time
    so the devs can build all the stuff, and wait for the mirrors to get updated.

    /bb

+ Reply to Thread