PQI 810i on SuSE 10.1 - Suse

This is a discussion on PQI 810i on SuSE 10.1 - Suse ; Hello, Recently bought PQI 810i 1Gb drive. Happens that it isn't recognised on my PC (Linux version 2.6.16.13-4-default (geeko@buildhost) (gcc version 4.1.0 (SUSE Linux)) #1 Wed May 3 04:53:23 UTC 2006) But @ work it works on XP, and on ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: PQI 810i on SuSE 10.1

  1. PQI 810i on SuSE 10.1

    Hello,

    Recently bought PQI 810i 1Gb drive. Happens that it isn't recognised
    on my PC (Linux version 2.6.16.13-4-default (geeko@buildhost) (gcc
    version 4.1.0 (SUSE Linux)) #1 Wed May 3 04:53:23 UTC 2006)

    But @ work it works on XP, and on a RHEL version; but not on W2000
    @home.

    When I do a mount /dev/sda -t vfat /, I get

    mount: wrong fs type, bad option, bad superblock on /dev/sda,
    missing codepage or other error

    dmesg says:

    usb 1-2: new full speed USB device using uhci_hcd and address 2
    usb 1-2: new device found, idVendor=3538, idProduct=0054
    usb 1-2: new device strings: Mfr=1, Product=2, SerialNumber=3
    usb 1-2: Product: Intelligent
    usb 1-2: Manufacturer: I-Stick mini
    usb 1-2: SerialNumber: c6a20c71586169
    usb 1-2: configuration #1 chosen from 1 choice
    SCSI subsystem initialized
    Initializing USB Mass Storage driver...
    scsi0 : SCSI emulation for USB Mass Storage devices
    usb-storage: device found at 2
    usb-storage: waiting for device to settle before scanning
    usbcore: registered new driver usb-storage
    USB Mass Storage support registered.
    Vendor: pqi Model: IntelligentStick Rev: 0.00
    Type: Direct-Access ANSI SCSI revision: 02
    usb-storage: device scan complete
    Driver 'sd' needs updating - please use bus_type methods
    SCSI device sda: 2015231 512-byte hdwr sectors (1032 MB)
    sda: Write Protect is off
    sda: Mode Sense: 00 00 00 00
    sda: assuming drive cache: write through
    SCSI device sda: 2015231 512-byte hdwr sectors (1032 MB)
    sda: Write Protect is off
    sda: Mode Sense: 00 00 00 00
    sda: assuming drive cache: write through
    sda: sda1
    sd 0:0:0:0: Attached scsi removable disk sda
    sd 0:0:0:0: Attached scsi generic sg0 type 0
    FAT: invalid media value (0x01)
    VFS: Can't find a valid FAT filesystem on dev sda.

    Thank you.

    -alex-


  2. Re: PQI 810i on SuSE 10.1

    Following link has already helped a bit, but the issue is not very
    clear yet. As a workaround I can now use my stick (with the mount sda,
    then sda1)

    http://www.linuxquestions.org/questi...s-vfat-413719/


+ Reply to Thread