Can't update gimp from 2.2 to 2.4 - Suse

This is a discussion on Can't update gimp from 2.2 to 2.4 - Suse ; I'm using Suse 10.2. The software updater program is offering to update gimp from version 2.2 to 2.4, but then it gives an error about unresolved dependencies. The entire text is pasted at the end. If I interpret this correctly, ...

+ Reply to Thread
Results 1 to 18 of 18

Thread: Can't update gimp from 2.2 to 2.4

  1. Can't update gimp from 2.2 to 2.4

    I'm using Suse 10.2.
    The software updater program is offering to update gimp from version
    2.2 to 2.4, but then it gives an error about unresolved dependencies.
    The entire text is pasted at the end.

    If I interpret this correctly, gimp 2.4 requires
    libpoppler-glib2-0.6.1-2.1.i586, which in turn requires
    libpoppler2-0.6.1-2.1.i586, but then I lost track of what is it exactly
    that it's telling me. Could someone please help me deciphering this?

    Unresolved dependencies:
    Updating gimp-2.2.13-87.3.i586[System packages] to
    gimp-2.4.0-3.2.i586[20070926-182108]
    Establishing atom:gimp-2.2.13-35.i586[System packages]
    libpoppler-glib2-0.6.1-2.1.i586[20070926-182108] needed by
    gimp-2.4.0-3.2.i586[20070926-182108]
    Installing libpoppler-glib2-0.6.1-2.1.i586[20070926-182108]
    libpoppler2-0.6.1-2.1.i586[20070926-182108] needed by
    libpoppler-glib2-0.6.1-2.1.i586[20070926-182108]
    Installing libpoppler2-0.6.1-2.1.i586[20070926-182108]
    Establishing atomoppler-0.5.4-33.3.i586[System packages]
    Marking poppler-0.5.4-20.i586[20070821-200538] as uninstallable due to
    conflicts over poppler == 0.5.4-20 from
    libpoppler2-0.6.1-2.1.i586[20070926-182108]
    poppler-0.5.4-41.2.i586[System packages] replaced by
    libpoppler2-0.6.1-2.1.i586[20070926-182108]
    poppler-0.5.4-41.2.i586[System packages] provides poppler == 0.5.4-41.2,
    but is scheduled to be uninstalled.
    poppler-0.5.4-20.i586[20070821-200538] provides poppler == 0.5.4-20, but
    it is uninstallable. Try installing it on its own for more details.
    There are no installable providers of poppler == 0.5.4 for
    poppler-qt-0.5.4-41.2.i586[System packages]
    poppler-qt-0.5.4-41.2.i586[System packages] dependend on poppler
    poppler-qt-0.5.4-41.2.i586[System packages] is missing the requirement
    libpoppler.so.1
    poppler-qt-0.5.4-41.2.i586[System packages] provides libpoppler-qt.so.1,
    but is scheduled to be uninstalled.
    poppler-qt-0.5.4-20.i586[20070821-200538] provides libpoppler-qt.so.1,
    but it is uninstallable. Try installing it on its own for more details.
    There are no installable providers of libpoppler-qt.so.1 for
    kdegraphics3-3.5.7-55.2.i586[System packages]
    poppler-qt-0.5.4-41.2.i586[System packages] provides libpoppler-qt.so.1,
    but is scheduled to be uninstalled.
    poppler-qt-0.5.4-20.i586[20070821-200538] provides libpoppler-qt.so.1,
    but it is uninstallable. Try installing it on its own for more details.
    There are no installable providers of libpoppler-qt.so.1 for
    koffice-illustration-1.6.3-64.1.i586[System packages]
    koffice-illustration-1.6.3-64.1.i586[System packages] dependend on
    poppler-qt
    kdegraphics3-3.5.7-55.2.i586[System packages] dependend on poppler-qt
    Establishing pattern:kde_imaging-10.2-145.i586[20070821-200538]
    koffice-illustration-1.6.0-30.i586[20070821-200538] needed by
    pattern:kde_imaging-10.2-145.i586[System packages]
    Updating koffice-illustration-1.6.3-64.1.i586[System packages] to
    koffice-illustration-1.6.0-30.i586[20070821-200538]
    kdegraphics3-3.5.5-30.i586[20070821-200538] needed by
    kdegraphics3-fax-3.5.7-55.2.i586[System packages]
    Updating kdegraphics3-3.5.7-55.2.i586[System packages] to
    kdegraphics3-3.5.5-30.i586[20070821-200538]
    poppler-qt-0.5.4-41.2.i586[System packages] provides libpoppler-qt.so.1,
    but is scheduled to be uninstalled.
    poppler-qt-0.5.4-20.i586[20070821-200538] provides libpoppler-qt.so.1,
    but it is uninstallable. Try installing it on its own for more details.
    There are no installable providers of libpoppler-qt.so.1 for
    kdegraphics3-3.5.5-30.i586[20070821-200538]
    poppler-qt-0.5.4-41.2.i586[System packages] provides libpoppler-qt.so.1,
    but is scheduled to be uninstalled.
    poppler-qt-0.5.4-20.i586[20070821-200538] provides libpoppler-qt.so.1,
    but it is uninstallable. Try installing it on its own for more details.
    There are no installable providers of libpoppler-qt.so.1 for
    koffice-illustration-1.6.0-30.i586[20070821-200538]

  2. Re: Can't update gimp from 2.2 to 2.4

    Juha Nieminen wrote:

    > The software updater program is offering to update gimp from version
    > 2.2 to 2.4, but then it gives an error about unresolved dependencies.
    > The entire text is pasted at the end.


    gimp 2.4 rpm's is not yet stable on openSUSE ;-)
    wait a day of two or install with the source.
    --
    EOS
    www.photo-memories.be
    Running KDE 3.5.8 / openSUSE 10.3

  3. Re: Can't update gimp from 2.2 to 2.4

    On Fri, 26 Oct 2007 14:21:40 +0000, EOS wrote:

    > Juha Nieminen wrote:
    >
    >> The software updater program is offering to update gimp from version
    >> 2.2 to 2.4, but then it gives an error about unresolved dependencies.
    >> The entire text is pasted at the end.

    >
    > gimp 2.4 rpm's is not yet stable on openSUSE ;-) wait a day of two or
    > install with the source.


    Actually, I installed Gimp 2.4 with YaST from the 10.2 packman repository
    last Friday. It all worked fine



    --
    Regards,
    David Bailey
    david _AT_ bailey dot id dot au

  4. Re: Can't update gimp from 2.2 to 2.4

    David Bailey wrote:
    > Actually, I installed Gimp 2.4 with YaST from the 10.2 packman repository
    > last Friday. It all worked fine


    I tried, to no avail. Basically YaST is complaining about the same
    things (even though much less verbosely):

    koffice-illustration-1.6.3-64.1.i586 cannot be installed due to missing
    dependencies
    There are no installable providers of libpoppler-qt.so.1 for
    koffice-illustration-1.6.3-64.1.i586
    Conflict Resolution:
    ( ) delete koffice-illustration
    ( ) Ignore this requirement just here
    poppler-qt-0.5.4-41.2.i586 cannot be installed due to missing dependencies
    There are no installable providers of poppler == 0.5.4 for
    poppler-qt-0.5.4-41.2.i586
    Conflict Resolution:
    ( ) delete poppler-qt
    ( ) Ignore this requirement just here

  5. Re: Can't update gimp from 2.2 to 2.4

    EOS wrote:
    > gimp 2.4 rpm's is not yet stable on openSUSE ;-)
    > wait a day of two or install with the source.


    It still doesn't work.

    Trying to update gimp 2.2 to 2.4 in YaST (which shows that the latter
    version is available, and the former is installed) gives the dependency
    error:

    There are no installable providers of poppler == 0.5.4 for
    poppler-qt-0.5.4-41.2.i586
    Conflict Resolution:
    ( ) delete poppler-qt
    ( ) Ignore this requirement just here

    I just can't understand what it is saying.

    If I search for "poppler" with YaST it shows that I have poppler
    version 0.5.4-41.2 installed and that version 0.5.4-33.3 is available
    (iow. an older version). From poppler-qt it says that I have version
    0.5.4-41.2 installed and version 0.5.4-20 is available.

    I went ahead and downgraded both to the available versions (I'm not
    completely sure I should have, but I did anyways). Nope, it didn't help.
    Trying to upgrade gimp still gives a dependency error:

    poppler-qt-0.5.4-20.i586 cannot be installed due to missing dependencies
    There are no installable providers of poppler == 0.5.4 for
    poppler-qt-0.5.4-20.i586
    Conflict Resolution:
    ( ) delete poppler-qt
    ( ) Ignore this requirement just here

    Help?

  6. Re: Can't update gimp from 2.2 to 2.4

    EOS wrote:
    > try
    > ( ) delete poppler-qt


    If I try that, it will report a bunch of other dependency problems
    (ie, as far as I can see, a bunch of programs depend on poppler-qt so it
    cannot be removed without either removing or crippling those other
    programs, I suppose.)

  7. Re: Can't update gimp from 2.2 to 2.4

    Juha Nieminen wrote:

    > Help?


    try
    ( ) delete poppler-qt

    i am on openSUSE 10.3 now, so i can't check your problem
    --
    EOS
    www.photo-memories.be
    Running KDE 3.5.8 / openSUSE 10.3

  8. Re: Can't update gimp from 2.2 to 2.4

    On Tue, 30 Oct 2007 18:36:15 +0200, Juha Nieminen wrote:

    > EOS wrote:
    >> try
    >> ( ) delete poppler-qt

    >
    > If I try that, it will report a bunch of other dependency problems
    > (ie, as far as I can see, a bunch of programs depend on poppler-qt so it
    > cannot be removed without either removing or crippling those other
    > programs, I suppose.)


    May I suugest a visit to the gimp website - all will become clear.



    --
    Neil
    reverse ra and delete l

  9. Re: Can't update gimp from 2.2 to 2.4

    Juha Nieminen wrote:

    > If I try that, it will report a bunch of other dependency problems
    > (ie, as far as I can see, a bunch of programs depend on poppler-qt so it
    > cannot be removed without either removing or crippling those other
    > programs, I suppose.)


    i should make a bug report
    where is the gimp 2.4 package from ?
    if it's openSUSE -->
    https://bugzilla.novell.com/ICSLogin...er_bug.cgi?%22

    but i think that gimp 2.4 from packman comes, then
    http://packman.links2linux.org/package/gimp24
    contact pascal@links2linux.de
    --
    EOS
    www.photo-memories.be
    Running KDE 3.5.8 / openSUSE 10.3

  10. Re: Can't update gimp from 2.2 to 2.4

    EOS wrote:
    > where is the gimp 2.4 package from ?


    How can I see that?

    The only thing that even remotely looks like that kind of info is in
    the "Technical Data" tab: "Vendor: openSUSE Build Service", but I'm not
    sure if that really tells which repository it's coming from.

  11. Re: Can't update gimp from 2.2 to 2.4

    Juha Nieminen wrote:

    > EOS wrote:
    >> where is the gimp 2.4 package from ?

    >
    > How can I see that?


    Hello Juha,

    Try "rpm -q gimp" and look at the output. Packman packages include the
    letters "pm.X" in the package name.

    Greetz Hendric
    --
    Hendric Stattmann, Mödling, Austria. Registered Linux User #178879

  12. Re: Can't update gimp from 2.2 to 2.4

    Juha Nieminen wrote:

    > How can I see that?
    >
    > The only thing that even remotely looks like that kind of info is in
    > the "Technical Data" tab: "Vendor: openSUSE Build Service", but I'm not
    > sure if that really tells which repository it's coming from.


    if the pacakge is not istalled you have that, that's normal
    you can look like that, and search again
    choose filter "resporitities"
    http://users.telenet.be/photo-memori...t-install2.png
    --
    EOS
    www.photo-memories.be
    Running KDE 3.5.8 / openSUSE 10.3

  13. Re: Can't update gimp from 2.2 to 2.4

    Btw, I noticed that there's a "gimp24" in packman. I tried installing
    that and it installed ok, but it doesn't work. When launched, it gives a
    big bunch of "GLib-GObject-CRITICAL" errors and then crashes with a
    segmentation fault.

  14. Re: Can't update gimp from 2.2 to 2.4

    Juha Nieminen wrote:

    > Btw, I noticed that there's a "gimp24" in packman. I tried installing
    > that and it installed ok, but it doesn't work. When launched, it gives a
    > big bunch of "GLib-GObject-CRITICAL" errors and then crashes with a
    > segmentation fault.


    update "gtk2"
    --
    EOS
    www.photo-memories.be
    Running KDE 3.5.8 / openSUSE 10.3

  15. Re: Can't update gimp from 2.2 to 2.4

    EOS wrote:
    > Juha Nieminen wrote:
    >
    >> Btw, I noticed that there's a "gimp24" in packman. I tried installing
    >> that and it installed ok, but it doesn't work. When launched, it gives a
    >> big bunch of "GLib-GObject-CRITICAL" errors and then crashes with a
    >> segmentation fault.

    >
    > update "gtk2"


    Shouldn't this be a dependency, by definition? Why doesn't the
    software manager say anything?

  16. Re: Can't update gimp from 2.2 to 2.4

    Juha Nieminen wrote:

    > Why doesn't the
    > software manager say anything?


    that's why you have to fill in a bug report ;-)
    i don't know why doesn't say.
    --
    EOS
    www.photo-memories.be
    Running KDE 3.5.8 / openSUSE 10.3

  17. Re: Can't update gimp from 2.2 to 2.4

    EOS wrote:
    > Juha Nieminen wrote:
    >
    >> Btw, I noticed that there's a "gimp24" in packman. I tried installing
    >> that and it installed ok, but it doesn't work. When launched, it gives a
    >> big bunch of "GLib-GObject-CRITICAL" errors and then crashes with a
    >> segmentation fault.

    >
    > update "gtk2"


    There was no newer version available than what I already had.

  18. Re: Can't update gimp from 2.2 to 2.4

    EOS wrote:
    > i should make a bug report


    Clearly this has to be a problem specific to my system. I find it
    quite unlikely that this was a global problem everyone is having without
    it being fixed already. It has been something like 2 weeks already. If
    it was a global problem someone in charge would have noticed it by now
    (either directly or by the tons of bug reports).

    Since it's most probably something exclusive to my system but I
    haven't the slightest idea of what it could be, I doubt a bug report
    would help much. I could report that it's failing to resolve the
    dependencies and I could copypaste those reports, but since I can't
    understand what's wrong with those dependencies and nobody here either,
    I doubt the people who read those bug reports would know any better.

    I will try to submit a bug report (if the system lets me in), but I
    doubt it will have any effect.

+ Reply to Thread