Firefox and Flash plugin not working - Suse

This is a discussion on Firefox and Flash plugin not working - Suse ; Hello, openSUSE 10.3 I have the flash-plugin rpm installed but Firefox is still complaining that the plug in is not installed when I got to a page using flash. Any suggestion on how I get this to work? One suggestion ...

+ Reply to Thread
Results 1 to 12 of 12

Thread: Firefox and Flash plugin not working

  1. Firefox and Flash plugin not working

    Hello,

    openSUSE 10.3

    I have the flash-plugin rpm installed but Firefox is still complaining
    that the plug in is not installed when I got to a page using flash.

    Any suggestion on how I get this to work?

    One suggestion I tried was to delete the ~/.mozilla/firefox/plugins.dat
    file and restart firefox but that hasn't helped.


    Thanks

    Glenn

  2. Re: Firefox and Flash plugin not working

    Glenn Robinson wrote:

    > Hello,
    >
    > openSUSE 10.3
    >
    > I have the flash-plugin rpm installed but Firefox is still complaining
    > that the plug in is not installed when I got to a page using flash.
    >
    > Any suggestion on how I get this to work?
    >
    > One suggestion I tried was to delete the ~/.mozilla/firefox/plugins.dat
    > file and restart firefox but that hasn't helped.
    >
    >
    > Thanks
    >
    > Glenn


    Do you have the 32 or the 64 bit version isntalled?

    --
    Gruß Guybrush

    OpenSuse (linux) 10.3. 64bit, KDE3.5.8 auf AMD Athlon64 3200+, 1GB RAM

  3. Re: Firefox and Flash plugin not working

    Guybrush Threepwood wrote:
    > Glenn Robinson wrote:
    >
    >> Hello,
    >>
    >> openSUSE 10.3
    >>
    >> I have the flash-plugin rpm installed but Firefox is still complaining
    >> that the plug in is not installed when I got to a page using flash.
    >>
    >> Any suggestion on how I get this to work?
    >>
    >> One suggestion I tried was to delete the ~/.mozilla/firefox/plugins.dat
    >> file and restart firefox but that hasn't helped.
    >>
    >>
    >> Thanks
    >>
    >> Glenn

    >
    > Do you have the 32 or the 64 bit version isntalled?
    >


    Not sure, Yast is showing I have flash-player 9.0.48.0-18 installed.

  4. Re: Firefox and Flash plugin not working

    Guybrush Threepwood wrote:
    > Glenn Robinson wrote:
    >
    >> Hello,
    >>
    >> openSUSE 10.3
    >>
    >> I have the flash-plugin rpm installed but Firefox is still complaining
    >> that the plug in is not installed when I got to a page using flash.
    >>
    >> Any suggestion on how I get this to work?
    >>
    >> One suggestion I tried was to delete the ~/.mozilla/firefox/plugins.dat
    >> file and restart firefox but that hasn't helped.
    >>
    >>
    >> Thanks
    >>
    >> Glenn

    >
    > Do you have the 32 or the 64 bit version isntalled?
    >


    I'm actually running the 64bit version of openSUSE 10.3

  5. Re: Firefox and Flash plugin not working

    Glenn Robinson wrote:

    > Guybrush Threepwood wrote:
    >> Glenn Robinson wrote:
    >>
    >>> Hello,
    >>>
    >>> openSUSE 10.3
    >>>
    >>> I have the flash-plugin rpm installed but Firefox is still complaining
    >>> that the plug in is not installed when I got to a page using flash.
    >>>
    >>> Any suggestion on how I get this to work?
    >>>
    >>> One suggestion I tried was to delete the ~/.mozilla/firefox/plugins.dat
    >>> file and restart firefox but that hasn't helped.
    >>>
    >>>
    >>> Thanks
    >>>
    >>> Glenn

    >>
    >> Do you have the 32 or the 64 bit version isntalled?
    >>

    >
    > I'm actually running the 64bit version of openSUSE 10.3


    Hello Glenn,

    as far as I know, there is no flash plugin for the 64 bit version of firefox
    available. I have the same problem and have not solved it until now.

    Perhaps anybody else has an idea...

    --
    Gruß Guybrush

    OpenSuse (linux) 10.3. 64bit, KDE3.5.8 auf AMD Athlon64 3200+, 1GB RAM

  6. Re: Firefox and Flash plugin not working

    On Sun, 21 Oct 2007 19:03:26 +0200, Guybrush Threepwood wrote:

    > as far as I know, there is no flash plugin for the 64 bit version of
    > firefox available. I have the same problem and have not solved it until
    > now.


    I'm a bit confused by this. I was convinced that I'd need to install the
    i386 firefox rpm, but forgot to do so and am running the 64bit version
    (installed via YaST).

    Flash continues to work as well as it did on SUSE 9.3 (which isn't bad)
    and I have no problem with YouTube. I am running the 32 bit version of
    flash, and haven't installed gnash.

    I upgraded to the latest one from the Mozilla repository and the flash
    plugin still works.

    Hows that work then?


    --
    David Haggett
    Linux user since 01/01/2003
    Email: davidhaggettdemoncouk

  7. Re: Firefox and Flash plugin not working

    On Sun, 21 Oct 2007 18:16:21 +0000, David Haggett wrote:

    >> as far as I know, there is no flash plugin for the 64 bit version of
    >> firefox available. I have the same problem and have not solved it until
    >> now.

    >
    > I'm a bit confused by this. I was convinced that I'd need to install
    > the i386 firefox rpm, but forgot to do so and am running the 64bit
    > version (installed via YaST).
    >
    > Flash continues to work as well as it did on SUSE 9.3 (which isn't bad)
    > and I have no problem with YouTube. I am running the 32 bit version of
    > flash, and haven't installed gnash.
    >
    > I upgraded to the latest one from the Mozilla repository and the flash
    > plugin still works.
    >
    > Hows that work then?


    OOOPS!

    Immediately after I hit the post button, I noticed that I have also got
    nspluginwrapper installed - there are versions in both the Mozilla and
    openSUSE repositories. According to the description:

    nspluginwrapper is an Open Source compatibility plugin for Netscape
    4 (NPAPI) plugins. It enables you to use plugins on platforms they
    were not built for. For example, you can use the plugins compiled for
    i386 in Mozilla on Linux/x86_64 or other architectures.

    So, I suspect *that's* how it works

    --
    David Haggett
    Linux user since 01/01/2003
    Email: davidhaggettdemoncouk

  8. Re: Firefox and Flash plugin not working

    David Haggett schrieb:
    > On Sun, 21 Oct 2007 18:16:21 +0000, David Haggett wrote:
    >
    > Immediately after I hit the post button, I noticed that I have also got
    > nspluginwrapper installed - there are versions in both the Mozilla and
    > openSUSE repositories. According to the description:
    >
    > nspluginwrapper is an Open Source compatibility plugin for Netscape
    > 4 (NPAPI) plugins. It enables you to use plugins on platforms they
    > were not built for. For example, you can use the plugins compiled for
    > i386 in Mozilla on Linux/x86_64 or other architectures.
    >
    > So, I suspect *that's* how it works
    >


    Maybe you have a 64 bit Suse, but a 32 bit firefox. I have that. You can check by typing
    about.buildconfig
    in the adddress line of firefox.

    Ciao

    Karl

  9. Re: Firefox and Flash plugin not working

    karl schrieb:

    > Maybe you have a 64 bit Suse, but a 32 bit firefox. I have that. You can check by typing
    > about.buildconfig


    Sorry, typo:

    about:buildconfig

    > in the adddress line of firefox.
    >
    > Ciao
    >
    > Karl


  10. Re: Firefox and Flash plugin not working

    On Mon, 22 Oct 2007 05:24:34 +0200, karl wrote:

    > David Haggett schrieb:
    >> On Sun, 21 Oct 2007 18:16:21 +0000, David Haggett wrote:
    >>
    >> Immediately after I hit the post button, I noticed that I have also got
    >> nspluginwrapper installed - there are versions in both the Mozilla and
    >> openSUSE repositories. According to the description:
    >>
    >> nspluginwrapper is an Open Source compatibility plugin for Netscape 4
    >> (NPAPI) plugins. It enables you to use plugins on platforms they were
    >> not built for. For example, you can use the plugins compiled for i386
    >> in Mozilla on Linux/x86_64 or other architectures.
    >>
    >> So, I suspect *that's* how it works
    >>
    >>

    > Maybe you have a 64 bit Suse, but a 32 bit firefox. I have that. You can
    > check by typing
    > about.buildconfig
    > in the adddress line of firefox.


    Seems to be the 64bit version.
    target: x86_64-unknown-linux-gnu


    --
    David Haggett
    Linux user since 01/01/2003
    Email: davidhaggettdemoncouk

  11. Re: Firefox and Flash plugin not working

    If you have installed firefox for x86_64, flash, and nspluginwrapper,
    just run the following command from the terminal:

    sudo nspluginwrapper -v -i /usr/lib/browser-plugins/libflashplayer.so

    The "sudo" isn't necessary if there's only one user for the machine.

    I hope this helps.

    -Mitch


  12. Re: Firefox and Flash plugin not working

    kingk wrote:

    > If you have installed firefox for x86_64, flash, and nspluginwrapper,
    > just run the following command from the terminal:
    >
    > sudo nspluginwrapper -v -i /usr/lib/browser-plugins/libflashplayer.so
    >
    > The "sudo" isn't necessary if there's only one user for the machine.
    >
    > I hope this helps.
    >
    > -Mitch



    Thanks Mitch

    I have searched for that longtime and it works now.

    Thanks very much again.


    --
    Gruß Guybrush

    OpenSuse (linux) 10.3. 64bit, KDE3.5.8 auf AMD Athlon64 3200+, 1GB RAM

+ Reply to Thread