SUSE 10.3 x86_64. Can't attach HP ScanJet 5p.

When trying to attach the scanner, YaST2, it tells me that no scanner i
recognized by this driver.

In Hardware-Information I get this:

34: udi =
'/org/freedesktop/Hal/devices/pci_1de1_391_scsi_host_scsi_device_lun0_scsi_gener ic'
linux.device_file = '/dev/sg3'
info.capabilities = { 'scsi_generic' }
info.udi =
'/org/freedesktop/Hal/devices/pci_1de1_391_scsi_host_scsi_device_lun0_scsi_gener ic'
linux.subsystem = 'scsi_generic'
scsi_generic.device = '/dev/sg3'
info.product = 'SCSI Generic Interface'
linux.hotplug_type = 2 (0x2)
linux.sysfs_path = '/sys/class/scsi_generic/sg3'
info.category = 'scsi_generic'
info.parent =
'/org/freedesktop/Hal/devices/pci_1de1_391_scsi_host_scsi_device_lun0'

51: SCSI 602.0: 10c04 Scanner
[Created at scsi.1561]
UDI:
/org/freedesktop/Hal/devices/pci_1de1_391_scsi_host_scsi_device_lun0_scsi_gener ic
Unique ID: Fx0u.qcWe7ZyVrmE
Parent ID: B35A.AWwcVN7XpfB
SysFS ID: /class/scsi_generic/sg3
SysFS BusID: 6:0:2:0
Hardware Class: scanner
Model: "HP C5110A"
Vendor: "HP"
Device: "C5110A"
Revision: "3701"
Driver: "dc395x"
Driver Modules: "dc395x"
Device File: /dev/sg3
Device Number: char 21:3
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #31 (SCSI storage controller)


lsscsi returns this:

[2:0:0:0] disk ATA Maxtor 7Y250M0 YAR5 /dev/sda
[4:0:0:0] disk ATA Maxtor 6Y160P0 YAR4 /dev/sdb
[5:0:0:0] cd/dvd HP DVD Writer 640b E152 /dev/sr0
[6:0:2:0] process HP C5110A 3701 -
[7:0:0:0] disk Generic USB SD Reader 1.00 /dev/sdc
[7:0:0:1] disk Generic USB CF Reader 1.01 /dev/sdd
[7:0:0:2] disk Generic USB SM Reader 1.02 /dev/sde
[7:0:0:3] disk Generic USB MS Reader 1.03 /dev/sdf


In SUSE 10.0 x86_64 it worked out perfect.

Any solution's?


--
gil