xf86-video-intel - Suse

This is a discussion on xf86-video-intel - Suse ; Hey, Anyone succesfully installed the xf86-video-intel driver? I've tried, been unsuccesful till now so i'm asking her for help. When i run ./autogen.sh i get following output: reg@desktop-reg:~/xf86-video-intel> ./autogen.sh autoreconf: Entering directory `.' autoreconf: configure.ac: not using Gettext autoreconf: running: ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: xf86-video-intel

  1. xf86-video-intel

    Hey,

    Anyone succesfully installed the xf86-video-intel driver?
    I've tried, been unsuccesful till now so i'm asking her for help.
    When i run ./autogen.sh i get following output:
    reg@desktop-reg:~/xf86-video-intel> ./autogen.sh
    autoreconf: Entering directory `.'
    autoreconf: configure.ac: not using Gettext
    autoreconf: running: aclocal
    autoreconf: configure.ac: tracing
    autoreconf: configure.ac: not using Libtool
    autoreconf: running: /usr/bin/autoconf
    autoreconf: running: /usr/bin/autoheader
    autoreconf: running: automake --add-missing --copy --no-force
    src/Makefile.am:36: Libtool library used but `LIBTOOL' is undefined
    src/Makefile.am:36:
    src/Makefile.am:36: The usual way to define `LIBTOOL' is to add
    `AC_PROG_LIBTOOL'
    src/Makefile.am:36: to `configure.ac' and run `aclocal' and `autoconf'
    again.
    src/ch7017/Makefile.am:8: Libtool library used but `LIBTOOL' is undefined
    src/ch7017/Makefile.am:8:
    src/ch7017/Makefile.am:8: The usual way to define `LIBTOOL' is to add
    `AC_PROG_LIBTOOL'
    src/ch7017/Makefile.am:8: to `configure.ac' and run `aclocal' and `autoconf'
    again.
    src/ch7xxx/Makefile.am:8: Libtool library used but `LIBTOOL' is undefined
    src/ch7xxx/Makefile.am:8:
    src/ch7xxx/Makefile.am:8: The usual way to define `LIBTOOL' is to add
    `AC_PROG_LIBTOOL'
    src/ch7xxx/Makefile.am:8: to `configure.ac' and run `aclocal' and `autoconf'
    again.
    src/ivch/Makefile.am:8: Libtool library used but `LIBTOOL' is undefined
    src/ivch/Makefile.am:8:
    src/ivch/Makefile.am:8: The usual way to define `LIBTOOL' is to add
    `AC_PROG_LIBTOOL'
    src/ivch/Makefile.am:8: to `configure.ac' and run `aclocal' and `autoconf'
    again.
    src/sil164/Makefile.am:8: Libtool library used but `LIBTOOL' is undefined
    src/sil164/Makefile.am:8:
    src/sil164/Makefile.am:8: The usual way to define `LIBTOOL' is to add
    `AC_PROG_LIBTOOL'
    src/sil164/Makefile.am:8: to `configure.ac' and run `aclocal' and `autoconf'
    again.
    src/tfp410/Makefile.am:8: Libtool library used but `LIBTOOL' is undefined
    src/tfp410/Makefile.am:8:
    src/tfp410/Makefile.am:8: The usual way to define `LIBTOOL' is to add
    `AC_PROG_LIBTOOL'
    src/tfp410/Makefile.am:8: to `configure.ac' and run `aclocal' and `autoconf'
    again.
    src/xvmc/Makefile.am:2: Libtool library used but `LIBTOOL' is undefined
    src/xvmc/Makefile.am:2:
    src/xvmc/Makefile.am:2: The usual way to define `LIBTOOL' is to add
    `AC_PROG_LIBTOOL'
    src/xvmc/Makefile.am:2: to `configure.ac' and run `aclocal' and `autoconf'
    again.
    autoreconf: automake failed with exit status: 1
    reg@desktop-reg:~/xf86-video-intel>

    Anyone around who could give me suggestions on how to go from here? I gotta
    define LIBTOOL but i'm not sure where to put 'AC_PROG_LIBTOOL'.
    Any help is appreciated!

    Thanks!
    --
    chEErs roN

  2. Re: xf86-video-intel

    Ron Eggler wrote:

    > Hey,
    >
    > Anyone succesfully installed the xf86-video-intel driver?
    > I've tried, been unsuccesful till now so i'm asking her for help.
    > When i run ./autogen.sh i get following output:
    > reg@desktop-reg:~/xf86-video-intel> ./autogen.sh
    > autoreconf: Entering directory `.'
    > autoreconf: configure.ac: not using Gettext
    > autoreconf: running: aclocal
    > autoreconf: configure.ac: tracing
    > autoreconf: configure.ac: not using Libtool
    > autoreconf: running: /usr/bin/autoconf
    > autoreconf: running: /usr/bin/autoheader
    > autoreconf: running: automake --add-missing --copy --no-force
    > src/Makefile.am:36: Libtool library used but `LIBTOOL' is undefined
    > src/Makefile.am:36:
    > src/Makefile.am:36: The usual way to define `LIBTOOL' is to add
    > `AC_PROG_LIBTOOL'
    > src/Makefile.am:36: to `configure.ac' and run `aclocal' and `autoconf'
    > again.
    > src/ch7017/Makefile.am:8: Libtool library used but `LIBTOOL' is undefined
    > src/ch7017/Makefile.am:8:
    > src/ch7017/Makefile.am:8: The usual way to define `LIBTOOL' is to add
    > `AC_PROG_LIBTOOL'
    > src/ch7017/Makefile.am:8: to `configure.ac' and run `aclocal' and
    > `autoconf' again.
    > src/ch7xxx/Makefile.am:8: Libtool library used but `LIBTOOL' is undefined
    > src/ch7xxx/Makefile.am:8:
    > src/ch7xxx/Makefile.am:8: The usual way to define `LIBTOOL' is to add
    > `AC_PROG_LIBTOOL'
    > src/ch7xxx/Makefile.am:8: to `configure.ac' and run `aclocal' and
    > `autoconf' again.
    > src/ivch/Makefile.am:8: Libtool library used but `LIBTOOL' is undefined
    > src/ivch/Makefile.am:8:
    > src/ivch/Makefile.am:8: The usual way to define `LIBTOOL' is to add
    > `AC_PROG_LIBTOOL'
    > src/ivch/Makefile.am:8: to `configure.ac' and run `aclocal' and `autoconf'
    > again.
    > src/sil164/Makefile.am:8: Libtool library used but `LIBTOOL' is undefined
    > src/sil164/Makefile.am:8:
    > src/sil164/Makefile.am:8: The usual way to define `LIBTOOL' is to add
    > `AC_PROG_LIBTOOL'
    > src/sil164/Makefile.am:8: to `configure.ac' and run `aclocal' and
    > `autoconf' again.
    > src/tfp410/Makefile.am:8: Libtool library used but `LIBTOOL' is undefined
    > src/tfp410/Makefile.am:8:
    > src/tfp410/Makefile.am:8: The usual way to define `LIBTOOL' is to add
    > `AC_PROG_LIBTOOL'
    > src/tfp410/Makefile.am:8: to `configure.ac' and run `aclocal' and
    > `autoconf' again.
    > src/xvmc/Makefile.am:2: Libtool library used but `LIBTOOL' is undefined
    > src/xvmc/Makefile.am:2:
    > src/xvmc/Makefile.am:2: The usual way to define `LIBTOOL' is to add
    > `AC_PROG_LIBTOOL'
    > src/xvmc/Makefile.am:2: to `configure.ac' and run `aclocal' and `autoconf'
    > again.
    > autoreconf: automake failed with exit status: 1
    > reg@desktop-reg:~/xf86-video-intel>
    >
    > Anyone around who could give me suggestions on how to go from here? I
    > gotta define LIBTOOL but i'm not sure where to put 'AC_PROG_LIBTOOL'.
    > Any help is appreciated!
    >
    > Thanks!


    It seems you are trying to use the cvs version. Why not use a stable
    version ? Then you can run ./configue && make && make install. You could
    also run ./configure --help for any options you may want to use.

    Here's a link to a mirror:

    http://x.paracoda.com/pub/X11R7.3/src/driver/


  3. Re: xf86-video-intel

    -------------------------------------snip-------------------------------
    >> Thanks!

    >
    > It seems you are trying to use the cvs version. Why not use a stable
    > version ? Then you can run ./configue && make && make install. You could
    > also run ./configure --help for any options you may want to use.
    >
    > Here's a link to a mirror:
    >
    > http://x.paracoda.com/pub/X11R7.3/src/driver/


    Of course you can use the up arrow in your browser to navigate to a
    different (older) version if you so choose. But this one is the most
    recent.

  4. Re: xf86-video-intel

    Michael Soibelman wrote:

    > -------------------------------------snip-------------------------------
    >>> Thanks!

    >>
    >> It seems you are trying to use the cvs version. Why not use a stable
    >> version ? Then you can run ./configue && make && make install. You
    >> could also run ./configure --help for any options you may want to use.
    >>
    >> Here's a link to a mirror:
    >>
    >> http://x.paracoda.com/pub/X11R7.3/src/driver/

    >
    > Of course you can use the up arrow in your browser to navigate to a
    > different (older) version if you so choose. But this one is the most
    > recent.


    Michael,

    Okay I downloaded this driver, ran "./configure" -> all fine and then "make"
    and i got following output:
    [shell]
    reg@desktop-reg:~/Desktop/xf86-video-intel-2.1.1> make
    make all-recursive
    make[1]: Entering directory `/home/reg/Desktop/xf86-video-intel-2.1.1'
    Making all in src
    make[2]: Entering directory `/home/reg/Desktop/xf86-video-intel-2.1.1/src'
    Making all in xvmc
    make[3]: Entering directory
    `/home/reg/Desktop/xf86-video-intel-2.1.1/src/xvmc'
    make[3]: Nothing to be done for `all'.
    make[3]: Leaving directory
    `/home/reg/Desktop/xf86-video-intel-2.1.1/src/xvmc'
    Making all in bios_reader
    make[3]: Entering directory
    `/home/reg/Desktop/xf86-video-intel-2.1.1/src/bios_reader'
    gcc -DHAVE_CONFIG_H -I. -I../.. -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -fno-strict-aliasing -I/usr/include/xorg -DXF86_MODES_RENAME -I../../src -I../../src/modes -I../../src/parser -g -O2 -MT
    bios_reader.o -MD -MP -MF .deps/bios_reader.Tpo -c -o bios_reader.o
    bios_reader.c
    In file included from bios_reader.c:33:
    .../i830_bios.h:31:21: error: xf86str.h: No such file or directory
    In file included from bios_reader.c:33:
    .../i830_bios.h:35: error: expected specifier-qualifier-list before ‘CARD16’
    .../i830_bios.h:46: error: expected specifier-qualifier-list before ‘CARD16’
    .../i830_bios.h:59: error: expected specifier-qualifier-list before ‘CARD8’
    .../i830_bios.h:67: error: expected specifier-qualifier-list before ‘CARD16’
    .../i830_bios.h:83: error: expected specifier-qualifier-list before ‘CARD16’
    .../i830_bios.h:105: error: expected specifier-qualifier-list before ‘CARD16’
    .../i830_bios.h:114: error: expected specifier-qualifier-list before ‘CARD8’
    .../i830_bios.h:123: error: expected specifier-qualifier-list before ‘CARD16’
    .../i830_bios.h:129: error: expected specifier-qualifier-list before ‘CARD8’
    .../i830_bios.h:134: error: expected specifier-qualifier-list before ‘CARD16’
    .../i830_bios.h:150: error: expected ‘)’ before ‘pScrn’
    .../i830_bios.h:152: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’
    before ‘i830_bios_get_panel_mode’
    .../i830_bios.h:155: error: expected ‘)’ before ‘pScrn’
    bios_reader.c:36:18: error: edid.h: No such file or directory
    bios_reader.c:41: error: expected specifier-qualifier-list before ‘CARD8’
    bios_reader.c: In function ‘main’:
    bios_reader.c:73: error: ‘struct _fake_i830’ has no member named ‘VBIOS’
    bios_reader.c:74: error: ‘struct _fake_i830’ has no member named ‘VBIOS’
    bios_reader.c:77: error: ‘struct _fake_i830’ has no member named ‘VBIOS’
    bios_reader.c:77: error: ‘struct _fake_i830’ has no member named ‘VBIOS’
    bios_reader.c:79: error: ‘struct _fake_i830’ has no member named ‘VBIOS’
    bios_reader.c:81: error: ‘struct vbt_header’ has no member named ‘version’
    bios_reader.c:81: error: ‘struct vbt_header’ has no member named ‘version’
    bios_reader.c:83: error: ‘struct vbt_header’ has no member
    named ‘bdb_offset’
    bios_reader.c:84: error: ‘struct _fake_i830’ has no member named ‘VBIOS’
    bios_reader.c:86: error: ‘struct bdb_header’ has no member named ‘version’
    bios_reader.c:86: error: ‘struct bdb_header’ has no member named ‘version’
    bios_reader.c:87: error: ‘struct bdb_header’ has no member
    named ‘header_size’
    bios_reader.c:87: error: ‘struct bdb_header’ has no member named ‘bdb_size’
    bios_reader.c:96: error: ‘CARD8’ undeclared (first use in this function)
    bios_reader.c:96: error: (Each undeclared identifier is reported only once
    bios_reader.c:96: error: for each function it appears in.)
    bios_reader.c:96: error: ‘timing_ptr’ undeclared (first use in this
    function)
    bios_reader.c:98: error: ‘struct _fake_i830’ has no member named ‘VBIOS’
    bios_reader.c:99: error: ‘struct _fake_i830’ has no member named ‘VBIOS’
    bios_reader.c:99: error: ‘struct _fake_i830’ has no member named ‘VBIOS’
    bios_reader.c:103: error: ‘struct _fake_i830’ has no member named ‘VBIOS’
    bios_reader.c:104: error: ‘struct lvds_bdb_1’ has no member
    named ‘panel_type’
    bios_reader.c:105: error: ‘struct lvds_bdb_1’ has no member named ‘caps’
    bios_reader.c:113: error: ‘struct _fake_i830’ has no member named ‘VBIOS’
    bios_reader.c:115: error: ‘struct lvds_bdb_2’ has no member
    named ‘table_size’
    bios_reader.c:118: error: ‘struct _fake_i830’ has no member named ‘VBIOS’
    bios_reader.c:119: error: ‘struct lvds_bdb_2’ has no member named ‘panels’
    bios_reader.c:120: error: ‘struct _fake_i830’ has no member named ‘VBIOS’
    bios_reader.c:121: error: ‘struct lvds_bdb_2’ has no member named ‘panels’
    bios_reader.c:122: error: ‘struct _fake_i830’ has no member named ‘VBIOS’
    bios_reader.c:123: error: ‘struct lvds_bdb_2’ has no member named ‘panels’
    bios_reader.c:124: error: ‘struct lvds_bdb_2_fp_params’ has no member
    named ‘terminator’
    bios_reader.c:128: error: ‘struct _fake_i830’ has no member named ‘VBIOS’
    bios_reader.c:129: error: ‘struct lvds_bdb_2’ has no member named ‘panels’
    bios_reader.c:130: error: ‘struct _fake_i830’ has no member named ‘VBIOS’
    bios_reader.c:131: error: ‘struct lvds_bdb_2’ has no member named ‘panels’
    bios_reader.c:132: error: ‘struct _fake_i830’ has no member named ‘VBIOS’
    bios_reader.c:133: error: ‘struct lvds_bdb_2’ has no member named ‘panels’
    bios_reader.c:135: error: ‘struct lvds_bdb_2_fp_params’ has no member
    named ‘terminator’
    bios_reader.c:143: error: ‘struct lvds_bdb_2_fp_params’ has no member
    named ‘x_res’
    bios_reader.c:143: error: ‘struct lvds_bdb_2_fp_params’ has no member
    named ‘y_res’
    bios_reader.c:144: warning: implicit declaration of function ‘_PIXEL_CLOCK’
    bios_reader.c:144: warning: nested extern declaration of ‘_PIXEL_CLOCK’
    bios_reader.c:146: warning: implicit declaration of function ‘_H_ACTIVE’
    bios_reader.c:146: warning: nested extern declaration of ‘_H_ACTIVE’
    bios_reader.c:146: warning: implicit declaration of function ‘_H_BLANK’
    bios_reader.c:146: warning: nested extern declaration of ‘_H_BLANK’
    bios_reader.c:147: warning: implicit declaration of function ‘_H_SYNC_OFF’
    bios_reader.c:147: warning: nested extern declaration of ‘_H_SYNC_OFF’
    bios_reader.c:147: warning: implicit declaration of function ‘_H_SYNC_WIDTH’
    bios_reader.c:147: warning: nested extern declaration of ‘_H_SYNC_WIDTH’
    bios_reader.c:148: warning: implicit declaration of function ‘_V_ACTIVE’
    bios_reader.c:148: warning: nested extern declaration of ‘_V_ACTIVE’
    bios_reader.c:148: warning: implicit declaration of function ‘_V_BLANK’
    bios_reader.c:148: warning: nested extern declaration of ‘_V_BLANK’
    bios_reader.c:149: warning: implicit declaration of function ‘_V_SYNC_OFF’
    bios_reader.c:149: warning: nested extern declaration of ‘_V_SYNC_OFF’
    bios_reader.c:149: warning: implicit declaration of function ‘_V_SYNC_WIDTH’
    bios_reader.c:149: warning: nested extern declaration of ‘_V_SYNC_WIDTH’
    bios_reader.c:152: error: ‘struct lvds_bdb_2_fp_params’ has no member
    named ‘x_res’
    bios_reader.c:152: error: ‘struct lvds_bdb_2_fp_params’ has no member
    named ‘y_res’
    make[3]: *** [bios_reader.o] Error 1
    make[3]: Leaving directory
    `/home/reg/Desktop/xf86-video-intel-2.1.1/src/bios_reader'
    make[2]: *** [all-recursive] Error 1
    make[2]: Leaving directory `/home/reg/Desktop/xf86-video-intel-2.1.1/src'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directo
    [/shell]

    Why, what's wrong? How can I find out what I'm missing?

    Thank you!
    --
    chEErs roN

+ Reply to Thread