Flash player & konqueror errors - Suse

This is a discussion on Flash player & konqueror errors - Suse ; I've been having problems with Konqueror freezing. This seems to be something to do with flashplayer. Here is the error I get when launching from a terminal: michael@mylinux:~> konqueror Flash Player: Warning: environment variable G_FILENAME_ENCODING is set and is not ...

+ Reply to Thread
Results 1 to 5 of 5

Thread: Flash player & konqueror errors

  1. Flash player & konqueror errors

    I've been having problems with Konqueror freezing. This seems to be
    something to do with flashplayer. Here is the error I get when launching
    from a terminal:

    michael@mylinux:~> konqueror
    Flash Player: Warning: environment variable G_FILENAME_ENCODING is set and
    is not UTF-8

    (process:20590): GLib-GObject-CRITICAL **: gtype.c:2242: initialization
    assertion failed, use IA__g_type_init() prior to this function

    (process:20590): GLib-CRITICAL **: g_once_init_leave: assertion
    `initialization_value != 0' failed

    (process:20590): Gtk-CRITICAL **: gtk_clipboard_get_for_display: assertion
    `GDK_IS_DISPLAY (display)' failed
    Adobe FlashPlayer: gtk_clipboard_get(GDK_SELECTION_PRIMARY); failed. Trying
    to call gtk_init(0,0);


    Any ideas what is causing this and how to fix it ?

    Thanks.

  2. Re: Flash player & konqueror errors

    Michael Soibelman wrote:

    > I've been having problems with Konqueror freezing. This seems to be
    > something to do with flashplayer. Here is the error I get when launching
    > from a terminal:

    ....
    > Any ideas what is causing this and how to fix it ?


    Netscape Flash plugin.
    I disabled .swf from File Associations, and except questions to download
    flash plugin all was fine.

    I just finished update to 10.3 Factory that is right now frozen at Beta 3
    status. The Konqueror is 3.5.7 release 58, and YouTube works fine. Examples
    from Adobe web site also.

    --
    Regards,
    Rajko.

  3. Re: Flash player & konqueror errors

    Rajko M. wrote:

    > Michael Soibelman wrote:
    >
    >> I've been having problems with Konqueror freezing. This seems to be
    >> something to do with flashplayer. Here is the error I get when launching
    >> from a terminal:

    > ...
    >> Any ideas what is causing this and how to fix it ?

    >
    > Netscape Flash plugin.
    > I disabled .swf from File Associations, and except questions to download
    > flash plugin all was fine.
    >
    > I just finished update to 10.3 Factory that is right now frozen at Beta 3
    > status. The Konqueror is 3.5.7 release 58, and YouTube works fine.
    > Examples from Adobe web site also.
    >


    Thanks. This appears to have fixed the problem of konqueror freezing. Now
    the question becomes how to enable the plugin for sites that use flash
    without the freezing occurring. Obviously this should not happen in the
    first place. I would expect others to have reported this problem as well.
    I will now try to find if this apparent bug is on the bugtrack list and/or
    what fix is available.

    Thank you again. Now I can use konqueror as my browser instead of those
    other less utilitarian alternatives.

    It's just too bad we still are stuck with that proprietary plugin in trhe
    first place ! ;-)

  4. Re: Flash player & konqueror errors

    -----------------------------------snip-------------------------------------
    >
    > Thanks. This appears to have fixed the problem of konqueror freezing.
    > Now the question becomes how to enable the plugin for sites that use flash
    > without the freezing occurring. Obviously this should not happen in the
    > first place. I would expect others to have reported this problem as well.
    > I will now try to find if this apparent bug is on the bugtrack list and/or
    > what fix is available.
    >
    > Thank you again. Now I can use konqueror as my browser instead of those
    > other less utilitarian alternatives.
    >
    > It's just too bad we still are stuck with that proprietary plugin in trhe
    > first place ! ;-)



    This issues is reported as 'resolved' at the kde bugtrack page. Perhaps
    this will be fixed in an update today or tomorrow.. I'll report back.

  5. Re: Flash player & konqueror errors

    On Fri, 07 Sep 2007 17:48:29 GMT
    Michael Soibelman wrote:

    > -----------------------------------snip-------------------------------------
    > >
    > > Thanks. This appears to have fixed the problem of konqueror
    > > freezing. Now the question becomes how to enable the plugin for
    > > sites that use flash without the freezing occurring. Obviously
    > > this should not happen in the first place. I would expect others
    > > to have reported this problem as well. I will now try to find if
    > > this apparent bug is on the bugtrack list and/or what fix is
    > > available.
    > >
    > > Thank you again. Now I can use konqueror as my browser instead of
    > > those other less utilitarian alternatives.
    > >
    > > It's just too bad we still are stuck with that proprietary plugin
    > > in trhe first place ! ;-)

    >
    >
    > This issues is reported as 'resolved' at the kde bugtrack page.
    > Perhaps this will be fixed in an update today or tomorrow.. I'll
    > report back.

    Hi
    I'm running 3.5.7 release 74.2 here it is SLED though but grabbed from
    the KDE repo.

    --
    Cheers Malcolm (Linux Counter #276890)
    SLED 10.0 SP1 x86_64 Kernel 2.6.16.53-0.8-smp
    up 21:35, 2 users, load average: 0.07, 0.04, 0.00

+ Reply to Thread