gdk-pixbuf-csource error - Suse

This is a discussion on gdk-pixbuf-csource error - Suse ; I am using Suse 9.1, and I am trying to install "amide" package for medical image manipulation. I have, among others, the following packages installed: gdk-pixbuf v. 0.22.0-62.7 i586 gtk v. 1.2.10-881 i586 gtk2 v. 2.2.4-125.4 i586 glib v. 1.2.10-586 ...

+ Reply to Thread
Results 1 to 5 of 5

Thread: gdk-pixbuf-csource error

  1. gdk-pixbuf-csource error

    I am using Suse 9.1, and I am trying to install "amide" package for
    medical image manipulation.
    I have, among others, the following packages installed:

    gdk-pixbuf v. 0.22.0-62.7 i586
    gtk v. 1.2.10-881 i586
    gtk2 v. 2.2.4-125.4 i586
    glib v. 1.2.10-586 i586
    glibc v. 2.3.3-98 i586
    glibc-devel v. 2.3.3-98 i586

    In spite of this, when I try to install amide package by:
    [] rpmbuild --rebuild amide-0.8.20-1.src.rpm

    it end with the following output:

    ......checking version of gcc... 3.3.3, good
    checking for i686-suse-linux-pkg-config... no
    checking for pkg-config... /usr/bin/pkg-config
    checking pkg-config is at least version 0.9.0... yes
    checking for AMIDE_GNOME... yes
    checking for glib-genmarshal... no
    checking for gdk-pixbuf-csource... no
    configure: error:
    *** You need the gdk-pixbuf-csource tool which is installed
    *** from GTK+ 2's gdk-pixbuf.
    ***
    *** Either the location where you installed your GTK+ 2 is
    *** not in your PATH or something is screwed up with your
    *** GTK+ 2 installation

    ==============================

    Could someone tell me what is wrong ?

    Cheers

    Darko


  2. Re: gdk-pixbuf-csource error

    Darko

    My first thought is that as a general rule compiling any program not
    only needs the package that contains the running program but also the
    associated development package. Perhaps there is a gdk-pixbuf-devel
    package needed.

    I haven't tried to verify this nor checked if such a package exists...

    Cheers Bob

    dgrosev@vip.hr wrote:
    > *** You need the gdk-pixbuf-csource tool which is installed
    > *** from GTK+ 2's gdk-pixbuf.
    > ***
    > *** Either the location where you installed your GTK+ 2 is
    > *** not in your PATH or something is screwed up with your
    > *** GTK+ 2 installation


  3. Re: gdk-pixbuf-csource error

    dgrosev@vip.hr wrote:

    > I am using Suse 9.1, and I am trying to install "amide" package for
    > medical image manipulation.
    > I have, among others, the following packages installed:
    >
    > gdk-pixbuf v. 0.22.0-62.7 i586
    > gtk v. 1.2.10-881 i586
    > gtk2 v. 2.2.4-125.4 i586
    > glib v. 1.2.10-586 i586
    > glibc v. 2.3.3-98 i586
    > glibc-devel v. 2.3.3-98 i586
    >
    > In spite of this, when I try to install amide package by:
    > [] rpmbuild --rebuild amide-0.8.20-1.src.rpm
    >
    > it end with the following output:
    >
    > .....checking version of gcc... 3.3.3, good
    > checking for i686-suse-linux-pkg-config... no
    > checking for pkg-config... /usr/bin/pkg-config
    > checking pkg-config is at least version 0.9.0... yes
    > checking for AMIDE_GNOME... yes
    > checking for glib-genmarshal... no
    > checking for gdk-pixbuf-csource... no
    > configure: error:
    > *** You need the gdk-pixbuf-csource tool which is installed
    > *** from GTK+ 2's gdk-pixbuf.
    > ***
    > *** Either the location where you installed your GTK+ 2 is
    > *** not in your PATH or something is screwed up with your
    > *** GTK+ 2 installation
    >
    > ==============================
    >
    > Could someone tell me what is wrong ?
    >
    > Cheers
    >
    > Darko


    Do you have Gtk2-devel installed ??

    Get it on this page for your version of Gtk2:

    http://rpm.pbone.net/index.php3?stat...125.4.i586.rpm

  4. Re: gdk-pixbuf-csource error

    On Jul 4, 8:35 pm, Michael Soibelman wrote:
    > dgro...@vip.hr wrote:
    > > I am using Suse 9.1, and I am trying to install "amide" package for
    > > medical image manipulation.
    > > I have, among others, the following packages installed:

    >
    > > gdk-pixbuf v. 0.22.0-62.7 i586
    > > gtk v. 1.2.10-881 i586
    > > gtk2 v. 2.2.4-125.4 i586
    > > glib v. 1.2.10-586 i586
    > > glibc v. 2.3.3-98 i586
    > > glibc-devel v. 2.3.3-98 i586

    >
    > > In spite of this, when I try to install amide package by:
    > > [] rpmbuild --rebuild amide-0.8.20-1.src.rpm

    >
    > > it end with the following output:

    >
    > > .....checking version of gcc... 3.3.3, good
    > > checking for i686-suse-linux-pkg-config... no
    > > checking for pkg-config... /usr/bin/pkg-config
    > > checking pkg-config is at least version 0.9.0... yes
    > > checking for AMIDE_GNOME... yes
    > > checking for glib-genmarshal... no
    > > checking for gdk-pixbuf-csource... no
    > > configure: error:
    > > *** You need the gdk-pixbuf-csource tool which is installed
    > > *** from GTK+ 2's gdk-pixbuf.
    > > ***
    > > *** Either the location where you installed your GTK+ 2 is
    > > *** not in your PATH or something is screwed up with your
    > > *** GTK+ 2 installation

    >
    > > ==============================

    >
    > > Could someone tell me what is wrong ?

    >
    > > Cheers

    >
    > > Darko

    >
    > Do you have Gtk2-devel installed ??
    >
    > Get it on this page for your version of Gtk2:
    >
    > http://rpm.pbone.net/index.php3?stat...1947&name=gtk2...


    It seems that I have all packages installed, but until now I have
    run ./configure and make always as root. When I did ./configure as a
    normal user, original gdk-pixbuf error is not displayed anymore.
    Still, configure is now complaining for not having found some
    packages, that I definitely installed (gsl, xmedcon).
    Her is some output of /.configure run as normal user:
    checking for gsl-config... /usr/bin/gsl-config
    checking for GSL - version >= 1.1.1... no
    *** Could not run GSL test program, checking why...
    *** The test program failed to compile or link. See the file
    config.log for the
    *** exact error that occured. This usually means GSL was incorrectly
    installed
    *** or that you have moved GSL since it was installed. In the latter
    case, you
    *** may want to edit the gsl-config script: /usr/bin/gsl-config
    checking for matrix_open in -lecat... no
    checking for vpGetErrorString in -lvolpack... yes
    checking for xmedcon-config... /usr/bin/xmedcon-config
    checking for XMEDCON - version >= 0.9.9.0... no
    *** Could not run XMEDCON test program, checking why...
    *** The test program compiled, but did not run. This usually means
    *** that the run-time linker is not finding XMEDCON or finding the
    wrong
    *** version of XMEDCON. If it is not finding XMEDCON, you'll need to
    set your
    *** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to
    point
    *** to the installed location Also, make sure you have run ldconfig
    if that
    *** is required on your system
    ***
    *** If you have an old version installed, it is best to remove it,
    although
    *** you may also be able to get things to work by modifying
    LD_LIBRARY_PATH
    ================================================

    Any hints ?

    Cheers

    Darko



  5. Re: gdk-pixbuf-csource error

    dgrosev@vip.hr wrote:

    > On Jul 4, 8:35 pm, Michael Soibelman wrote:
    >> dgro...@vip.hr wrote:
    >> > I am using Suse 9.1, and I am trying to install "amide" package for
    >> > medical image manipulation.
    >> > I have, among others, the following packages installed:

    >>
    >> > gdk-pixbuf v. 0.22.0-62.7 i586
    >> > gtk v. 1.2.10-881 i586
    >> > gtk2 v. 2.2.4-125.4 i586
    >> > glib v. 1.2.10-586 i586
    >> > glibc v. 2.3.3-98 i586
    >> > glibc-devel v. 2.3.3-98 i586

    >>
    >> > In spite of this, when I try to install amide package by:
    >> > [] rpmbuild --rebuild amide-0.8.20-1.src.rpm

    >>
    >> > it end with the following output:

    >>
    >> > .....checking version of gcc... 3.3.3, good
    >> > checking for i686-suse-linux-pkg-config... no
    >> > checking for pkg-config... /usr/bin/pkg-config
    >> > checking pkg-config is at least version 0.9.0... yes
    >> > checking for AMIDE_GNOME... yes
    >> > checking for glib-genmarshal... no
    >> > checking for gdk-pixbuf-csource... no
    >> > configure: error:
    >> > *** You need the gdk-pixbuf-csource tool which is installed
    >> > *** from GTK+ 2's gdk-pixbuf.
    >> > ***
    >> > *** Either the location where you installed your GTK+ 2 is
    >> > *** not in your PATH or something is screwed up with your
    >> > *** GTK+ 2 installation

    >>
    >> > ==============================

    >>
    >> > Could someone tell me what is wrong ?

    >>
    >> > Cheers

    >>
    >> > Darko

    >>
    >> Do you have Gtk2-devel installed ??
    >>
    >> Get it on this page for your version of Gtk2:
    >>
    >> http://rpm.pbone.net/index.php3?stat...1947&name=gtk2...

    >
    > It seems that I have all packages installed, but until now I have
    > run ./configure and make always as root. When I did ./configure as a
    > normal user, original gdk-pixbuf error is not displayed anymore.
    > Still, configure is now complaining for not having found some
    > packages, that I definitely installed (gsl, xmedcon).
    > Her is some output of /.configure run as normal user:
    > checking for gsl-config... /usr/bin/gsl-config
    > checking for GSL - version >= 1.1.1... no
    > *** Could not run GSL test program, checking why...
    > *** The test program failed to compile or link. See the file
    > config.log for the
    > *** exact error that occured. This usually means GSL was incorrectly
    > installed
    > *** or that you have moved GSL since it was installed. In the latter
    > case, you
    > *** may want to edit the gsl-config script: /usr/bin/gsl-config
    > checking for matrix_open in -lecat... no
    > checking for vpGetErrorString in -lvolpack... yes
    > checking for xmedcon-config... /usr/bin/xmedcon-config
    > checking for XMEDCON - version >= 0.9.9.0... no
    > *** Could not run XMEDCON test program, checking why...
    > *** The test program compiled, but did not run. This usually means
    > *** that the run-time linker is not finding XMEDCON or finding the
    > wrong
    > *** version of XMEDCON. If it is not finding XMEDCON, you'll need to
    > set your
    > *** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to
    > point
    > *** to the installed location Also, make sure you have run ldconfig
    > if that
    > *** is required on your system
    > ***
    > *** If you have an old version installed, it is best to remove it,
    > although
    > *** you may also be able to get things to work by modifying
    > LD_LIBRARY_PATH
    > ================================================
    >
    > Any hints ?
    >
    > Cheers
    >
    > Darko


    If you've started by running either './configure' or 'make' as root you
    should uninstall them and start over... This means running 'make clean' in
    the top level build directory. Then as a normal user run ./configure &
    make. As root run make install. And, make certain to run 'ldconfig' next.
    Then exit. As the warning message mentions this you probably didn't do
    this. Here is what man ldconfig says:

    ldconfig creates the necessary links and cache to the most recent
    shared libraries found in the directories specified on the command
    line, in the file /etc/ld.so.conf, and in the trusted directories (/lib
    and /usr/lib). The cache is used by the run-time linker, ld.so or ld-
    linux.so. ldconfig checks the header and filenames of the libraries it
    encounters when determining which versions should have their links
    updated.



+ Reply to Thread