Problem with radeon - Suse

This is a discussion on Problem with radeon - Suse ; I have strange problem with my radeon card - X1650pro and 3D performance. Card seems to work as glxinfo name of display: :0.0 display: :0 screen: 0 direct rendering: Yes server glx vendor string: SGI server glx version string: 1.2 ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: Problem with radeon

  1. Problem with radeon

    I have strange problem with my radeon card - X1650pro and 3D performance.
    Card seems to work as

    glxinfo
    name of display: :0.0
    display: :0 screen: 0
    direct rendering: Yes
    server glx vendor string: SGI
    server glx version string: 1.2
    server glx extensions:
    GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
    GLX_EXT_import_context, GLX_EXT_texture_from_pixmap,
    GLX_OML_swap_method,
    GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_hyperpipe,
    GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig, GLX_MESA_copy_sub_buffer
    client glx vendor string: ATI
    client glx version string: 1.3
    client glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
    GLX_ARB_get_proc_address, GLX_SGI_video_sync, GLX_ARB_multisample,
    GLX_ATI_pixel_format_float, GLX_ATI_render_texture
    GLX extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
    GLX_ARB_multisample
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: Radeon X1650 Series
    OpenGL version string: 2.0.6473 (8.37.6)

    but performance is:

    glxgears
    14952 frames in 5.0 seconds = 2990.259 FPS
    2848 frames in 5.1 seconds = 559.139 FPS
    108 frames in 5.0 seconds = 21.393 FPS
    237 frames in 5.1 seconds = 46.651 FPS
    4515 frames in 5.1 seconds = 877.781 FPS
    3055 frames in 5.2 seconds = 588.372 FPS
    785 frames in 5.0 seconds = 156.994 FPS
    1148 frames in 5.1 seconds = 225.578 FPS

    Any idea how to improve performance ?

    --
    szpakuu(at)poczta.onet.pl

  2. Re: Problem with radeon

    zbyszek wrote:

    > I have strange problem with my radeon card - X1650pro and 3D performance.
    > Card seems to work as
    >
    > glxinfo
    > name of display: :0.0
    > display: :0 screen: 0
    > direct rendering: Yes
    > server glx vendor string: SGI
    > server glx version string: 1.2
    > server glx extensions:
    > GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
    > GLX_EXT_import_context, GLX_EXT_texture_from_pixmap,
    > GLX_OML_swap_method,
    > GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_hyperpipe,
    > GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig, GLX_MESA_copy_sub_buffer
    > client glx vendor string: ATI
    > client glx version string: 1.3
    > client glx extensions:
    > GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
    > GLX_ARB_get_proc_address, GLX_SGI_video_sync, GLX_ARB_multisample,
    > GLX_ATI_pixel_format_float, GLX_ATI_render_texture
    > GLX extensions:
    > GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
    > GLX_ARB_multisample
    > OpenGL vendor string: ATI Technologies Inc.
    > OpenGL renderer string: Radeon X1650 Series
    > OpenGL version string: 2.0.6473 (8.37.6)
    >
    > but performance is:
    >
    > glxgears
    > 14952 frames in 5.0 seconds = 2990.259 FPS
    > 2848 frames in 5.1 seconds = 559.139 FPS
    > 108 frames in 5.0 seconds = 21.393 FPS
    > 237 frames in 5.1 seconds = 46.651 FPS
    > 4515 frames in 5.1 seconds = 877.781 FPS
    > 3055 frames in 5.2 seconds = 588.372 FPS
    > 785 frames in 5.0 seconds = 156.994 FPS
    > 1148 frames in 5.1 seconds = 225.578 FPS
    >
    > Any idea how to improve performance ?
    >


    I have an X1300 Pro 256MB. My system is AMD Athlon X2 64 4200+ openSUSE
    10.2 2.6.18 kernel fglrx 8.32.5 with DVI. My screen is 1280x1024.

    ~> glxgears
    16991 frames in 5.0 seconds = 3398.137 FPS
    17498 frames in 5.0 seconds = 3499.503 FPS
    17545 frames in 5.0 seconds = 3508.855 FPS
    17566 frames in 5.0 seconds = 3513.080 FPS
    17565 frames in 5.0 seconds = 3512.923 FPS
    17543 frames in 5.0 seconds = 3508.488 FPS
    17606 frames in 5.0 seconds = 3521.186 FPS
    17590 frames in 5.0 seconds = 3517.878 FPS
    17544 frames in 5.0 seconds = 3508.610 FPS
    17585 frames in 5.0 seconds = 3516.852 FPS
    17591 frames in 5.0 seconds = 3518.057 FPS

    I believe it's better thought to use fgl_glxgears. Here's what I get:

    ~> fgl_glxgears
    Using GLX_SGIX_pbuffer
    2884 frames in 5.0 seconds = 576.800 FPS
    3659 frames in 5.0 seconds = 731.800 FPS
    3656 frames in 5.0 seconds = 731.200 FPS
    3658 frames in 5.0 seconds = 731.600 FPS
    3660 frames in 5.0 seconds = 732.000 FPS
    3661 frames in 5.0 seconds = 732.200 FPS
    3659 frames in 5.0 seconds = 731.800 FPS
    3658 frames in 5.0 seconds = 731.600 FPS
    3662 frames in 5.0 seconds = 732.400 FPS
    3661 frames in 5.0 seconds = 732.200 FPS
    3661 frames in 5.0 seconds = 732.200 FPS
    3662 frames in 5.0 seconds = 732.400 FPS

    Here are my xorg.conf settings for fglrx:

    Section "Device"
    BoardName "Radeon X1300 Pro 256MB (PCIE)"
    BusID "3:0:0"
    Driver "fglrx"
    Identifier "Device[0]"
    Option "BusType" "PCI"
    Option "Composite" "Disable"
    Option "NoTV"
    Option "no_accel" "no"
    Option "BlockSignalsOnLock" "true"
    Option "no_dri" "no"
    Option "OpenGLOverlay" "off"
    Option "VideoOverlay" "off"
    Option "Stereo" "off"
    Option "CenterMode" "off"
    Option "ScreenOverlap" "0"
    Option "mtrr" "off"
    Option "ForceGenericCPU" "no"
    Option "UseInternalAGPGART" "no"
    Option "UseFastTLS" "2"
    Option "GammaCorrectionI" "0x00000000"
    Option "GammaCorrectionII" "0x00000000"
    Option "KernelModuleParm" "locked-userpages=0"
    Option "PseudoColorVisuals" "off"
    Option "StereoSyncEnable" "0"
    Option "Capabilities" "0x00000000"
    Option "CapabilitiesEx" "0x00000000"
    Option "FSAADisableGamma" "no"
    Option "FSAACustomizeMSPos" "no"
    Option "FSAAEnable" "no"
    Option "FSAAScale" "0"
    Option "FSAAMSPosX0" "0.000000"
    Option "FSAAMSPosX1" "0.000000"
    Option "FSAAMSPosX2" "0.000000"
    Option "FSAAMSPosX3" "0.000000"
    Option "FSAAMSPosX4" "0.000000"
    Option "FSAAMSPosX5" "0.000000"
    Option "FSAAMSPosY0" "0.000000"
    Option "FSAAMSPosY1" "0.000000"
    Option "FSAAMSPosY2" "0.000000"
    Option "FSAAMSPosY3" "0.000000"
    Option "FSAAMSPosY4" "0.000000"
    Option "FSAAMSPosY5" "0.000000"
    Option "EnablePrivateBackZ" "on"
    Option "MaxGARTSize" "256"
    Screen 0
    VendorName "ATI Technologies Inc."
    EndSection

    --
    Chris

  3. Re: Problem with radeon

    Chris napisaƂ(a):
    > zbyszek wrote:
    >


    >
    > I have an X1300 Pro 256MB. My system is AMD Athlon X2 64 4200+ openSUSE
    > 10.2 2.6.18 kernel fglrx 8.32.5 with DVI. My screen is 1280x1024.
    >
    > ~> glxgears
    > 16991 frames in 5.0 seconds = 3398.137 FPS
    > 17498 frames in 5.0 seconds = 3499.503 FPS
    > 17545 frames in 5.0 seconds = 3508.855 FPS
    > 17566 frames in 5.0 seconds = 3513.080 FPS
    > 17565 frames in 5.0 seconds = 3512.923 FPS
    > 17543 frames in 5.0 seconds = 3508.488 FPS
    > 17606 frames in 5.0 seconds = 3521.186 FPS
    > 17590 frames in 5.0 seconds = 3517.878 FPS
    > 17544 frames in 5.0 seconds = 3508.610 FPS
    > 17585 frames in 5.0 seconds = 3516.852 FPS
    > 17591 frames in 5.0 seconds = 3518.057 FPS
    >
    > I believe it's better thought to use fgl_glxgears. Here's what I get:
    >
    > ~> fgl_glxgears
    > Using GLX_SGIX_pbuffer
    > 2884 frames in 5.0 seconds = 576.800 FPS
    > 3659 frames in 5.0 seconds = 731.800 FPS
    > 3656 frames in 5.0 seconds = 731.200 FPS
    > 3658 frames in 5.0 seconds = 731.600 FPS
    > 3660 frames in 5.0 seconds = 732.000 FPS
    > 3661 frames in 5.0 seconds = 732.200 FPS
    > 3659 frames in 5.0 seconds = 731.800 FPS
    > 3658 frames in 5.0 seconds = 731.600 FPS
    > 3662 frames in 5.0 seconds = 732.400 FPS
    > 3661 frames in 5.0 seconds = 732.200 FPS
    > 3661 frames in 5.0 seconds = 732.200 FPS
    > 3662 frames in 5.0 seconds = 732.400 FPS
    >
    > Here are my xorg.conf settings for fglrx:


    I coped your section of device but still :

    $ glxgears
    1207 frames in 5.0 seconds = 241.305 FPS
    1169 frames in 5.0 seconds = 233.793 FPS
    1185 frames in 5.0 seconds = 236.794 FPS
    1190 frames in 5.0 seconds = 237.985 FPS

    however:

    $ fgl_glxgears
    Using GLX_SGIX_pbuffer
    1686 frames in 5.0 seconds = 337.200 FPS
    2064 frames in 5.0 seconds = 412.800 FPS
    1996 frames in 5.0 seconds = 399.200 FPS
    2227 frames in 5.0 seconds = 445.400 FPS


    any idea how to fix that problem ?

+ Reply to Thread