Anyone know where to get a trustworthy patched firefox pgk for Solaris?

-Mike

(1) CRITICAL: Mozilla Products Multiple Vulnerabilities
Affected:
Mozilla Firefox versions 3.0.1 and prior
Mozilla Thunderbird versions 2.0.0.16 and prior
Mozilla SeaMonkey versions 1.1.11 and prior