Anonymous ftp Problem - SUN

This is a discussion on Anonymous ftp Problem - SUN ; I have set up an anonymous ftp server running on Solaris 10. I created an ftp account, created the home directory (/export/home/ ftp), set up the bin, lib directories. etc has only the necessary file and passwd only has root ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: Anonymous ftp Problem

  1. Anonymous ftp Problem

    I have set up an anonymous ftp server running on Solaris 10.

    I created an ftp account, created the home directory (/export/home/
    ftp), set up the bin, lib directories. etc has only the necessary file
    and passwd only has root and ftp accounts listed.

    I can connect to the server with a command-line ftp and with IE,
    Firefox, & Safari browsers. I can navigate the directory structure
    just fine. However, I can not see any files. Not in the command-line
    ftp or browser display.

    Here is some of the traffic I see from snoop on the server when using
    a browser to access the ftp server:

    FTP: "257 "/" is current directory.\r\n"
    FTP: "PASV\r\n"
    FTP: "227 Entering Passive Mode (192,168,1,220,242,123)\r\n"
    FTP: "550 /: not a plain file.\r\n"
    FTP: "550 / is marked unretrievable\r\n"
    FTP: "150 Opening BINARY mode data connection for /bin/ls.\r\n"

    I have gone so far (for testing only) to set the /export/home/ftp and
    pub and directories and all files in pub to 777.

    But still I can not see any files anywhere in the ftp directory tree.
    Nor can I see the entries for the directories themselves.


    Any information would be appreciated.


    Thanks,
    Mike


  2. Re: Anonymous ftp Problem

    On Dec 5, 10:36 am, Mike wrote:
    > I have set up an anonymous ftp server running on Solaris 10.
    > I created an ftp account, created the home directory (/export/home/
    > ftp), set up the bin, lib directories. etc has only the necessary file
    > and passwd only has root and ftp accounts listed.


    Puzzling. Did you use ftpconfig??
    It does not read that way.

  3. Re: Anonymous ftp Problem

    I did not use the ftpconfig at first but used some other anonymous ftp
    setup instructions.

    Didn't work.

    So I removed directory tree I had created and the ftp account. Then I
    ran the ftpconfig and magic all works great!

    Thanks for the tip.




    On Dec 5, 9:46 pm, gerryt wrote:
    > On Dec 5, 10:36 am, Mike wrote:
    >
    > > I have set up an anonymous ftp server running on Solaris 10.
    > > I created an ftp account, created the home directory (/export/home/
    > > ftp), set up the bin, lib directories. etc has only the necessary file
    > > and passwd only has root and ftp accounts listed.

    >
    > Puzzling. Did you use ftpconfig??
    > It does not read that way.



+ Reply to Thread