service in maintenance mode how to bring it back - SUN

This is a discussion on service in maintenance mode how to bring it back - SUN ; Hey folks, I have been trying since yesterday to implement NIS. Somehow most of the services were disabled and NIS did not work properly. Than I ran sccs | grep nis and found that online 11:51:34 svc:/network/nis/passwd:default online 11:52:18 svc:/network/nis/update:default ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: service in maintenance mode how to bring it back

  1. service in maintenance mode how to bring it back

    Hey folks,

    I have been trying since yesterday to implement NIS. Somehow most of
    the services were disabled and NIS did not work properly. Than I ran
    sccs | grep nis and found that

    online 11:51:34 svc:/network/nis/passwd:default
    online 11:52:18 svc:/network/nis/update:default
    online 11:52:33 svc:/network/nis/xfr:default
    maintenance 11:47:25 svc:/network/nis/client:default
    maintenance 13:37:27 svc:/network/nis/server:default

    I have tried
    svcadm disable
    svcadm enable
    svcadm restart
    svcadm refresh

    and it is just not coming up online again.
    I checked the logs it says that directory not found so I checked that
    there was a directory in /var/yp/
    Jun 8 10:51:39 Executing start method ("/lib/svc/method/yp") ]
    /lib/svc/method/yp: domain directory missing.


  2. Re: service in maintenance mode how to bring it back

    On Jun 8, 4:48 pm, learner wrote:
    > Hey folks,
    >
    > I have been trying since yesterday to implement NIS. Somehow most of
    > the services were disabled and NIS did not work properly. Than I ran
    > sccs | grep nis and found that
    >
    > online 11:51:34 svc:/network/nis/passwd:default
    > online 11:52:18 svc:/network/nis/update:default
    > online 11:52:33 svc:/network/nis/xfr:default
    > maintenance 11:47:25 svc:/network/nis/client:default
    > maintenance 13:37:27 svc:/network/nis/server:default
    >
    > I have tried
    > svcadm disable
    > svcadm enable
    > svcadm restart
    > svcadm refresh


    The short answer is 'svcadm clear', if the underlying problem is
    resolved.

    >
    > and it is just not coming up online again. ...




  3. Re: service in maintenance mode how to bring it back

    In article
    <1181332106.660019.147060@q66g2000hsg.googlegroups. com>learner
    wrote:

    > I have been trying since yesterday to implement NIS. Somehow most of
    > the services were disabled and NIS did not work properly. Than I
    > ran sccs | grep nis and found that


    I think, you meant "svcs | grep nis"

    > online 11:51:34 svc:/network/nis/passwd:default
    > online 11:52:18 svc:/network/nis/update:default
    > online 11:52:33 svc:/network/nis/xfr:default
    > maintenance 11:47:25 svc:/network/nis/client:default
    > maintenance 13:37:27 svc:/network/nis/server:default
    >
    > I have tried
    > svcadm disable
    > svcadm enable
    > svcadm restart
    > svcadm refresh


    missing: "svcadm clear nis/client" and "svcadm clear nis/server"

    How did you initialize the services? You should set up your NIS master
    server with "ypinit -m", not by svcadm!
    Greetings
    Jan Dreyer

    --
    I'm trying a new usenet client for Mac, Nemo OS X.
    You can download it at http://www.malcom-mac.com/nemo


+ Reply to Thread