Mounting USB flash drive on Solaris 8 - SUN

This is a discussion on Mounting USB flash drive on Solaris 8 - SUN ; I know that this has been hashed through before...but I can't find any info on my problem. I'm trying to mount a USB flash drive on Solaris 8. Solaris appears to see the drive -- I did a reconfigure boot, ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Mounting USB flash drive on Solaris 8

  1. Mounting USB flash drive on Solaris 8

    I know that this has been hashed through before...but I can't
    find any info on my problem. I'm trying to mount a USB flash
    drive on Solaris 8.

    Solaris appears to see the drive -- I did a reconfigure boot,
    and here are the relevant messages:

    # dmesg | egrep 'scsa2usb0|CBM|usb_sd0'
    May 23 16:49:28 valkyrie.itt.purdue.edu usba: [ID 855233 kern.info] USB-device: storage@2, scsa2usb0 at bus address 2
    May 23 16:49:28 valkyrie.itt.purdue.edu usba: [ID 349649 kern.info] CBM, Flash Disk, 2108008FDD1A0009
    May 23 16:49:28 valkyrie.itt.purdue.edu genunix: [ID 936769 kern.info] scsa2usb0 is /pci@1e,600000/usb@a/storage@2
    May 23 16:49:28 valkyrie.itt.purdue.edu scsi: [ID 193665 kern.info] usb_sd0 at scsa2usb0: target 0 lun 0
    May 23 16:49:28 valkyrie.itt.purdue.edu genunix: [ID 936769 kern.info] usb_sd0 is /pci@1e,600000/usb@a/storage@2/disk@0,0
    May 23 16:49:28 valkyrie.itt.purdue.edu genunix: [ID 408114 kern.info] /pci@1e,600000/usb@a/storage@2/disk@0,0 (usb_sd0) online
    May 23 16:49:28 valkyrie.itt.purdue.edu genunix: [ID 408114 kern.info] /pci@1e,600000/usb@a/storage@2 (scsa2usb0) online

    The output from "iostat -En" shows:

    usb_sd0 Soft Errors: 0 Hard Errors: 4 Transport Errors: 0
    Vendor: CBM Product: Flash Di2108008F Revision: DD1A Serial No: Size: 0.00GB <0 bytes>
    Media Error: 0 Device Not Ready: 4 No Device: 0 Recoverable: 0
    Illegal Request: 0 Predictive Failure Analysis: 0

    The drive appears to be a 64MB unit based on what a Windows XP box
    shows. Iostat shows the size to be zero, which is *interesting*.

    The device nodes are being created in /dev/dsk and /dev/rdsk. It's
    showing up as c5t0d0s[0-7]. My understanding is that I should be
    able to mount it (having stopped vold first) as:

    # mount -F pcfs /dev/dsk/c5t0d0s2:c /mnt

    I get "mount: No such device or address" of this and any out
    permutation of the mount command that I can think of.

    Any ideas on what I can try here?
    --
    Jeff Wieland

  2. Re: Mounting USB flash drive on Solaris 8

    In article Jeff Wieland writes:
    >I know that this has been hashed through before...but I can't
    >find any info on my problem. I'm trying to mount a USB flash
    >drive on Solaris 8.
    >
    >Solaris appears to see the drive -- I did a reconfigure boot,
    >and here are the relevant messages:
    >
    ># dmesg | egrep 'scsa2usb0|CBM|usb_sd0'
    >May 23 16:49:28 valkyrie.itt.purdue.edu usba: [ID 855233 kern.info] USB-device: storage@2, scsa2usb0 at bus address 2
    >May 23 16:49:28 valkyrie.itt.purdue.edu usba: [ID 349649 kern.info] CBM, Flash Disk, 2108008FDD1A0009
    >May 23 16:49:28 valkyrie.itt.purdue.edu genunix: [ID 936769 kern.info] scsa2usb0 is /pci@1e,600000/usb@a/storage@2
    >May 23 16:49:28 valkyrie.itt.purdue.edu scsi: [ID 193665 kern.info] usb_sd0 at scsa2usb0: target 0 lun 0
    >May 23 16:49:28 valkyrie.itt.purdue.edu genunix: [ID 936769 kern.info] usb_sd0 is /pci@1e,600000/usb@a/storage@2/disk@0,0
    >May 23 16:49:28 valkyrie.itt.purdue.edu genunix: [ID 408114 kern.info] /pci@1e,600000/usb@a/storage@2/disk@0,0 (usb_sd0) online
    >May 23 16:49:28 valkyrie.itt.purdue.edu genunix: [ID 408114 kern.info] /pci@1e,600000/usb@a/storage@2 (scsa2usb0) online
    >
    >The output from "iostat -En" shows:
    >
    >usb_sd0 Soft Errors: 0 Hard Errors: 4 Transport Errors: 0
    >Vendor: CBM Product: Flash Di2108008F Revision: DD1A Serial No: Size: 0.00GB <0 bytes>
    >Media Error: 0 Device Not Ready: 4 No Device: 0 Recoverable: 0
    >Illegal Request: 0 Predictive Failure Analysis: 0
    >
    >The drive appears to be a 64MB unit based on what a Windows XP box
    >shows. Iostat shows the size to be zero, which is *interesting*.
    >
    >The device nodes are being created in /dev/dsk and /dev/rdsk. It's
    >showing up as c5t0d0s[0-7]. My understanding is that I should be
    >able to mount it (having stopped vold first) as:
    >
    ># mount -F pcfs /dev/dsk/c5t0d0s2:c /mnt
    >
    >I get "mount: No such device or address" of this and any out
    >permutation of the mount command that I can think of.
    >
    >Any ideas on what I can try here?
    >--
    >Jeff Wieland


    Hmmm. I tried out a different flash drive -- this one is a 512MB PNY
    Attache'. It seems to work fine, except for the following problem when
    unmounting: after I do the "eject rmdisk" command, and the flash drive
    is unmounted, I unplug it, and I get the following error messages:

    usba: [ID 464422 kern.warning] WARNING: /pci@1f,0/pci@1/usb@2/storage@2 (scsa2usb0): Disconnected device was busy, please reconnect.
    usba: [ID 349649 kern.info] usba: offlining scsa2usb0 failed (-5)

    Then I plug it back in again, and get:

    usba: [ID 464422 kern.warning] WARNING: /pci@1f,0/pci@1/usb@2/storage@2 (scsa2usb0): reinserted device is accessible again

    And it mounts the flash drive again. I have no idea if the disk is
    cleanly unmounted (since it just has a vfat-type filesystem anyway).

    Anyone know what's going on here?
    --
    Jeff Wieland

+ Reply to Thread