Issue: Adding new disk from SAN (EMC) to Solaris 10 OS - SUN

This is a discussion on Issue: Adding new disk from SAN (EMC) to Solaris 10 OS - SUN ; Would like to expand one of partition which is alread on SAN, and already assign another 100 gb, but on Solaris 10, using format, couldn't see that new 100gb disk. even after reboot, still can't see new disk, What could ...

+ Reply to Thread
Results 1 to 13 of 13

Thread: Issue: Adding new disk from SAN (EMC) to Solaris 10 OS

  1. Issue: Adding new disk from SAN (EMC) to Solaris 10 OS

    Would like to expand one of partition which is alread on SAN, and already
    assign another 100 gb, but on Solaris 10, using format, couldn't see that
    new 100gb disk.
    even after reboot, still can't see new disk,

    What could be wrong? And how to know the disk has been added correctly?

    Thanks a bunch.



  2. Re: Issue: Adding new disk from SAN (EMC) to Solaris 10 OS

    If you mean you did this using another cable, then run "iostat -xn" to
    see if you see anything extra. If does, run "devfsadm -c disk -v". If
    does not from iostat, you may need to figure out to add this new SAN
    initiator to your box.

    If you mean you added a single disk to one of the SAN arrays, you may
    deal with that using EMC software.

    Regards
    Victor


  3. Re: Issue: Adding new disk from SAN (EMC) to Solaris 10 OS

    On Fri, 15 Sep 2006 16:08:26 -0400, steeles wrote:

    > Would like to expand one of partition which is alread on SAN, and already
    > assign another 100 gb, but on Solaris 10, using format, couldn't see that
    > new 100gb disk.
    > even after reboot, still can't see new disk,
    >
    > What could be wrong? And how to know the disk has been added correctly?
    >
    > Thanks a bunch.


    I'm confused... Did you expand the LUN or did you add a second lun?

    Are you using EMC power path?


  4. Re: Issue: Adding new disk from SAN (EMC) to Solaris 10 OS


    steeles wrote:
    > Would like to expand one of partition which is alread on SAN, and already
    > assign another 100 gb, but on Solaris 10, using format, couldn't see that
    > new 100gb disk.
    > even after reboot, still can't see new disk,
    >
    > What could be wrong? And how to know the disk has been added correctly?
    >
    > Thanks a bunch.



    Could you show us the related messages in /var/adm/messages?

    Victor


  5. Re: Issue: Adding new disk from SAN (EMC) to Solaris 10 OS

    Sorry to confuse you guys.
    The fact is,

    One of SAN (EMC) guys gave another addtional 100gb space to Solaris box
    (10) from SAN array, and I need to expand one of partitions which is
    mounted from SAN.

    I did "devfsadmin -c" and format, but couldn't see that extra space
    (hard drive).
    Was suggested by rebooting solaris, but still luck finding it.

    Yes, it is using EMC power path. What could be wrong?

    If disk from SAN added correctly, will it change "sd.conf" file
    automatically?

    Please help.

    victorfeng1973@yahoo.com wrote:
    > steeles wrote:
    > > Would like to expand one of partition which is alread on SAN, and already
    > > assign another 100 gb, but on Solaris 10, using format, couldn't see that
    > > new 100gb disk.
    > > even after reboot, still can't see new disk,
    > >
    > > What could be wrong? And how to know the disk has been added correctly?
    > >
    > > Thanks a bunch.

    >
    >
    > Could you show us the related messages in /var/adm/messages?
    >
    > Victor



  6. Re: Issue: Adding new disk from SAN (EMC) to Solaris 10 OS

    On Fri, 15 Sep 2006 16:08:26 -0400, steeles wrote:

    > Would like to expand one of partition which is alread on SAN, and already
    > assign another 100 gb, but on Solaris 10, using format, couldn't see that
    > new 100gb disk.
    > even after reboot, still can't see new disk,
    >
    > What could be wrong? And how to know the disk has been added correctly?
    >
    > Thanks a bunch.


    Hmm, exam question perchance?

  7. Re: Issue: Adding new disk from SAN (EMC) to Solaris 10 OS


    steeles wrote:
    > Sorry to confuse you guys.
    > The fact is,
    >
    > One of SAN (EMC) guys gave another addtional 100gb space to Solaris box
    > (10) from SAN array, and I need to expand one of partitions which is
    > mounted from SAN.
    >
    > I did "devfsadmin -c" and format, but couldn't see that extra space
    > (hard drive).
    > Was suggested by rebooting solaris, but still luck finding it.
    >
    > Yes, it is using EMC power path. What could be wrong?
    >
    > If disk from SAN added correctly, will it change "sd.conf" file
    > automatically?


    May or may not. Our vendor even suggests to add up to 256 targets in
    sd.conf if things do not work out, but it did not happen to us.

    If your SAN guy could confirm that 100gb was added in his side, the
    worst scenario is to start over to connect to your SAN.

    Victor


  8. Re: Issue: Adding new disk from SAN (EMC) to Solaris 10 OS

    Thanks Victor,

    How to start over to start over to SAN?

    wrote in message
    news:1158588795.861814.289060@m7g2000cwm.googlegro ups.com...
    >
    > steeles wrote:
    >> Sorry to confuse you guys.
    >> The fact is,
    >>
    >> One of SAN (EMC) guys gave another addtional 100gb space to Solaris box
    >> (10) from SAN array, and I need to expand one of partitions which is
    >> mounted from SAN.
    >>
    >> I did "devfsadmin -c" and format, but couldn't see that extra space
    >> (hard drive).
    >> Was suggested by rebooting solaris, but still luck finding it.
    >>
    >> Yes, it is using EMC power path. What could be wrong?
    >>
    >> If disk from SAN added correctly, will it change "sd.conf" file
    >> automatically?

    >
    > May or may not. Our vendor even suggests to add up to 256 targets in
    > sd.conf if things do not work out, but it did not happen to us.
    >
    > If your SAN guy could confirm that 100gb was added in his side, the
    > worst scenario is to start over to connect to your SAN.
    >
    > Victor
    >




  9. Re: Issue: Adding new disk from SAN (EMC) to Solaris 10 OS

    How to tell if the disk has been added correctly? Any file gets changed when
    SAN guy added extra disk space?


    "steeles" wrote in message
    news:q1yPg.24$FA4.2@newsfe21.lga...
    > Thanks Victor,
    >
    > How to start over to start over to SAN?
    >
    > wrote in message
    > news:1158588795.861814.289060@m7g2000cwm.googlegro ups.com...
    >>
    >> steeles wrote:
    >>> Sorry to confuse you guys.
    >>> The fact is,
    >>>
    >>> One of SAN (EMC) guys gave another addtional 100gb space to Solaris box
    >>> (10) from SAN array, and I need to expand one of partitions which is
    >>> mounted from SAN.
    >>>
    >>> I did "devfsadmin -c" and format, but couldn't see that extra space
    >>> (hard drive).
    >>> Was suggested by rebooting solaris, but still luck finding it.
    >>>
    >>> Yes, it is using EMC power path. What could be wrong?
    >>>
    >>> If disk from SAN added correctly, will it change "sd.conf" file
    >>> automatically?

    >>
    >> May or may not. Our vendor even suggests to add up to 256 targets in
    >> sd.conf if things do not work out, but it did not happen to us.
    >>
    >> If your SAN guy could confirm that 100gb was added in his side, the
    >> worst scenario is to start over to connect to your SAN.
    >>
    >> Victor
    >>

    >
    >




  10. Re: Issue: Adding new disk from SAN (EMC) to Solaris 10 OS


    steeles wrote:
    > How to tell if the disk has been added correctly? Any file gets changed when
    > SAN guy added extra disk space?
    >
    >
    > "steeles" wrote in message
    > news:q1yPg.24$FA4.2@newsfe21.lga...
    > > Thanks Victor,
    > >
    > > How to start over to start over to SAN?


    I do not know EMC. Would you like to call EMC? The iSCSI card we get
    is from QLogic. It has its driver and management software. We had
    different issue and I restalled the driver and software twice. Maybe
    you need to read the manual first because sometimes the technical
    support is not good enough and you have to twist it out by yourself
    like us.

    Victor


  11. Re: Issue: Adding new disk from SAN (EMC) to Solaris 10 OS


    steeles wrote:
    > Would like to expand one of partition which is alread on SAN, and already
    > assign another 100 gb, but on Solaris 10, using format, couldn't see that
    > new 100gb disk.
    > even after reboot, still can't see new disk,
    >
    > What could be wrong? And how to know the disk has been added correctly?
    >
    > Thanks a bunch.

    1. At first runa luxadm probe to see the HBAs.

    2. Then try with /etc/powermt display dev=all --- to see the current
    paths.

    3. With devfsadm -C you will recognize the new devices. If you are
    thinking about rebooting the system try on this way: reboot -l -- -r

    4. Check using format y you have any news.

    5. In order to do a further research I would try probing the devices
    from the OBP.

    Good Luck!
    Sebastian.


  12. Re: Issue: Adding new disk from SAN (EMC) to Solaris 10 OS


    steeles wrote:
    > How to tell if the disk has been added correctly? Any file gets changed when
    > SAN guy added extra disk space?


    Mostly likely there is no file indicating these if "format" could not
    see these changes. Right now although your SAN guy have seen this
    extra 100gb using his software, maybe he missed one step, e.g. growing
    this initiator/device which is similar to "growfs". If you start it
    over, then the problem is absolutely from his side. Do not forget
    backing up before start it.

    But I really think EMC should provide assistance.

    Good luck!
    Victor


  13. Re: Issue: Adding new disk from SAN (EMC) to Solaris 10 OS


    victorfeng1973@yahoo.com wrote:
    > steeles wrote:
    > > How to tell if the disk has been added correctly? Any file gets changed when
    > > SAN guy added extra disk space?

    >
    > Mostly likely there is no file indicating these if "format" could not
    > see these changes. Right now although your SAN guy have seen this
    > extra 100gb using his software, maybe he missed one step, e.g. growing
    > this initiator/device which is similar to "growfs". If you start it
    > over, then the problem is absolutely from his side. Do not forget
    > backing up before start it.
    >
    > But I really think EMC should provide assistance.
    >
    > Good luck!
    > Victor


    format doesnt see the drive after reconfig reboot. this is what I am
    getting from the OP's post.

    OP has to specify if they are using Sun Leadville drivers / using the
    Emulex drivers and doing persistent binding and sd.conf entries
    manually. Talk to your SAN guy and have him check if he has forgot any
    thing from his end. If he hasn't I would assume it is on the host side
    as the host already sees some devices from the SAN.

    HTH


+ Reply to Thread