Problem Re-Installing Sun One App Server 7 on Solaris 8 - SUN

This is a discussion on Problem Re-Installing Sun One App Server 7 on Solaris 8 - SUN ; I will try my best to describe my problem. Hopefully I am posting to the right forums also. I successfully installed Sun One App Server 7 Standard Edition on Solaris 8. It was installed on a mounted secondary hard disk. ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: Problem Re-Installing Sun One App Server 7 on Solaris 8

  1. Problem Re-Installing Sun One App Server 7 on Solaris 8

    I will try my best to describe my problem. Hopefully I am posting to
    the right forums also.

    I successfully installed Sun One App Server 7 Standard Edition on
    Solaris 8. It was installed on a mounted secondary hard disk. That hard
    disk has since gone bad. I bought a new hard disk and have that
    mounted.

    I want to install Sun One App Server 7 again. I am installing through
    the GUI, but do not the options to install the server even though it is
    completely gone. I guess the installer seems to think that the product
    is already installed, even though the previous hard disk with all of
    the application server files are gone. Is there any way to uninstall or
    remove the installed status of the application server so I can
    reinstall?

    Thanks.


  2. Re: Problem Re-Installing Sun One App Server 7 on Solaris 8

    chungste@gmail.com wrote:
    > I will try my best to describe my problem. Hopefully I am posting to
    > the right forums also.
    >
    > I successfully installed Sun One App Server 7 Standard Edition on
    > Solaris 8. It was installed on a mounted secondary hard disk. That hard
    > disk has since gone bad. I bought a new hard disk and have that
    > mounted.
    >
    > I want to install Sun One App Server 7 again. I am installing through
    > the GUI, but do not the options to install the server even though it is
    > completely gone. I guess the installer seems to think that the product
    > is already installed, even though the previous hard disk with all of
    > the application server files are gone. Is there any way to uninstall or
    > remove the installed status of the application server so I can
    > reinstall?
    >


    It is perhaps installed as a package, and the package information in
    /var/sadm is still there.
    If you do not know the package name, try

    pkginfo | egrep -i "sun|one|app server"
    and remove the unwanted package with

    pkgrm package


    --
    Michael Tosch @ hp : com

  3. Re: Problem Re-Installing Sun One App Server 7 on Solaris 8

    chungste@gmail.com wrote:
    > I will try my best to describe my problem. Hopefully I am posting to
    > the right forums also.
    >
    > I successfully installed Sun One App Server 7 Standard Edition on
    > Solaris 8. It was installed on a mounted secondary hard disk. That hard
    > disk has since gone bad. I bought a new hard disk and have that
    > mounted.
    >
    > I want to install Sun One App Server 7 again. I am installing through
    > the GUI, but do not the options to install the server even though it is
    > completely gone. I guess the installer seems to think that the product
    > is already installed, even though the previous hard disk with all of
    > the application server files are gone. Is there any way to uninstall or
    > remove the installed status of the application server so I can
    > reinstall?
    >
    > Thanks.
    >


    Try deleting the productregistry file under /var/sadm.

  4. Re: Problem Re-Installing Sun One App Server 7 on Solaris 8

    SUN may use /etc/opt /var/opt and /opt folders, along with the PKG
    registry to determine if a package is installed or not.

    So, please clean up SUN One AppServer stuff from above folders and
    registry and retry. That should work.

    -Dexthor.


+ Reply to Thread