Can't install Multipath I/O on WS2008 Enterprise - Storage

This is a discussion on Can't install Multipath I/O on WS2008 Enterprise - Storage ; I'm unable to install Multipath I/O in WS 2008 Enterprise. So far I've tried: - installing as two separate users, both with administrator permissions - using server manager and servermanagercmd - verifying the files - multiple attempts with lots of ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: Can't install Multipath I/O on WS2008 Enterprise

  1. Can't install Multipath I/O on WS2008 Enterprise

    I'm unable to install Multipath I/O in WS 2008 Enterprise. So far I've tried:
    - installing as two separate users, both with administrator permissions
    - using server manager and servermanagercmd
    - verifying the files
    - multiple attempts with lots of rebooting.

    I successfully installed another feature (telnet client) to verify that
    feature installation works. The most relevant CBS long entries follow.

    Needless to say, this adversely affects my ability to do muultipathing.

    Thanks for any suggestions or advice.

    --------
    09:09:37, Info CSI 00000012 Performing 1 operations; 1
    are not lock/unlock and follow:
    LockComponentPath (10): flags: 0 comp: {l:16
    b:2f029ab938c3c80110000000cc13ec16} pathid: {l:16
    b:2f029ab938c3c80111000000cc13ec16} path:
    [l:238{119}]"\SystemRoot\WinSxS\amd64_microsoft-windows-m..evicespecificmodule_31bf3856ad364e35_6.0.6001.1 8000_none_db156ea6cdb9436e"
    pid: 13cc starttime: 128567233273887431 (0x01c8c337ad0b7ac7)
    2008-05-31 09:09:37, Info CSI 00000013 Performing 1
    operations; 1 are not lock/unlock and follow:
    LockComponentPath (10): flags: 0 comp: {l:16
    b:7f639cb938c3c80112000000cc13ec16} pathid: {l:16
    b:7f639cb938c3c80113000000cc13ec16} path:
    [l:226{113}]"\SystemRoot\WinSxS\amd64_microsoft-windows-wmi-mofinstaller_31bf3856ad364e35_6.0.6001.18000_none_ 6e3bfabfe41e1e82"
    pid: 13cc starttime: 128567233273887431 (0x01c8c337ad0b7ac7)
    2008-05-31 09:09:40, Error CSI
    00000001@2008/5/31:16:09:40.884 (F) Logged @2008/5/31:16:09:38.061 :
    [ml:100{50},l:98{49}]"MOF (install online) $(runtime.wbem)\dsmtrace.mof"
    [gle=0x80004005]
    2008-05-31 09:09:40, Error CSI
    00000002@2008/5/31:16:09:40.884 (F) CMIADAPTER: Inner Error Message from AI
    HRESULT = 8004402f [Error,Facility=FACILITY_ITF,Code=16431 (0x402f)]
    [
    (null)
    ]
    [gle=0x80004005]
    2008-05-31 09:09:40, Error CSI
    00000003@2008/5/31:16:09:40.884 (F) CMIADAPTER: AI failed. HRESULT = 8004402f
    [Error,Facility=FACILITY_ITF,Code=16431 (0x402f)]
    Element:
    [84]" name="$(runtime.wbem)\dsmtrace.mof" />"
    [gle=0x80004005]
    2008-05-31 09:09:40, Error CSI
    00000014@2008/5/31:16:09:40.884 (F)
    d:\rtm\base\wcp\cmiadapter\installers.cpp(356): Error 8004402f
    [Error,Facility=FACILITY_ITF,Code=16431 (0x402f)] originated in function
    Windows::WCP::CmiAdapter::CMIWrapperBasicInstaller ::ResolveAndInvokeInstaller
    expression: hr
    [gle=0x80004005]
    2008-05-31 09:09:44, Error CSI
    00000004@2008/5/31:16:09:44.862 (F) CMIADAPTER: Exiting with HRESULT code =
    8004402f [Error,Facility=FACILITY_ITF,Code=16431 (0x402f)].
    [gle=0x80004005]


  2. Re: Can't install Multipath I/O on WS2008 Enterprise

    You can't install it because it is already built into Windows 2008, so is
    iSCSI. It is updated through hotfixes and Service Packs, not via new
    releases of MPIO.

    "WSuser" wrote in message
    news:EDD743E6-C667-4BC5-9537-CB7C8C65B92A@microsoft.com...
    > I'm unable to install Multipath I/O in WS 2008 Enterprise. So far I've
    > tried:
    > - installing as two separate users, both with administrator permissions
    > - using server manager and servermanagercmd
    > - verifying the files
    > - multiple attempts with lots of rebooting.
    >
    > I successfully installed another feature (telnet client) to verify that
    > feature installation works. The most relevant CBS long entries follow.
    >
    > Needless to say, this adversely affects my ability to do muultipathing.
    >
    > Thanks for any suggestions or advice.
    >
    > --------
    > 09:09:37, Info CSI 00000012 Performing 1 operations; 1
    > are not lock/unlock and follow:
    > LockComponentPath (10): flags: 0 comp: {l:16
    > b:2f029ab938c3c80110000000cc13ec16} pathid: {l:16
    > b:2f029ab938c3c80111000000cc13ec16} path:
    > [l:238{119}]"\SystemRoot\WinSxS\amd64_microsoft-windows-m..evicespecificmodule_31bf3856ad364e35_6.0.6001.1 8000_none_db156ea6cdb9436e"
    > pid: 13cc starttime: 128567233273887431 (0x01c8c337ad0b7ac7)
    > 2008-05-31 09:09:37, Info CSI 00000013 Performing 1
    > operations; 1 are not lock/unlock and follow:
    > LockComponentPath (10): flags: 0 comp: {l:16
    > b:7f639cb938c3c80112000000cc13ec16} pathid: {l:16
    > b:7f639cb938c3c80113000000cc13ec16} path:
    > [l:226{113}]"\SystemRoot\WinSxS\amd64_microsoft-windows-wmi-mofinstaller_31bf3856ad364e35_6.0.6001.18000_none_ 6e3bfabfe41e1e82"
    > pid: 13cc starttime: 128567233273887431 (0x01c8c337ad0b7ac7)
    > 2008-05-31 09:09:40, Error CSI
    > 00000001@2008/5/31:16:09:40.884 (F) Logged @2008/5/31:16:09:38.061 :
    > [ml:100{50},l:98{49}]"MOF (install online) $(runtime.wbem)\dsmtrace.mof"
    > [gle=0x80004005]
    > 2008-05-31 09:09:40, Error CSI
    > 00000002@2008/5/31:16:09:40.884 (F) CMIADAPTER: Inner Error Message from
    > AI
    > HRESULT = 8004402f [Error,Facility=FACILITY_ITF,Code=16431 (0x402f)]
    > [
    > (null)
    > ]
    > [gle=0x80004005]
    > 2008-05-31 09:09:40, Error CSI
    > 00000003@2008/5/31:16:09:40.884 (F) CMIADAPTER: AI failed. HRESULT =
    > 8004402f
    > [Error,Facility=FACILITY_ITF,Code=16431 (0x402f)]
    > Element:
    > [84]" > name="$(runtime.wbem)\dsmtrace.mof" />"
    > [gle=0x80004005]
    > 2008-05-31 09:09:40, Error CSI
    > 00000014@2008/5/31:16:09:40.884 (F)
    > d:\rtm\base\wcp\cmiadapter\installers.cpp(356): Error 8004402f
    > [Error,Facility=FACILITY_ITF,Code=16431 (0x402f)] originated in function
    > Windows::WCP::CmiAdapter::CMIWrapperBasicInstaller ::ResolveAndInvokeInstaller
    > expression: hr
    > [gle=0x80004005]
    > 2008-05-31 09:09:44, Error CSI
    > 00000004@2008/5/31:16:09:44.862 (F) CMIADAPTER: Exiting with HRESULT code
    > =
    > 8004402f [Error,Facility=FACILITY_ITF,Code=16431 (0x402f)].
    > [gle=0x80004005]
    >



  3. Re: Can't install Multipath I/O on WS2008 Enterprise

    I don't think that's quite right. Multipathing is an optional feature in
    WS2008 and is installed using the server manager. At least in my version of
    the OS, it was not preinstalled and has to be selected and installed. There
    are a number of such optional features and I have successfully installed 7 of
    the 35 options. However, Multipath installation does not succeed.

    Put another way, I'm not trying to install the WS2003 MPIO, I'm trying to
    install the options WS2008 Multipath feature.

    Thanks for responding.


    "Me" wrote:

    > You can't install it because it is already built into Windows 2008, so is
    > iSCSI. It is updated through hotfixes and Service Packs, not via new
    > releases of MPIO.



  4. Re: Can't install Multipath I/O on WS2008 Enterprise

    Please check the event logs. When MPIO is running it's events are under
    "source mpio" but during installation it may be something else.

    Also, check the setupapi.log ... should be located under
    %SystemDrive%\Windows\

    WSuser wrote:
    > I don't think that's quite right. Multipathing is an optional feature in
    > WS2008 and is installed using the server manager. At least in my version of
    > the OS, it was not preinstalled and has to be selected and installed. There
    > are a number of such optional features and I have successfully installed 7 of
    > the 35 options. However, Multipath installation does not succeed.
    >
    > Put another way, I'm not trying to install the WS2003 MPIO, I'm trying to
    > install the options WS2008 Multipath feature.
    >
    > Thanks for responding.
    >
    >
    > "Me" wrote:
    >
    >> You can't install it because it is already built into Windows 2008, so is
    >> iSCSI. It is updated through hotfixes and Service Packs, not via new
    >> releases of MPIO.

    >


+ Reply to Thread