PowerPath SLES9 SP1 installation issue - Storage

This is a discussion on PowerPath SLES9 SP1 installation issue - Storage ; Hi, I'm trying to install PowerPath package on a SLES9.0 SP1 32Bits machine. According EMCpowerlink website, I must use latest version of PowerPath which is: EMCpower.LINUX-4.4.0-343.sles.i386 But installation failed complaining as follow: ------------------------------ house2:~/SAN/PowerPath/v4.4.0 # rpm -ivh EMCpower.LINUX-4.4.0-343.sles.i386.rpm Preparing... ########################################### ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: PowerPath SLES9 SP1 installation issue

  1. PowerPath SLES9 SP1 installation issue

    Hi,

    I'm trying to install PowerPath package on a SLES9.0 SP1 32Bits
    machine. According EMCpowerlink website, I must use latest version of
    PowerPath which is:

    EMCpower.LINUX-4.4.0-343.sles.i386

    But installation failed complaining as follow:

    ------------------------------
    house2:~/SAN/PowerPath/v4.4.0 # rpm -ivh
    EMCpower.LINUX-4.4.0-343.sles.i386.rpm
    Preparing... ###########################################
    [100%]
    1:EMCpower.LINUX ###########################################
    [100%]
    PowerPath driver version magic mismatch
    error: %post(EMCpower.LINUX-4.4.0-343) scriptlet failed, exit status 1
    -----------------------------

    My machine is running SP1 *only* and complies with EMC requirements:

    ----------------------------
    house2:~/SAN/PowerPath/v4.4.0 # SPident

    CONCLUSION: ServicePack Level: SLES-9-i386-SP1 => up-to-date
    ----------------------------


    My HBA drivers appears to be good an up to date for SLES9.0 SP1

    ----------------------------
    house2:~/SAN/PowerPath/v4.4.0 # cat /proc/scsi/qla2xxx/1
    QLogic PCI to Fibre Channel Host Adapter for QLE2360:
    Firmware version 3.03.01 IPX, Driver version 8.00.00
    Entry address = f88a1a20
    ISP: ISP2322, Serial# U43773
    Request Queue = 0x37680000, Response Queue = 0x375a0000
    Request Queue count = 4096, Response Queue count = 512
    Total number of active commands = 0
    Total number of interrupts = 4562
    Device queue depth = 0x20
    Number of free request entries = 3891
    Number of mailbox timeouts = 0
    Number of ISP aborts = 0
    Number of loop resyncs = 0
    Number of retries for empty slots = 0
    Number of reqs in pending_q= 0, retry_q= 0, done_q= 0, scsi_retry_q= 0
    Host adapter:loop state = , flags = 0x1813
    Dpc flags = 0x80000
    MBX flags = 0x0
    Link down Timeout = 045
    Port down retry = 045
    Login retry count = 045
    Commands retried with dropped frame(s) = 0
    Product ID = 4953 5020 2020 0005


    SCSI Device Information:
    scsi-qla0-adapter-node=200000e08b1f7d2f;
    scsi-qla0-adapter-port=210000e08b1f7d2f;
    scsi-qla0-target-0=500601683021a261;

    SCSI LUN Information:
    (Id:Lun) * - indicates lun is not registered with the OS.
    ( 0: 0): Total reqs 133, Pending reqs 0, flags 0x0, 0:0:00 00
    ( 0: 1): Total reqs 43, Pending reqs 0, flags 0x0, 0:0:00 00
    ---------------------



    Also, I can say that I have the same trouble with a second machine
    running SLES9.0 SP2 this time and get exact same error message. With
    SLES9.0 SP2, the default QLA driver is 8.00.02 but produce exact same
    error.

    Does anyone knows why PowerPath complain about Driver version mismatch
    and how to solve this ?


  2. Re: PowerPath SLES9 SP1 installation issue

    This error comes up when PowerPath encounters an unsupported version of
    the SUSE Kernel.
    Ensure that your particular Kernel version is supported by checking the
    EMC Support Matrix


  3. Re: PowerPath SLES9 SP1 installation issue

    Exact. But here is the funny part. EMC claims support for SLES9 SP1
    which is running kernel revision 139. OR looks what's happen when you
    switch the installation of the RPM verbose enough:

    house2:~/SAN/PowerPath/v4.4.0 # rpm -ivvh
    EMCpower.LINUX-4.4.0-343.sles.i386.rpm
    [...]
    + ref_driver=scsi_mod
    ++ modinfo scsi_mod
    ++ sed -n '/^vermagic:/s/^vermagic: *//p'
    + ref_version=2.6.5-7.139-smp SMP 586 REGPARM gcc-3.3
    ++ modinfo
    //etc/opt/emcpower/EMCpower.LINUX-4.4.0/bin/driver/emcp_slessmp
    ++ sed -n '/^vermagic:/s/^vermagic: *//p'
    + pp_version=2.6.5-7.151-smp SMP 586 REGPARM gcc-3.3
    + '[' suse = redhat ']'
    '[' '2.6.5-7.151-smp SMP 586 REGPARM gcc-3.3' = '2.6.5-7.139-smp SMP
    586 REGPARM gcc-3.3' ']'
    + return 1
    + '[' 1 '!=' 0 ']'
    + echo 'PowerPath driver version magic mismatch'
    PowerPath driver version magic mismatch
    + rpm_reset 8020
    + exit 1
    D: install: waitpid(8033) rc 8033 status 100
    error: %post(EMCpower.LINUX-4.4.0-343) scriptlet failed, exit status 1
    + rpm_proc=8020
    D: closed db index /var/lib/rpm/Pubkeys
    + ps -p 8020
    D: closed db index /var/lib/rpm/Filemd5s
    D: closed db index /var/lib/rpm/Sha1header
    D: closed db index /var/lib/rpm/Sigmd5
    D: closed db index /var/lib/rpm/Installtid
    D: closed db index /var/lib/rpm/Provideversion
    D: closed db index /var/lib/rpm/Requireversion
    D: closed db index /var/lib/rpm/Dirnames
    D: closed db index /var/lib/rpm/Triggername
    D: closed db index /var/lib/rpm/Conflictname
    D: closed db index /var/lib/rpm/Providename
    D: closed db index /var/lib/rpm/Requirename
    D: closed db index /var/lib/rpm/Group
    D: closed db index /var/lib/rpm/Basenames
    D: closed db index /var/lib/rpm/Name
    D: closed db index /var/lib/rpm/Packages
    D: closed db environment /var/lib/rpm/Packages
    house2:~/SAN/PowerPath/v4.4.0 # + '[' 1 = 0 ']'
    + '[' 1 ']'
    + rpm -e --noscripts EMCpower.LINUX-4.4.0-343
    + '[' 0 = 0 ']'
    + exit 1


    Have a closer look above and notice the condition:

    2.6.5-7.151-smp SMP 586 REGPARM gcc-3.3' = '2.6.5-7.139-smp SMP 586
    REGPARM gcc-3.3

    You are not dreaming. For EMC, a SLES9 SP1 is a machine having kernel
    revision 151 !!! And they are not saying anything about anywhere !!!

    After loaded this kernel revision, everything is ok. But why claiming
    support for SP1 then ?

    Thanks Conor.

    Conor a écrit :

    > This error comes up when PowerPath encounters an unsupported version of
    > the SUSE Kernel.
    > Ensure that your particular Kernel version is supported by checking the
    > EMC Support Matrix



+ Reply to Thread