SSH client runs OpenSSH 4.2 on HP-UX 11.23
SSH server runs OpenSSH 3.5 on Solaris 8

I put the public key of the user on the client box to the $HOME/.ssh/
authorized_keys file on the server. Also, I checked all the obvious
things like permissions on files and the .ssh directory and DNS and
still cannot get it to work without passwords. Any idea what's going
on?

# ssh -v -v -v bava


debug1: Host 'bava' is known and matches the DSA host key.
debug1: Found key in /home/user1/.ssh/known_hosts:1
debug2: bits set: 506/1024
debug1: ssh_dss_verify: signature correct
debug2: kex_derive_keys
debug2: set_newkeys: mode 1
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug2: set_newkeys: mode 0
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug2: service_accept: ssh-userauth
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug2: key: /home/user1/.ssh/id_rsa (00000000)
debug2: key: /home/user1/.ssh/id_dsa (4004e8e0)
debug1: Authentications that can continue: publickey,password
debug3: start over, passed a different list publickey,password
debug3: preferred publickey,keyboard-interactive,password
debug3: authmethod_lookup publickey
debug3: remaining preferred: keyboard-interactive,password
debug3: authmethod_is_enabled publickey
debug1: Next authentication method: publickey
debug1: Trying private key: /home/user1/.ssh/id_rsa
debug3: no such identity: /home/user1/.ssh/id_rsa
debug1: Offering public key: /home/user1/.ssh/id_dsa
debug3: send_pubkey_test
debug2: we sent a publickey packet, wait for reply
debug1: Authentications that can continue: publickey,password
debug2: we did not send a packet, disable method
debug3: authmethod_lookup password
debug3: remaining preferred: ,password
debug3: authmethod_is_enabled password
debug1: Next authentication method: password
user1@bava's password: