PAM authentication not working after update ? - SSH

This is a discussion on PAM authentication not working after update ? - SSH ; hi I'm using SSH-2.0-OpenSSH_4.3 on fedora core 5. After updating to this latest package I had to set usePAM no in /etc/ssh/sshd_config in order to get logins. I'd like to use PAM as we use history and expiry. Any idea ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: PAM authentication not working after update ?

  1. PAM authentication not working after update ?

    hi
    I'm using SSH-2.0-OpenSSH_4.3 on fedora core 5. After updating to this
    latest package I had to set usePAM no in /etc/ssh/sshd_config in order
    to get logins. I'd like to use PAM as we use history and expiry. Any
    idea what has changed ? /etc/pam.d/system-auth is unchanged as was
    /etc/ssh/sshd_config
    Elaine


  2. Re: PAM authentication not working after update ?

    >>>>> "E" == cmap writes:

    E> hi I'm using SSH-2.0-OpenSSH_4.3 on fedora core 5. After updating
    E> to this latest package I had to set usePAM no in
    E> /etc/ssh/sshd_config in order to get logins. I'd like to use PAM as
    E> we use history and expiry. Any idea what has changed ?
    E> /etc/pam.d/system-auth is unchanged as was /etc/ssh/sshd_config
    E> Elaine

    If you don't get a better suggestion, check the syslog and debug messages
    from sshd, and/or set debugging in the relevant PAM modules to find out
    why its rejecting the logins.

    --
    Richard Silverman
    res@qoxp.net


  3. Re: PAM authentication not working after update ?

    hi
    I managed to resolve by copying across the system-auth-ac from another
    machine. They are both supposedly identical but only one had the issue.
    At least its fixed now.
    E
    Richard E. Silverman wrote:
    > >>>>> "E" == cmap writes:

    >
    > E> hi I'm using SSH-2.0-OpenSSH_4.3 on fedora core 5. After updating
    > E> to this latest package I had to set usePAM no in
    > E> /etc/ssh/sshd_config in order to get logins. I'd like to use PAM as
    > E> we use history and expiry. Any idea what has changed ?
    > E> /etc/pam.d/system-auth is unchanged as was /etc/ssh/sshd_config
    > E> Elaine
    >
    > If you don't get a better suggestion, check the syslog and debug messages
    > from sshd, and/or set debugging in the relevant PAM modules to find out
    > why its rejecting the logins.
    >
    > --
    > Richard Silverman
    > res@qoxp.net



  4. Re: PAM authentication not working after update ?

    hi
    I managed to resolve by copying across the system-auth-ac from another
    machine. They are both supposedly identical but only one had the issue.
    At least its fixed now.
    E
    Richard E. Silverman wrote:
    > >>>>> "E" == cmap writes:

    >
    > E> hi I'm using SSH-2.0-OpenSSH_4.3 on fedora core 5. After updating
    > E> to this latest package I had to set usePAM no in
    > E> /etc/ssh/sshd_config in order to get logins. I'd like to use PAM as
    > E> we use history and expiry. Any idea what has changed ?
    > E> /etc/pam.d/system-auth is unchanged as was /etc/ssh/sshd_config
    > E> Elaine
    >
    > If you don't get a better suggestion, check the syslog and debug messages
    > from sshd, and/or set debugging in the relevant PAM modules to find out
    > why its rejecting the logins.
    >
    > --
    > Richard Silverman
    > res@qoxp.net



+ Reply to Thread