amd64 ssh hangs - SSH

This is a discussion on amd64 ssh hangs - SSH ; I'm having an odd error where my SSH connection to my amd64 server occasionally hangs and eventually times out. From my perspective it seems to happen randomly and has little relation with how long the session has been established. A ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: amd64 ssh hangs

  1. amd64 ssh hangs

    I'm having an odd error where my SSH connection to my amd64 server
    occasionally hangs and eventually times out. From my perspective it
    seems to happen randomly and has little relation with how long the
    session has been established. A netstat on the server shows that bytes
    are queuing up in the recieve queue for the process (the client is just
    fine), and a quick backtrace shows that the process is stuck in
    /lib64/tls/libc.so.6 in __read_nocancel. Is this a known bug?

    Client: FC3
    Server: RHEL4 AS Update 3 for x86_64 (OpenSSH 3.9p1, OpenSSL 0.97a) on
    8-way Opteron.

    Thanks
    -Mike


  2. Re: amd64 ssh hangs

    In comp.security.ssh mlartz@gmail.com:
    > I'm having an odd error where my SSH connection to my amd64 server
    > occasionally hangs and eventually times out. From my perspective it
    > seems to happen randomly and has little relation with how long the
    > session has been established. A netstat on the server shows that bytes
    > are queuing up in the recieve queue for the process (the client is just
    > fine), and a quick backtrace shows that the process is stuck in
    > /lib64/tls/libc.so.6 in __read_nocancel. Is this a known bug?


    Bugs get fixed if they are known.

    > Client: FC3
    > Server: RHEL4 AS Update 3 for x86_64 (OpenSSH 3.9p1, OpenSSL 0.97a) on
    > 8-way Opteron.


    You could just open a ticket to RH, you get some support with
    buying RHEL. Or compile the latest openssh (4.3p2) or so, see if
    the problem persist and then open up a ticket to RH.

    I'd try out the latest client in addition in any case.

    BTW
    Since you might be new to usenet, this is *NOT* a groups.google
    forum, even if it looks like this to you, please try:

    "Google Groups users please read - Howto reply properly"
    http://groups.google.com/support/bin...y?answer=14213

    --
    Michael Heiming (X-PGP-Sig > GPG-Key ID: EDD27B94)
    mail: echo zvpunry@urvzvat.qr | perl -pe 'y/a-z/n-za-m/'
    #bofh excuse 387: Your computer's union contract is set to
    expire at midnight.

  3. Re: amd64 ssh hangs

    > > /lib64/tls/libc.so.6 in __read_nocancel. Is this a known bug?
    >
    > Bugs get fixed if they are known.


    Which was the point of the question. Getting new software into our lab
    isn't exactly easy (policy), and I just wanted to see if anyone had
    experienced similar errors in the past and could point me in the right
    upgrade direction. Thanks for the RH suggestions, though.

    > BTW
    > Since you might be new to usenet, this is *NOT* a groups.google
    > forum, even if it looks like this to you, please try:
    >
    > "Google Groups users please read - Howto reply properly"
    > http://groups.google.com/support/bin...y?answer=14213


    Not quite sure I understand ... did I do something wrong? I have used
    Usenet before, I just like the Google Groups interface.


  4. Re: amd64 ssh hangs

    In comp.security.ssh mlartz@gmail.com:
    >> > /lib64/tls/libc.so.6 in __read_nocancel. Is this a known bug?

    >>
    >> Bugs get fixed if they are known.


    > Which was the point of the question. Getting new software into our lab
    > isn't exactly easy (policy), and I just wanted to see if anyone had
    > experienced similar errors in the past and could point me in the right
    > upgrade direction. Thanks for the RH suggestions, though.


    Just for testing purposes, installed to /usr/local temporary, as
    you would certainly speed up RH's reaction if you can prove that
    this bug doesn't happen with a more recent version of openssh.

    [..]

    >> "Google Groups users please read - Howto reply properly"
    >> http://groups.google.com/support/bin...y?answer=14213


    > Not quite sure I understand ... did I do something wrong? I have used
    > Usenet before, I just like the Google Groups interface.


    No, nothing. Just a precaution, sadly enough about 95% of G2
    users get caught by the dumb G3 default reply mode, not knowing
    that groups.google is just an http interface to usenet.

    --
    Michael Heiming (X-PGP-Sig > GPG-Key ID: EDD27B94)
    mail: echo zvpunry@urvzvat.qr | perl -pe 'y/a-z/n-za-m/'
    #bofh excuse 388: Bad user karma.

+ Reply to Thread