SSH into Win Server 2003 fails - SSH

This is a discussion on SSH into Win Server 2003 fails - SSH ; Hello! I have a bash script running on Linux that SCPs files from a Windows Server 2003 box daily using public/private keys. The Windows box has cygwin installed of course. Every so often the SCP command in the script fails ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: SSH into Win Server 2003 fails

  1. SSH into Win Server 2003 fails

    Hello!

    I have a bash script running on Linux that SCPs files from a Windows
    Server 2003 box daily using public/private keys. The Windows box has
    cygwin installed of course.

    Every so often the SCP command in the script fails with the error:

    C:\cygwin\usr\sbin\sshd.exe (264): *** could not load user32, Win32
    error 0

    Last night my script failed at 4:05 am. It was rerun at 4:15 and again
    at 4:30 with the same results. When it was rerun again at 9:00am it
    worked fine; apparently the issue having resolved itself.

    This is the second time this has happened in the one month the script
    has been in operation.

    I think it is some issue with the Windows box. I need some help on how
    to trouble shoot this, so please drop off any tips you may have.

    Thanks, Chad


  2. Re: SSH into Win Server 2003 fails


    cevans81 schrieb:

    > Hello!
    >
    > I have a bash script running on Linux that SCPs files from a Windows
    > Server 2003 box daily using public/private keys. The Windows box has
    > cygwin installed of course.
    >
    > Every so often the SCP command in the script fails with the error:
    >
    > C:\cygwin\usr\sbin\sshd.exe (264): *** could not load user32, Win32
    > error 0
    >


    Hello,
    I have the same message in the OpenSSHd.log:
    C:\Programme\OpenSSH\usr\sbin\sshd.exe (3820): *** could not load
    user32, Win32 error 0
    C:\Programme\OpenSSH\usr\sbin\sshd.exe (1204): *** could not load
    user32, Win32 error 0

    It happens after closing the first connection. Every following
    connection is refused. If I try to restart the service, it fails. Only
    a reboot of the server gets it back online.
    Here some further informations:
    Windows 2003 Server german SP1 full patched
    OpenSSH for Windows v3.8.1p1-1

    any suggestion?

    regards

    Carsten


+ Reply to Thread