Tru64 5.1 fails on configure on zlib - SSH

This is a discussion on Tru64 5.1 fails on configure on zlib - SSH ; I have a Tru64 5.1 system that I am trying to install OpenSSH on. I have tried a few versions and the configure script fails in the same place. The message is: configure: error: *** zlib missing - please install ...

+ Reply to Thread
Results 1 to 5 of 5

Thread: Tru64 5.1 fails on configure on zlib

  1. Tru64 5.1 fails on configure on zlib

    I have a Tru64 5.1 system that I am trying to install OpenSSH on. I have
    tried a few versions and the configure script fails in the same place. The
    message is:

    configure: error: *** zlib missing - please install first or check
    config.log ***

    Now I have gnu tar insatlled and have zlib.h in /usr/sys/include/streamsm/.
    I also added the option:

    --with-zlib=/usr/sys/include/streamsm/

    Still no joy. What do I need to do to get this working? Do I maybe need
    to upgrade zlib? GNU Tar version 1.13. Thanks,

    fybar

  2. Re: Tru64 5.1 fails on configure on zlib

    fybar lothgorian wrote:
    > I have a Tru64 5.1 system that I am trying to install OpenSSH on. I have
    > tried a few versions and the configure script fails in the same place. The
    > message is:
    >
    > configure: error: *** zlib missing - please install first or check
    > config.log ***
    >
    > Now I have gnu tar insatlled and have zlib.h in /usr/sys/include/streamsm/.
    > I also added the option:
    >
    > --with-zlib=/usr/sys/include/streamsm/
    >
    > Still no joy. What do I need to do to get this working? Do I maybe need
    > to upgrade zlib? GNU Tar version 1.13. Thanks,
    >
    > fybar


    Perhaps you should look in 'config.log', or try running 'sh -x configure' to
    see what happens?

  3. Re: Tru64 5.1 fails on configure on zlib

    Nico Kadel-Garcia wrote in
    news:4913F402.7060100@gmail.com:

    > fybar lothgorian wrote:
    >> I have a Tru64 5.1 system that I am trying to install OpenSSH on. I
    >> have tried a few versions and the configure script fails in the same
    >> place. The message is:
    >>
    >> configure: error: *** zlib missing - please install first or check
    >> config.log ***
    >>
    >> Now I have gnu tar insatlled and have zlib.h in
    >> /usr/sys/include/streamsm/. I also added the option:
    >>
    >> --with-zlib=/usr/sys/include/streamsm/
    >>
    >> Still no joy. What do I need to do to get this working? Do I maybe
    >> need to upgrade zlib? GNU Tar version 1.13. Thanks,
    >>
    >> fybar

    >
    > Perhaps you should look in 'config.log', or try running 'sh -x
    > configure' to see what happens?


    This is what I see just before the only mention of zlib and it didn't seem
    telling:

    | #define HAVE_DIRNAME 1
    | #define HAVE_LIBGEN_H 1
    | #define HAVE_BASENAME 1
    | /* end confdefs.h. */
    |
    | /* Override any gcc2 internal prototype to avoid an error. */
    | #ifdef __cplusplus
    | extern "C"
    | #endif
    | /* We use char because int might match the return type of a gcc2
    | builtin and then its argument prototype would still apply. */
    | char deflate ();
    | int
    | main ()
    | {
    | deflate ();
    | ;
    | return 0;
    | }
    configure:8095: error: *** zlib missing - please install first or check
    config.log ***

    This IS from config.log, it refers to itself in the third person. sh -x
    did not give anything different than just running configure. Any other
    suggestions?

    fybar

  4. Re: Tru64 5.1 fails on configure on zlib

    fybar lothgorian wrote in
    news:Xns9B4F92DD6D4B4fybarnowherecom@69.16.185.250 :

    > Nico Kadel-Garcia wrote in
    > news:4913F402.7060100@gmail.com:
    >
    >> fybar lothgorian wrote:
    >>> I have a Tru64 5.1 system that I am trying to install OpenSSH on. I
    >>> have tried a few versions and the configure script fails in the same
    >>> place. The message is:
    >>>
    >>> configure: error: *** zlib missing - please install first or check
    >>> config.log ***
    >>>
    >>> Now I have gnu tar insatlled and have zlib.h in
    >>> /usr/sys/include/streamsm/. I also added the option:
    >>>
    >>> --with-zlib=/usr/sys/include/streamsm/
    >>>
    >>> Still no joy. What do I need to do to get this working? Do I maybe
    >>> need to upgrade zlib? GNU Tar version 1.13. Thanks,

    >
    > This IS from config.log, it refers to itself in the third person. sh
    > -x did not give anything different than just running configure. Any
    > other suggestions?


    Ok, I installed the latest version of zlib and I got past this error. I
    have to install a version of OpenSSL and I have 0.9.8g and when I try to
    run ./config I get an error with perl:

    $> ./config --prefix=/usr/local --openssldir=/usr/local/openssl
    Operating system: alpha-dec-tru64
    Can't locate strict.pm in @INC (@INC contains: /usr/lib/perl-
    5.005/lib/5.00503/alpha-dec_osf /usr/lib/perl-5.005/lib/5.00503
    /usr/lib/perl-5.005/lib/site_perl/5.005/alpha-dec_osf /usr/lib/perl-
    5.005/lib/site_perl/5.005 .) at ./Configure line 9.
    BEGIN failed--compilation aborted at ./Configure line 9.
    Can't locate strict.pm in @INC (@INC contains: /usr/lib/perl-
    5.005/lib/5.00503/alpha-dec_osf /usr/lib/perl-5.005/lib/5.00503
    /usr/lib/perl-5.005/lib/site_perl/5.005/alpha-dec_osf /usr/lib/perl-
    5.005/lib/site_perl/5.005 .) at ./Configure line 9.
    BEGIN failed--compilation aborted at ./Configure line 9.
    This system (tru64-alpha-cc) is not supported. See file INSTALL for
    details.

    The use strict directive is what the ./Configure script is balking at.
    Is this a problem with my perl installation? Any help appreciated.

    Thanks,

    fybar

  5. Re: Tru64 5.1 fails on configure on zlib

    fybar lothgorian wrote:
    > fybar lothgorian wrote in
    > news:Xns9B4F92DD6D4B4fybarnowherecom@69.16.185.250 :
    >
    >> Nico Kadel-Garcia wrote in
    >> news:4913F402.7060100@gmail.com:
    >>
    >>> fybar lothgorian wrote:
    >>>> I have a Tru64 5.1 system that I am trying to install OpenSSH on. I
    >>>> have tried a few versions and the configure script fails in the same
    >>>> place. The message is:
    >>>>
    >>>> configure: error: *** zlib missing - please install first or check
    >>>> config.log ***
    >>>>
    >>>> Now I have gnu tar insatlled and have zlib.h in
    >>>> /usr/sys/include/streamsm/. I also added the option:
    >>>>
    >>>> --with-zlib=/usr/sys/include/streamsm/
    >>>>
    >>>> Still no joy. What do I need to do to get this working? Do I maybe
    >>>> need to upgrade zlib? GNU Tar version 1.13. Thanks,

    >> This IS from config.log, it refers to itself in the third person. sh
    >> -x did not give anything different than just running configure. Any
    >> other suggestions?

    >
    > Ok, I installed the latest version of zlib and I got past this error. I
    > have to install a version of OpenSSL and I have 0.9.8g and when I try to
    > run ./config I get an error with perl:
    >
    > $> ./config --prefix=/usr/local --openssldir=/usr/local/openssl
    > Operating system: alpha-dec-tru64
    > Can't locate strict.pm in @INC (@INC contains: /usr/lib/perl-
    > 5.005/lib/5.00503/alpha-dec_osf /usr/lib/perl-5.005/lib/5.00503
    > /usr/lib/perl-5.005/lib/site_perl/5.005/alpha-dec_osf /usr/lib/perl-
    > 5.005/lib/site_perl/5.005 .) at ./Configure line 9.
    > BEGIN failed--compilation aborted at ./Configure line 9.
    > Can't locate strict.pm in @INC (@INC contains: /usr/lib/perl-
    > 5.005/lib/5.00503/alpha-dec_osf /usr/lib/perl-5.005/lib/5.00503
    > /usr/lib/perl-5.005/lib/site_perl/5.005/alpha-dec_osf /usr/lib/perl-
    > 5.005/lib/site_perl/5.005 .) at ./Configure line 9.
    > BEGIN failed--compilation aborted at ./Configure line 9.
    > This system (tru64-alpha-cc) is not supported. See file INSTALL for
    > details.
    >
    > The use strict directive is what the ./Configure script is balking at.
    > Is this a problem with my perl installation? Any help appreciated.
    >
    > Thanks,
    >
    > fybar


    Number one: use a contemporary operating system. Tru64 6.1 is not well
    supported anymore, HP is trying to migrate people to HPUX.

    Number two: do not expect up-to-date versions of open source tools to be able
    to compile on old systems. I went through this a lot, including with Tru64.

    Number three: which version of OpenSSH are you compiling? If it's the latest,
    you may just be that poor beggar who gets to find the incompatibilities with
    an OS or configuration and gets to point them out to the maintainers of the
    openssh 'p1' variants.

    Number four: is your Perl standard? Or do you have a system Perl and a
    /usr/local/bin/perl that someone installed manually (which I've seen happen,
    and drove me nuts!)

+ Reply to Thread