putty focus problem in XP - SSH

This is a discussion on putty focus problem in XP - SSH ; putty works fine in XP until i change the focus. upon returning to putty, the cursor becomes black, and so not visible with the default black background. more importantly, about half the time the characters are also rendered black on ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: putty focus problem in XP

  1. putty focus problem in XP

    putty works fine in XP until i change the focus. upon returning to
    putty, the cursor becomes black, and so not visible with the default
    black background. more importantly, about half the time the
    characters are also rendered black on black, making them not visible
    either. strangely, this is only for text that i type. the output of
    programs (mutt, vi, etc.) is totally fine. i don't think this is not
    a problem with putty, as on two other XP machines i've tested, things
    work fine. somehow i think my system is screwed up.

    perhaps relatedly, when i cursor over the putty window, the cursor
    switches to the text tool as usual. however, instead of turning white
    to accommodate the default black background of putty, it stays black
    and is hence not visible.

    i've cleaned the registry. uninstalled putty and re-installed several
    times. release 0.60. anyone have any ideas?? thanks.

  2. Re: putty focus problem in XP

    On 8 May, 13:16, bjarthur wrote:
    > putty works fine in XP until i change the focus. *upon returning to
    > putty, the cursor becomes black, and so not visible with the default
    > black background. *more importantly, about half the time the
    > characters are also rendered black on black, making them not visible
    > either. *strangely, this is only for text that i type. *the output of
    > programs (mutt, vi, etc.) is totally fine. *i don't think this is not
    > a problem with putty, as on two other XP machines i've tested, things
    > work fine. *somehow i think my system is screwed up.
    >
    > perhaps relatedly, when i cursor over the putty window, the cursor
    > switches to the text tool as usual. *however, instead of turning white
    > to accommodate the default black background of putty, it stays black
    > and is hence not visible.
    >
    > i've cleaned the registry. *uninstalled putty and re-installed several
    > times. *release 0.60. *anyone have any ideas?? *thanks.


    What are you Puttying *to*? I personally loathe the results of emacs c-
    mode coloring on top of Putty, and the results of the colorized 'ls'
    commands on Linux.

  3. Re: putty focus problem in XP

    > What are you Puttying *to*?

    i'm puttying to an OSX box, but does that matter?

    everything works fine on two other machines, both the cursor fore- &
    back-ground color as well as the pointer color when mousing over the
    window. but on this one machine, everything breaks when i return to
    putty after changing the focus. how could i have screwed up XP in
    such a way??

+ Reply to Thread