Hello everyone,
I'm having a big problem with Squid. tried versions 2.4 and 2, both
stable, on FreeBSD but I get the same problem. Access denied. No matter
what I do, squid answers access denied and I can't change it.

If anyone has any ideas about what can be wrong, i'd appreciate it.
Regards,
hjf

My config file is as follows

hierarchy_stoplist cgi-bin ?
acl QUERY urlpath_regex cgi-bin \?
no_cache deny QUERY
acl all src 0.0.0.0/0.0.0.0
acl manager proto cache_object
acl localhost src 127.0.0.1/255.255.255.255
acl clientesa src 192.168.2.0/255.255.255.0
acl clientesb src 200.45.198.0/255.255.255.0
acl SSL_ports port 443 563
acl Safe_ports port 80 # http
acl Safe_ports port 21 # ftp
acl Safe_ports port 443 563 # https, snews
acl Safe_ports port 70 # gopher
acl Safe_ports port 210 # wais
acl Safe_ports port 1025-65535 # unregistered ports
acl Safe_ports port 280 # http-mgmt
acl Safe_ports port 488 # gss-http
acl Safe_ports port 591 # filemaker
acl Safe_ports port 777 # multiling http
acl CONNECT method CONNECT
acl dstlocal dst 200.45.198.0/255.255.255.192

http_access allow manager localhost
#http_access allow dstlocal
http_access deny manager
http_access deny !Safe_ports
http_access deny CONNECT !SSL_ports
http_access allow localhost clientesa clientesb
icp_access allow all
http_access deny all

cache_replacement_policy heap LFUDA
memory_replacement_policy heap GDSF
uri_whitespace allow
cache_dir ufs /usr/local/squid/cache 10000 16 256
maximum_object_size 128 MB
cache_mem 300 MB
http_port 3128
visible_hostname proxy.mp-isp.com.ar
httpd_accel_host virtual
httpd_accel_port 80
httpd_accel_with_proxy on
httpd_accel_uses_host_header on
#anonymize_headers deny Accept-Encoding
#header_access Via deny all
#header_access X-Forwarded-For deny all
#header_access Accept-Encoding deny all

cache_effective_user squid
cache_effective_group squid

strip_query_terms off
emulate_httpd_log on