One website slow through Squid proxy, others are just fine - squid

This is a discussion on One website slow through Squid proxy, others are just fine - squid ; Hi, We have a weird problem: Our Squid proxy works just fine, transferrates etc are normal, except when accessing one specific website. When opening that site through the proxy it takes about 2 minutes before the site is actually loaded ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: One website slow through Squid proxy, others are just fine

  1. One website slow through Squid proxy, others are just fine

    Hi,

    We have a weird problem: Our Squid proxy works just fine, transferrates
    etc are normal, except when accessing one specific website. When
    opening that site through the proxy it takes about 2 minutes before the
    site is actually loaded completely, on a testing box with the proxy
    disabled and accessing it directly it takes about 15 seconds. Network
    settings on the proxyserver are the same as on the machine we used for
    testing. It only happens with this specific site (brainbox.usor.nl),
    all other sites are fine. The hostingprovider and owner of the site
    couldn't give us any clues or possible reasons for their site loading
    that slow...
    I'm kinda stuck here. Anyone good ideas on how to solve this?

    Thanks,

    Jasper


  2. Re: One website slow through Squid proxy, others are just fine

    I forgot to mention that we excluded this site from the cache. However,
    when it IS cachable it has the same symptoms.

    If you need more info, here are some entries from the access.log:

    1132918917.687 118 192.168.110.240 TCP_MISS/304 284 GET
    http://brainbox.usor.nl/ - DIRECT/195.169.138.121 text/plain
    1132918917.768 79 192.168.110.240 TCP_MISS/200 1799 GET
    http://brainbox.usor.nl/bin/entry_leftpanel.pl - DIRECT/195.169.138.121
    text/html
    1132918918.046 152 192.168.110.240 TCP_MISS/200 4119 GET
    http://brainbox.usor.nl/bin/entry_rightpanel.pl -
    DIRECT/195.169.138.121 text/html
    1132918918.398 106 192.168.110.240 TCP_MISS/304 225 GET
    http://brainbox.usor.nl/ui/styles/blackboard.css -
    DIRECT/195.169.138.121 -
    [....]
    1132918957.798 39501 192.168.110.240 TCP_MISS/304 224 GET
    http://brainbox.usor.nl/ui/styles/palette.css - DIRECT/195.169.138.121
    -
    [....]
    1132918977.446 59148 192.168.110.240 TCP_MISS/304 240 GET
    http://brainbox.usor.nl/images/spacer.gif - DIRECT/195.169.138.121
    text/plain


    The TCP_MISS is correct I guess since we're not caching this site. So
    it tries to get it directly, wich causes no problems as far as I can
    see except that it's taking real long for Squid to fetch even a 2kb GIF
    file...

    Anyone any suggestions?

    Jasper


  3. Re: One website slow through Squid proxy, others are just fine

    if you get an anwer please let me know, having the same issue..


    wrote in message
    news:1132923692.648706.238670@g49g2000cwa.googlegr oups.com...
    >I forgot to mention that we excluded this site from the cache. However,
    > when it IS cachable it has the same symptoms.
    >
    > If you need more info, here are some entries from the access.log:
    >
    > 1132918917.687 118 192.168.110.240 TCP_MISS/304 284 GET
    > http://brainbox.usor.nl/ - DIRECT/195.169.138.121 text/plain
    > 1132918917.768 79 192.168.110.240 TCP_MISS/200 1799 GET
    > http://brainbox.usor.nl/bin/entry_leftpanel.pl - DIRECT/195.169.138.121
    > text/html
    > 1132918918.046 152 192.168.110.240 TCP_MISS/200 4119 GET
    > http://brainbox.usor.nl/bin/entry_rightpanel.pl -
    > DIRECT/195.169.138.121 text/html
    > 1132918918.398 106 192.168.110.240 TCP_MISS/304 225 GET
    > http://brainbox.usor.nl/ui/styles/blackboard.css -
    > DIRECT/195.169.138.121 -
    > [....]
    > 1132918957.798 39501 192.168.110.240 TCP_MISS/304 224 GET
    > http://brainbox.usor.nl/ui/styles/palette.css - DIRECT/195.169.138.121
    > -
    > [....]
    > 1132918977.446 59148 192.168.110.240 TCP_MISS/304 240 GET
    > http://brainbox.usor.nl/images/spacer.gif - DIRECT/195.169.138.121
    > text/plain
    >
    >
    > The TCP_MISS is correct I guess since we're not caching this site. So
    > it tries to get it directly, wich causes no problems as far as I can
    > see except that it's taking real long for Squid to fetch even a 2kb GIF
    > file...
    >
    > Anyone any suggestions?
    >
    > Jasper
    >




+ Reply to Thread