Problems with Cisco 806 (12.3) proxy to squid. - squid

This is a discussion on Problems with Cisco 806 (12.3) proxy to squid. - squid ; Hi, I'm having problems getting my cisco 806 to proxy to squid. Here is the config: access-list 120 deny tcp any any neq www access-list 120 deny tcp host 192.168.23.26 any access-list 120 permit tcp any any route-map proxy-redirect permit ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Problems with Cisco 806 (12.3) proxy to squid.

  1. Problems with Cisco 806 (12.3) proxy to squid.

    Hi,

    I'm having problems getting my cisco 806 to proxy to squid.

    Here is the config:

    access-list 120 deny tcp any any neq www
    access-list 120 deny tcp host 192.168.23.26 any
    access-list 120 permit tcp any any

    route-map proxy-redirect permit 10
    match ip address 120
    set ip next-hop 192.168.23.26

    interface Ethernet0
    ip address 192.168.23.1 255.255.255.0
    ip nat inside
    no cdp enable
    hold-queue 32 in
    ip policy route-map proxy-redirect


    So, I am running squid on my mac (192.168.23.26) I'm running a tcp
    dump, but I can see no port 80 packets from the cisco, did I miss
    something?

    If I understand correctly with this config, anything on the
    192.168.23.x network that sends port 80/443 packets will get redirected
    to 192.168.23.26 which is listening on 80

    Squid workes, I can proxy through it if I set up my browser to use it,
    but it seems the cisco is not proxying the packets.


    sb


  2. Re: Problems with Cisco 806 (12.3) proxy to squid.

    access-list 120 deny tcp host 192.168.23.26 any

    route-map proxy-redirect permit 10
    > match ip address 120
    > set ip next-hop 192.168.23.26


    It's staring me in the face.. Your 806 is'nt stateful so it cant return the
    traffic.. and as its a route-map the line should read PERMIT..



    wrote in message
    news:1128129586.388446.9650@g44g2000cwa.googlegrou ps.com...
    > Hi,
    >
    > I'm having problems getting my cisco 806 to proxy to squid.
    >
    > Here is the config:
    >
    > access-list 120 deny tcp any any neq www
    > access-list 120 deny tcp host 192.168.23.26 any
    > access-list 120 permit tcp any any
    >
    > route-map proxy-redirect permit 10
    > match ip address 120
    > set ip next-hop 192.168.23.26
    >
    > interface Ethernet0
    > ip address 192.168.23.1 255.255.255.0
    > ip nat inside
    > no cdp enable
    > hold-queue 32 in
    > ip policy route-map proxy-redirect
    >
    >
    > So, I am running squid on my mac (192.168.23.26) I'm running a tcp
    > dump, but I can see no port 80 packets from the cisco, did I miss
    > something?
    >
    > If I understand correctly with this config, anything on the
    > 192.168.23.x network that sends port 80/443 packets will get redirected
    > to 192.168.23.26 which is listening on 80
    >
    > Squid workes, I can proxy through it if I set up my browser to use it,
    > but it seems the cisco is not proxying the packets.
    >
    >
    > sb
    >




+ Reply to Thread