IE under citrix with squid authentication problem - squid

This is a discussion on IE under citrix with squid authentication problem - squid ; Hi, I have successfully set up an authenticating proxy using NTLM with Squid 2.5STABLE7. This works transparently with MSIE run from the desktop but not when run from IE published through Citrix. The problem is that the Citrix-hosted IE does ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: IE under citrix with squid authentication problem

  1. IE under citrix with squid authentication problem

    Hi,

    I have successfully set up an authenticating proxy using NTLM with
    Squid 2.5STABLE7. This works transparently with MSIE run from the
    desktop but not when run from IE published through Citrix.

    The problem is that the Citrix-hosted IE does not present any
    credentials to Squid and if set to prompt for them no pop-box appears.
    I can see the TCP_DENIED messages in access.log.

    Does anyone know how to fix this?

    Steve.

  2. Re: IE under citrix with squid authentication problem

    On Wed, 12 Jan 2005 22:01:41 +0000, Steve Burton
    wrote:

    >Hi,
    >
    >I have successfully set up an authenticating proxy using NTLM with
    >Squid 2.5STABLE7. This works transparently with MSIE run from the
    >desktop but not when run from IE published through Citrix.
    >
    >The problem is that the Citrix-hosted IE does not present any
    >credentials to Squid and if set to prompt for them no pop-box appears.
    >I can see the TCP_DENIED messages in access.log.
    >
    >Does anyone know how to fix this?
    >
    >Steve.

    Sad to reply to one's own posts but....

    The Citrix thing seems to be a red herring. It seems that running MSIE
    6 on Windows Server 2003 is the cause. I still don't know the solution
    :-(

    Steve.


  3. Re: IE under citrix with squid authentication problem

    If your using Citrix, why not just setup a Security group of the users
    you want to access the net. Build GPO no-internte, add the citrix
    servers and security group into Security Filtering for the GPO and go.
    the policy should point to your proxy.

    Just my two cents.

    On Wed, 12 Jan 2005 22:01:41 +0000, Steve Burton
    wrote:

    >Hi,
    >
    >I have successfully set up an authenticating proxy using NTLM with
    >Squid 2.5STABLE7. This works transparently with MSIE run from the
    >desktop but not when run from IE published through Citrix.
    >
    >The problem is that the Citrix-hosted IE does not present any
    >credentials to Squid and if set to prompt for them no pop-box appears.
    >I can see the TCP_DENIED messages in access.log.
    >
    >Does anyone know how to fix this?
    >
    >Steve.


+ Reply to Thread